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1. Inspection of Freesurfer Output
In this exercise you will visualize and inspect correctly processed output data so that you can become
familiar with what the end product should look like. The exercise will take you through a variety of
output, but is not necessarily the recommended procedure to take when trying to verify each subject. Some
outputs are only necessary to check when there are problems or for a particular type of study. However it
is a good idea for new users to become familiar with what the expected output should look like and how to
view it. 

1.1. Preparations

1.1.1. If You’re at an Organized Course

If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 

1.1.2. If You’re not at an Organized Course

If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 



1.2. Viewing Volumes with Tkmedit
Output volumes can be loaded into tkmedit, along with surface outlines and the subcortical segmentation.
With one command line, you can load in the brainmask.mgz and wm.mgz volumes, the rh.white and
lh.white surfaces (outlines), and the subcortical segmentation. Copy and paste the command below inside
the terminal window: 

tkmedit good_output brainmask.mgz \
        -aux T1.mgz -surfs -aseg

Some notes on the above command line: 

good_output : name of subject 
brainmask.mgz : skull-stripped volume primarily used for troubleshooting (found in
$SUBJECTS_DIR/good_output/mri). 
-aux T1.mgz : pre-skull-stripped volume loaded as 2nd volume (in
$SUBJECTS_DIR/good_output/mri) 
-surfs : loads all surfaces (orig, white, and pial, for left and right hemispheres) 
-aseg : loads automatic volume segmentation called aseg.mgz 

You should see a tkmedit window open:

(use the zoom  and move  buttons to match the snapshot below)



You are currently looking at the brainmask.mgz with the surfaces displayed and the aseg.mgz (subcortical
segmentation) overlayed. The pial (red line), and white (yellow line) surfaces are shown. You can toggle
between the brainmask.mgz (loaded as the "main" volume) and the T1.mgz (loaded as the "auxiliary" or

2nd volume) with buttons  and  . As you switch between these two buttons, notice that at the top of
the display window, the asterisks (**) surround the name of the volume you are currently looking at. 

Keyboard Shortcut: Alt-c will allow you to quickly switch back and forth between the two volumes
instead of clicking between these buttons. 



If you hover your mouse over a button in the Tkmedit Tools window, a pop-up will tell you what it does

and its keyboard shortcut. When the Navigation button  is chosen, you can drag the brain around in the
display window. Try it out. Notice how you are not able to move around the cursor (the little red
cross-hair). 

To change the location of the cursor, choose any button to the right of the Navigation button and then
left-click in the display window. Notice the cursor move to wherever you click. When you zoom, it
will zoom into the location of the cursor. When you change brain orientation (to axial or sagittal),
you will be viewing the slice where the cursor was located in that plane. 

To change which brain slice you are viewing, you can use the + or - buttons next to where it says "Slice". 

Keyboard Shortcut: Use the Up or Down arrows on your keyboard to change slices faster (this will
only work when the Display window is selected and not on the Tools window). 

Now that you know the basics, you can make your way through the data. To verify that FreeSurfer did a
good job, you will want to check: 

1.  Whether the surfaces accurately follow the gray matter and white matter boundaries. 
2.  Whether the aseg accurately follows the subcortical intensity boundaries. 

1.2.1. Checking the Surfaces

Toggle to the brainmask volume, if not already in view, by using the  button or Alt-c. The white
surface (yellow line) is used to calculate total white matter volume and should accurately follow the
boundary between white matter and gray matter. The pial surface is used to calculate cortical gray matter
volume and should accurately follow the boundary between the gray matter and the CSF. 

Tip: It may be easier to concentrate on the surfaces if you toggle off the aseg with the  button. 

Keyboard Shortcut: Ctrl-g will also turn off the aseg. 

As you scroll through the slices checking the surfaces, keep in mind that you are looking at a
2-dimensional rendering of a 3-dimensional image - be sure to look at more than just one view (i.e.,

sagittal, coronal and horizontal). To check your surfaces, toggle them off and on with  for the pial

surface and  for the white surface. Would you draw the boundary in the same location? Adjust the
brightness and contrast so you can see the shift in intensity between gray and white. You can do this by
going to View > Configure > Brightness/Contrast in the Tkmedit Tools window and then moving the
sliders to adjust the levels. 



Keyboard Shortcuts: You can also use Ctrl-p and Cltr-m to turn on and off the pial and white
surfaces. 
If the Tkmedit Tools window is highlighted, Ctrl+b will open the Brightness/Contrast window.
Alternatively, you can hold down the shift button and drag the left mouse button in the display
window and this will change the brightness/contrast without using the sliders. 

There are regions where the surfaces are not intended to be accurate that you should be aware of: 

Areas around the hippocampus and amygdala. The surfaces will not completely include or exclude
certain subcortical regions. These inaccuracies can be ignored as subcortical regions are excluded
from the cortical measures and subcortical volume is measured by the aseg, not the surfaces. 

For an example of this, see coronal slice 137 (enter 137 into the box next to where it says "Slice"
and hit enter). 

Along the midline cut, it is possible to see some overlapping of the surfaces from one hemisphere to
another. The medial wall is not included in the cortical measures so this can generally be ignored. 

1.2.2. Subcortical Segmentation

Toggle on the subcortical segmentation with the  button or Ctrl-g. This will show the complete
segmentation of the subcortical structures. Each structure is labeled with a unique color/number
distinction. If you click on a voxel the structures name and number label will be shown in the Tkmedit
Tools window (under where it says "Cursor"). Toggle the aseg on and off to make sure the aseg is
accurately following the underlying intensity boundaries of each structure. Scrolling through the slices
you will be able to see that everything is labeled, and done so accurately. Sometimes it is easier to see the
structures and their boundaries looking in either the sagittal or horizontal view, so be sure to check around

in all of them. If you hold down the Ctrl button and left click on the  button, a window will pop up that
will allow you to adjust the segmentation opacity. 

1.2.3. Other Things To Do in Tkmedit

Below, we introduce you to other volumes and techniques which are good to be familiar with, especially
when troubleshooting. 

1.2.3.1. Aparc+Aseg segmentation

To load the aparc+aseg segmentation you can go to File > Load Segmentation and browse to the 
aparc+aseg.mgz . Hit OK once you have selected the file and then OK again in the Load
Segmentation window. When loaded, it will look like this: 



This segmentation shows the same subcortical structures that are labeled in the aseg.mgz, but also displays
the cortical parcellation labels in the volume (later we will look at the labels on the surface). Click around
the cortex to see the name of each cortical region in the Tools window. The aparc+aseg.mgz uses the
Desikan-Killiany atlas. To see the Destrieux atlas, you would load the aparc.a2009s+aseg.mgz 

1.2.3.2. Skull Strip

Turn off the segmentation (Ctrl-g) and scroll through the brainmask volume. Notice that there is no skull
left in your image. Notice also that the cerebellum is still included in the volume. You should not see any
large areas of skull left behind, or any areas of cortex or cerebellum removed from this volume. You can
toggle between the brainmask.mgz volume and the non-skull-stripped, T1.mgz volume using Alt-c to
ensure that the skullstrip has worked properly. In the TroubleshootingData tutorial, we’ll go over what to
do if there was a skull strip error. 



1.2.3.3. Intensity Normalization

Scroll through the brainmask volume and notice that the intensity is all uniform. You should not see any
very bright or very dark spots in the white matter or gray matter. If you click on a voxel in the white
matter, you can see that it has been normalized to an intensity of (or very close to) 110 in the Tkmedit
Tools Window (under Cursor, next to where it says "brainmask.mgz val"). When wm voxels are not close
to 110, they may be erroneously excluded from the white surface. In the TroubleshootingData tutorial,
we’ll go over what to do if there was an intensity normalization error. 

1.2.3.4. WM Volume

To check the wm volume you should load it in as a new aux volume. To do this go to File > Aux Volume
> Load Aux Volume and browse to wm.mgz. This should open: 



This volume is FreeSurfer’s initial segmentation of the white matter (shown in shades of gray) with
additions from the automatic topology fixer (in white). This "mask" is the starting point for the white
surface which grows out from here and stops at a more accurate location along the wm/gm boundary using
the intensity gradients in the brainmask.mgz volume as a guide. The wm.mgz can be used to add missing
wm voxels or delete voxels that are not wm but were included in the surface. In the TroubleshootingData
tutorial, we’ll go over what to do if there was a wm segmentation error. 

You can now close Tkmedit by hitting the X on the display window. You can also use Ctrl-q to close it. 

1.3. Viewing Surfaces with Tksurfer
Now that you’ve checked out everything in the volume using tkmedit, you can close it and begin to inspect
your data on the surface. For this, you will use tksurfer. Tksurfer displays one hemisphere at a time. This
exercise will go through visualizing things on the left hemisphere only, but everything works the same on
the right hemisphere (except in the Tksurfer command, you would specify rh instead of lh). 

Here are the things you can look at with tksurfer: 

pial, white and inflated surface 
sulc and curv curvature files 
thickness maps 
cortical parcellation 

To open Tksurfer with the left hemisphere inflated surface of your subject, open a new terminal window,
then use the following command: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR
tksurfer good_output lh inflated

You should see a Tksurfer window open up to this: 



You are currently looking at the inflated surface. The surface can be rotated using the buttons in the

navigation toolbar:  . Use the redraw button  to repaint the image if it gets
corrupted by window movement. 

Mouse Shortcut: Right click in the Tksurfer window to redraw. 



Inflated surface 

The inflated surface is good to look at when checking to see if you need to make edits to the wm.mgz
volume. You’ll notice as you inspect this surface that it is smooth and free from holes, bumps and other
defects. If you click on the surface, you will see the coordinates of the vertex you clicked on in the Tools
window under "Cursor". To clear the marks made on the surface after clicking on it, you can go to Edit >
Unmark All Vertices. 

Keyboard Shortcut: You can unmark one vertex at a time by using Ctrl+Shift+middle click on each. 
Troubleshooting Tip: If at any point clicking in the Tksurfer window automatically causes you to
zoom in, your Ctrl key is stuck. Trying hitting the Ctrl button a few times to get it unstuck. 

Pial Surface 

All surfaces (pial, white, orig) have been loaded as a default along with the inflated surface. You can

switch to the pial surface by clicking the  button. You should see this: 



The pial surface is showing you the outer boundary between the gray matter and CSF (cerebrospinal
fluid). This is the same file that was viewed in Tkmedit, just represented as a 3D surface image rather than
the red outline on the 2D slices in the brainmask volume. You can inspect this surface by rotating it
around as you wish. 

White Surface 



Click on the  button to view the white surface. This is what the white surface will look like: 

The white surface shows the boundary between the white and the gray matter. Again, this is the same file
that was viewed in Tkmedit (as the yellow outline) just represented in a 3D manner. You can inspect this
surface by rotating it around as you wish. 



Curv and Sulc Files 

Switch back to viewing the inflated surface of the brain by pushing the  button. You can now load in

the curvature file, lh.curv, by holding Ctrl and right clicking on the  button on the Tksurfer Tools
window. The box that pops up will automatically have selected the lh.curv file, so click ok. The curvature
file will look like this: 



This is showing the slightly smoothed mean curvature. It has the units of 1/mm, and with an outward
pointing normal vector field. Negative regions are folded-out and shown in green (gyral), and positive
regions are folded-in and shown in red (sulcal) 

To view the sulc file you could have changed the dialog box to say lh.sulc when right clicking on the curv
button as described above, or you can go to File > Curvature > Load Curvature and browse to the 
lh.sulc file  (found in 
$TUTORIAL_DATA/buckner_data/tutorial_subjs/good_output/surf/ ). Be sure you
select the curvature file for the correct hemisphere, if you select the wrong one it will not look right. The
lh.sulc file will load a slightly different display of green/red values than the lh.curv. These are showing the
sulcal depth and again here the red regions are sulcal and the green regions are gyral. You can still view

this overlay as you switch to the pial or white surfaces using the  and  buttons. 

Thickness Maps 

To view the thickness maps it is probably best to toggle off the curvature  . You can load the thickness

map, lh.thickness, by holding Ctrl and right clicking  on the Tksurfer Tools window. Browse to the
lh.thickness file (you may have to find the subject "good_output" from the list of subjects, then navigate to
the surf  directory and select lh.thickness ). Be sure you select the thickness file for the correct
hemisphere, if you select the wrong one it will not look right. The lh.thickness map should open up and
look like this: 



You can adjust the thresholds of the map by going to View > Configure > Overlay which will open a new
window that will allow you to change the thresholds. First click the Thresholds: Linear checkbox. Then
try some different settings and see how it affects the display on the map (try a Min of 1.0 and Max of 3.0,
Min of 2 and Max of 5, etc). After you change the min and max values be sure to hit Apply to see the
changes. If the Apply button is not visible to you, hit the space bar to Apply the changes. 

Cortical Parcellations 



To view the cortical parcellation it is probably best to toggle off the curvature  and thickness files  

(if any are still visible), and to switch to the pial surface,  . You can load the parcellation by going to 
File > Label > Import Annotation and browsing to the lh.aparc.annot file  (found in 
$TUTORIAL_DATA/buckner_data/tutorial_subjs/good_output/label/ ). Be sure you
select the label file for the correct hemisphere, if you select the wrong one it will not look right. The
lh.aparc.annot should open up and like this: 



Click on a color and view the name of the cortical region in the Tksurfer Tools box. Rotate the brain so
you are looking at the medial wall. Notice that all subcortical gray matter is not a part of the surface labels
(because again, those areas do not count towards the cortical surface measures). You can also switch to the

inflated view and turn the labels to outlines using the  button. 

The parcellation that is loaded here was created with the Desikan-Killiany atlas. By default there are two
parcellations that are made when recon-all is run. The second parcellation, called ?h.aparc.a2009s.annot, is
created with the Destrieux atlas. The difference is the number and designation of the areas that are labeled.
You can load this second parcellation by first going to File -> Label -> Delete all Labels. This will
remove the first parcellation. Then you can repeat the steps for loading a parcellation, this time browsing
to lh.aparc.a2009s.annot to load the second parcellation. 

1.4. Using Tkmedit and Tksurfer together
When you are viewing the same subject in Tkmedit and Tksurfer at the same time you can click on a point
on the surface (in tksurfer) and automatically locate the same point in the volume (in tkmedit). To do this,
first open a new terminal window so you can open up the same subject in Tkmedit as you have open in
Tksurfer: 

tkmedit good_output brainmask.mgz \
        -aux T1.mgz -surfs -aseg

Click on a location in Tksurfer. Next, click the save point button  in the Tksurfer Tools window. This

will save the cursor position. Then, in the Tkmedit Tools window, click the "goto saved point" button  
. This will now bring you to the same point, only in the volume. Look for the new location of the cursor in
Tkmedit. If you are having trouble finding it, the red lines on the edges of the Tkmedit display window
will indicate which row and column it is located within. You can also click on a point in Tkmedit, save it

using the  button and opening the same point in Tksurfer using the  button. 

This technique is very useful when you see something wrong on the surface of a subject (in Tksurfer) and
you want to see what is happening in the volume in that same place and vice versa. 

When you are done, you can close Tksurfer by going to File > Quit. You can close Tkmedit by hitting the 
X on the display window or going to File > Quit . You can also do Ctrl-q to quit for both. 

This tutorial was meant as an introduction to Tkmedit and Tksurfer. For information on buttons or menu
options not covered here, you can find out about them on the Freesurfer Tools wiki. 
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1. Troubleshooting your output
This set of exercises will take you through a few examples of problem outputs, asking you to identify the
problems and possible methods to fix the problems. Each example will have a before and after picture, as
well as an explanation of how to fix the problems seen. 

Contents

1.  Troubleshooting your output
1.  Preparations

1.  If You’re at an Organized Course
2.  If You’re not at an Organized Course

2.  Failure Modes
1.  Edits to the brainmask volume
2.  Edits to the wm volume
3.  Correcting topological defects
4.  Skull strip
5.  Adding control points
6.  Talairach transformation
7.  Editing the Aseg

1.1. Preparations

1.1.1. If You’re at an Organized Course

If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 



1.1.2. If You’re not at an Organized Course

If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 

1.2. Failure Modes
Below, we ask you to look at several subjects with various errors that require manual intervention. Open
each subject and try to identify the problem on your own. For each subject, there is a link to instructions
on how to fix the problem. While you are trying to identify the problems with the subjects listed below
you may find it helpful to refer back to the previous exercise, or open your own instance of the subject
good_output to compare these subjects to a good example. 

1.2.1. Edits to the brainmask volume

Open the subject, pial_edits_before. 

tkmedit pial_edits_before brainmask.mgz -aux T1.mgz -surfs

The command above will open the brainmask.mgz volume, the T1.mgz loaded as aux, and the surfaces for
both hemispheres. (You can feel free to open other volumes in aux or to load in the aseg.mgz if you want
or need to.) Scroll through the slices of this subject to check the pial and white surfaces for accuracy,
making sure they follow the actual gray/white boundaries and that they do not include anything that
should not be included. 

If you would like to see the inflated surfaces for each hemisphere of this subject, open a second and third
terminal window, then open the surfaces in tksurfer: 

tksurfer pial_edits_before lh inflated

tksurfer pial_edits_before rh inflated

Once you have identified the problem (or have given up!), click here for detailed instructions on how you
can fix it. 



1.2.2. Edits to the wm volume

Now, take a look at the next subject, wm1_edits_before. 

tkmedit wm1_edits_before brainmask.mgz -aux T1.mgz -surfs

Again, this will bring up the brainmask.mgz volume, the T1.mgz volume, and the surfaces for both
hemispheres. 

In your second and third terminal window, if not already open, open the surfaces in tksurfer: 

tksurfer wm1_edits_before lh inflated

tksurfer wm1_edits_before rh inflated

This will open the inflated surfaces for both hemispheres in tksurfer. 

The trouble with this subject has occurred during the white matter segmentation step. Check the surfaces
in the T1 volume to find the spot that does not match the actual gray/white boundary. If you load the
wm.mgz volume as the aux volume you will see a hole in this area. If you are looking in tksurfer you will
see a hole or dimple in the inflated surface. You can use the "save point" "goto point" commands to find
this spot in the volume. 

Click here for detailed instructions on how you can fix it. You can also compare the original data to a
corrected and rerun version, wm1_edits_after. 

To view this corrected subject (which was corrected by following the detailed instructions provided to
you): 

tkmedit wm1_edits_after brainmask.mgz -aux wm.mgz -surfs

1.2.3. Correcting topological defects

Open the subject, topo_defect_before, in tkmedit. 

tkmedit topo_defect_before brainmask.mgz -aux wm.mgz -surfs

This will open the brainmask.mgz volume, the wm.mgz loaded as aux, and the surfaces for both
hemispheres. 

Take a look at this subject, inspecting the various outputs that were mentioned in the previous exercise and
see if you can identify what is wrong. 

Hint: It’s a very small error in the posterior part of the brain. 

Once you spot the error, click here for detailed instructions on how you can fix it. After you have fixed it,
you can compare the original data to the a corrected and rerun version, topo_defect_after. To view this
corrected subject: 



tkmedit topo_defect_after brainmask.mgz -aux wm.mgz -surfs

1.2.4. Skull strip

Now, take a look at the next subject, skullstrip1_before, in tkmedit. 

tkmedit skullstrip1_before brainmask.mgz -aux T1.mgz -surfs

This will open the brainmask.mgz volume, the T1.mgz loaded as aux, and the surfaces for both
hemispheres. 

The trouble with this subject has occurred in the skull stripping step. Check the brainmask.mgz volume
carefully, comparing it to the T1.mgz volume (loaded in aux) to make sure that the skull has been
completely stripped away, leaving behind the complete cortex and the cerebellum. 

You can feel free to open other volumes in aux or to load in the aseg.mgz if you want or need to. 

Click here for detailed instructions on how you can fix it. You can also compare this to the finished
version, skullstrip1_after. 

1.2.5. Adding control points

Now, take a look at the next subject, cp_before. 

tkmedit cp_before brainmask.mgz -aux T1.mgz -surfs

Again, this will bring up the brainmask.mgz volume, the T1.mgz volume, and the surfaces for both
hemispheres. 

In your second terminal window, if not already open, open the surfaces in tksurfer: 

tksurfer cp_before lh inflated &
tksurfer cp_before rh inflated &

This will open the inflated surfaces for both hemispheres in tksurfer. 

The trouble with this subject has occured during the intensity normalization. Check the white surface and
be sure it is including all of the white matter as it should. If you find an area that is not included as white
matter be sure to check to see that the intensity is at (or very close to) 110. 

You may need to open other volumes in order to see or fix the problem. 

Click here for detailed instructions on how you can fix it. 



1.2.6. Talairach transformation

Now, take a look at the next subject, tal_before. 

tkmedit tal_before brainmask.mgz -aux T1.mgz -surfs

Again, this will bring up the brainmask.mgz volume and the T1.mgz volume and the surfaces for both
hemispheres. 

In a second and third terminal window, if not already open, open the surfaces in tksurfer: 

tksurfer tal_before lh inflated

tksurfer tal_before rh inflated

This will open the inflated surfaces for both hemispheres in tksurfer. 

The trouble with this subject is a little tricky to figure out. The midline cutting planes are not actually on
the midline, but the real root of this problem is in one of the very initial steps of recon-all. The talairach
transform is bad and will need to be fixed. 

You may need to open other volumes in order to see or fix the problem. 

Click here for detailed instructions on how you can fix it. 

1.2.7. Editing the Aseg

We generally advise against editing the aseg.mgz unless absolutely necessary. Try using an xopts script
first to change the intensity thresholds being used. Editing the aseg will add more variance to your data.
Instructions on how to edit the aseg are here. 
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1. Correcting topological defects

To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

Sometimes, the topological fixer fails which leads the white matter (WM) surface (yellow line) to exclude
some voxels that are white matter. Simple edits to wm.mgz volume can correct this defect. 

1.1. Editing the Volume
Subject topo_defect_before is an example of topological defect and this page will walk you through fixing
it. 

Open topo_defect_before in tkmedit. 

tkmedit topo_defect_before brainmask.mgz -aux wm.mgz -surfs

Use the arrow keys to scroll through the volume to find the error in white matter surface. If you look at
coronal slice 57, there is a defect in the left hemisphere closer to the midline, where some white matter
voxels are segmented incorrectly. This type of topological defect is called a ’hole’ which needs to be filled
as opposed to a handle which needs to be cut. 



As you can see in wm.mgz, some white matter voxels are excluded from the white matter surface. 



To view the defect in the surface viewer, first open another terminal: 

tcsh

and then open the surface viewer: 

tksurfer topo_defect_before lh smoothwm.nofix

Below are couple of images of lh.smooth.nofix loaded in tksurfer and zoomed in image of lh.smooth.nofix
with Wireframe Overlay turned on (View --> Wireframe Overlay), respectively. You can see the error as
pointed by the yellow arrow, which is a hole that needs to be filled to correct this type of topological
defect. 





Now back to the tkmedit display, if you scroll through slice by slice, you’ll notice that there is a small
group of white matter voxels which disconnect and connect back again after a few slices. The white matter
surface doesn’t include these voxels when they are disconnected. 

This area is too thin to add control points to extend the WM surface. You’ll need to add some white
matter voxels to fix this error. But first scroll through the slices in the brainmask.mgz volume and make
a note of where the white surface is just beginning to exclude voxels and where the problem ends. In this
case, the problem starts at coronal slice 53 and goes on upto slice 60. 



To begin editing, click on the Edit Voxels Tool button on the tkmedit tool bar, then go to Tools -->
Configure Brush Info... Since wm.mgz is loaded as aux volume, select Aux volume as the Target. Use
the middle mouse button to begin painting in the voxels. Use the right mouse button to delete voxels. 

Start adding the voxels to wm.mgz volume on coronal slice 53. Toggle between the brainmask.mgz and
wm.mgz using Ctrl-1 and Ctrl-2. Use brainmask.mgz as a guide while painting. Only add as many voxels
as is needed to correct the error. Switch between the coronal, sagittal and horizontal views to check if you
need to add more for the white matter to be labelled correctly. With more practice, it becomes easier to
decide where to add voxels to correct the defect. 

At any time, you can save the changes you’ve made to the wm volume by selecting ’Save Aux Volume’ in 
tkmedit’s ’File’ menu, and clicking ’OK’ 

You can look at wm.mgz volume of topo_defect_after to compare your edits with the tutorial data. 

Coronal slice 57 in brainmask.mgz looks like this after correction. 



1.2. Regenerating the Surface
Once you have made all the edits to the wm.mgz volume, you can run the following command to
regenerate the surfaces: 

recon-all -autorecon2-wm -autorecon3 -subjid topo_defect_before

Do not run this command if you are conducting the tutorial! 
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1. Making Edits to the White Matter

To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

Sometimes the white matter is not segmented correctly: sometimes voxels that should be white matter are
excluded, and other times voxels that should not be white matter are included in error. Either of these
occurences can be fixed with simple manual edits. Below you will find examples of a few of the common
problems and how to fix them. For some people it is easiest to see these problems when looking at the
inflated surface in tksurfer. Others can pick them out while viewing the volumes in tkmedit. Either method
is fine for identifying these problems. However they can only be fixed using tkmedit with the wm.mgz
volume. 

1.1. Geometric inaccuracy due to brain lesion
wm1_edits_before is an example of white matter being excluded from the wm.mgz volume due to the
presence of a brain lesion. This page will walk you through fixing this specific example as well as other
common problems with the wm.mgz volume. 

First, make sure you have wm1_edits_before loaded in tkmedit: 

tkmedit wm1_edits_before brainmask.mgz -aux wm.mgz -surfs

If you look at coronal slice 160 you will notice an area on the right hemisphere where the white surface
(yellow line) does not follow the surface of the brain, but in fact cuts into it. This geometric inaccuracy is
caused by a lesion where white matter has been marked as non-white matter. 



You can see this as a dimple or hole on the inflated surface in tksurfer too (see next image). If not already
open, in a second terminal window, open the rh surface in tksurfer and you can see the dimple or hole on
the medial side: 

tksurfer wm1_edits_before rh inflated



With the wm.mgz volume loaded into tkmedit you can see that this area has been left out of the wm
volume completely. 



To fix this problem you will need to fill in the missing voxels in the wm.mgz volume. First, it’s a good
idea to use the arrow keys to scroll through the individual slices in the volume until you get a good idea of
where the problem starts and ends. You will want to start filling in voxels when the inaccuracy appears,
and keep filling them in slice by slice until the problem is no longer visible. The coronal view and a brush
radius of one or two are good settings for painting in voxels. Zoom In and Out either by using the icons in
the tkmedit Tool window or by Ctrl-right mouse button (Zoom In) and Ctrl-left mouse button (Zoom Out)
to help you see the inaccuracy. 

To begin editing voxels, click on the Edit Voxels Tool button  , then go to Tools --> Configure
Brush Info... Set the radius to 2 and Shape to be Circle. By default tkmedit will edit on the main volume
loaded, if the wm volume is loaded as your aux volume you will also need to select Aux volume as the 
Target. Use the middle button on your mouse to begin painting in the voxels. If you fill in too many
voxels, the right mouse button acts as an eraser. When you are done filling the region, slice 160 should
look like this: 



While filling the hole in slice 160, you will notice that the hole is not completely enclosed. To see where
the boundary should be, switch back and forth between the brainmask.mgz and wm.mgz volume with
Ctrl-1 and Ctrl-2. Use the brainmask.mgz volume as a guide, and make the boundary of the voxels that
you paint in correspond as closely as possible to the boundaries suggested in the brain volume. Go to the
next slice, and fill in this slice in the same way. You will need to continue filling in slices in this fashion
until the region is completely filled in. If you would like to compare your edits to ones that have been
done for you you can open a second tkmedit with the wm1_edits_after wm.mgz volume, and for each slice
check your results with the corresponding slice in the wm1_edits_after volume. At any time, you can save
the changes you’ve made to the wm volume by selecting ’Save Volume’ in tkmedit’s ’File’ menu, and
clicking ’OK’. You can verify your results by viewing the changes made to the wm1_edits_after wm.mgz
volume 



Tips:

Sometimes regions may appear enclosed in some slices (i.e. appear as holes), open in subsequent
slices (i.e. no longer appear as holes), then enclosed again as you scroll forward. The rule of thumb
when editing these is to keep filling until you reach the slice where they finally open up and are no
longer enclosed. 
When editing geometric inaccuracies in the future, you may find it easier to edit the first slice and last
slice first, thereby ’capping’ the slices that need filling. Then you just need to fill all the slices
between the endcaps. 
Sometimes there is variation between a subject’s left and right hemispheres, so that in a particular
slice one hemisphere’s region will finally ’open up’, but the other hemisphere’s region is still
enclosed. In such cases, continue to fill the enclosed region only, even though the other is open. This
will address the topological problem. 
Problems like the one shown here, due to brain lesions, should always be fixed with edits to the
wm.mgz volume. Do not use control points to try and automatically adjust the intensity in these
areas. 

After you have saved all of your edits, you could recreate the final surfaces with the command: 

recon-all -autorecon2-wm -subjid wm1_edits_before

Do not run this command if you are conducting the tutorial! This step will take a long time and there
is no need to run it for the tutorial purposes. 

1.2. Non-white matter classified as white matter
Sometimes non-white matter (i.e., skull) is included as white matter. To load in the example use this
command: 

tkmedit wm2_edits_before wm.mgz -aux brainmask.mgz -surfs

Scroll through the brainmask.mgz volume slices and as you go posterior you will see a group of voxels
included as white matter, around slice 152. They are surrounded by the white surface (yellow line). This
group lies outside of the pial surface (red line) and is clearly not white matter. In order to correct this
inaccuracy it is necessary to delete the voxels which are not part of the white matter. 





Using Ctrl-1 and Ctrl-2 to switch back and forth between the brain and wm volumes, you can clearly see
that this region should not be labeled as white matter. To delete these voxels, click the Edit Voxels Tool 

 button in the tkmedit toolbar, and put your mouse cursor over the voxels you want to delete. Delete
them with the right mouse button. This is what slice 152 should look like after you have deleted the errant
voxels: 



Go through the slices with the up and down arrows, continuing to delete voxels until the inaccuracy is no
longer there. (It spans approximately 30 slices.) You can check your results by looking at the
wm2_edits_after wm.mgz volume in tkmedit. Note that in this volume, only a few of the voxels have been
removed from each slice, instead of removing the entire inaccuracy. This is because you only need to
remove as many voxels as is necessary for the segmentation to classify this region as non-white matter.
Until you are more comfortable with editing inaccuracies, go ahead and remove all of the voxels. More
practice will give you a better feel for how many voxels need to be removed. 

Once you have made all the edits to the wm.mgz volume you would regenerate the surfaces using the
following command: 

recon-all -autorecon2-wm -autorecon3 -subjid wm2_edits_before



Do not run this command if you are conducting the tutorial! This step will take a long time and there
is no need to run it for the tutorial purposes. 

1.3. Lateral Ventricle
The automatic edits made to to wm volume will fill the lateral ventricles. On occasion they are not filled
entirely. Open wm3_edits_before in tkmedit. 

tkmedit wm3_edits_before wm.mgz -aux brainmask.mgz -surfs

As you scroll to the posterior portions of the brainmask.mgz you will see the white surface (yellow line)
start to follow the edge of the ventricle (look around coronal slice 53). 



When you toggle between wm and the brain volume, you can see that this portion of the ventricle should
be filled in. This inaccuracy can be corrected in the same fashion as the inaccuracies above, using the Edit
Voxels tool to fill in the missing voxels. 

When you are finished filling in slice 53, it should look like this: 



Continue filling in this region until the hole disappears. The geometric inaccuracy is present from slices 50
through 168. Once you have fully edited the wm.mgz volume you would regenerate the surfaces with the
following command: 

recon-all -autorecon2-wm -autorecon3 -subjid wm3_edits_before

Do not run this command if you are conducting the tutorial! This step will take a long time and there
is no need to run it for the tutorial purposes. 
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1. Correcting Pial Surfaces

To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

The pial surface is created by expanding the white matter surface so that it closely follows the gray-CSF
intensity gradient as found in the brainmask.mgz volume. Once an accurate white surface is created then
you can work on correcting the pial surface if needed. The pial surface boundary and white matter surface
boundary should not cross. After the pial surface has been generated, it’s a good idea to visually check it
for defects that may have been created during automatic topology fixing. To check the pial surface, it may
be loaded into tkmedit and viewed along with the brainmask.mgz volume. If the surface appears not to
follow the gray-CSF boundary in the volume, edits may be required. 

1.1. Editing the Volume
Subject pial_edits_before is an example of the pial surface including non-cortex within the boundaries.
This page will take you through fixing this and other similar problems with the pial surface including
non-cortex material. 

First, make sure you have pial_edits_before loaded in tkmedit: 

tkmedit pial_edits_before brainmask.mgz -surfs

Use the arrow keys to go through the volume slice by slice, and view the pial surface (red line) and white
matter surface (yellow line). Notice the bright diagonal line in slice 157 that has caused the pial surface to
expand past the actual pial boundary. This is the result of a bad segmentation incorporating a piece of the
dura within the pial surface. 



To fix this type of error you can simply edit away the offending voxels from the brainmask.mgz volume.
To do this you will need to select the edit voxels tool and set the brush to a size and shape comfortable for
you. A circle brush of radius 2 works well for this edit. In the tkmedit toolbar, go to Tools -> Configure
Brush Info... Set Radius to 2, and Shape to "Circle". Close the configuration menu, and click the "Edit
Voxels" button in tkmedit toolbar. 

Find a place in the image where the dura is causing errors in the segmentation. Use the right mouse button
to delete the voxels. It is not necessary to completely remove the dura to get an adequate pial surface, but
it is good to do so until you are more familiar with manual editing. When you are finished removing the
bright diagonal line in slice 157, it should look like this: 



Continue on the other slices until the dura is removed. 

Ctrl-z and Edit -> Undo Last Edit in tkmedit only allow you to go back one edit. If you remove too many
voxels, you can use the clone tool to paint areas back in from the original T1 volume. Load T1 as aux
volume. To paint voxels, go to Tools -> Configure Volume Brush... , in the tkmedit toolbar. 

Set Mode to "Clone", and Clone Source to "Aux Volume". To change the size and shape of your brush, go
to: 

Tools -> Configure Brush Info... 

Select a radius and shape of the brush. Click the "Edit Voxels" button in tkmedit toolbar and use the
middle button on the mouse to paint in voxels from the auxiliary volume 



At any time, you can save the changes you’ve made to the brainmask.mgz volume by selecting ’Save
Volume’ in tkmedit’s ’File’ menu, and clicking ’OK’ 

You can check your result by viewing the brainmask.mgz volume in the pial_edits_after directory. 

1.2. Regenerating the Surface
When you are finished editing the voxels, you will need to regenerate the surfaces. Since the white matter
hasn’t been changed, you don’t need to resegment the volume. You can regenerate the pial surface with: 

recon-all -autorecon-pial -subjid pial_edits_before

Do not run this command if you are conducting the tutorial! This step will take a long time and there
is no need to run it for the tutorial purposes. 

1.3. Edits to correct pial surface extension into cerebellum
The brain.finalsurfs.manedit.mgz volume will allow for the correction of a particular type of problem
involving pial surface misplacement whereby parts of the pial surface have extended into the cerebellum
in certain areas. It is only in this case where the pial surface extends into cerebellum where the
brain.finalsurfs.manedit.mgz volume should be edited. For all other non-cerebellum pial surface problems,
brainmask.mgz should be edited. This cerebellum / pial surface problem can be fixed by removing those
cerebellum voxels and other surrounding problematic voxels in the brain.finalsurfs.manedit.mgz volume
such that upon running recon-all, the pial surface will be pulled in as desired, bordering only gray matter/
CSF boundary, and not jutting into the cerebellum. If only edits to this volume are made on a subject, it is
sufficient to re-run recon-all from the point of these edits using the flag -autorecon3-pial. Note that you
must create brain.finalsurfs.manedit.mgz by copying it from brain.finalsurfs.mgz: 

cd <subjid>/mri
cp brain.finalsurfs.mgz brain.finalsurfs.manedit.mgz

You do not need to do this for this tutorial. If you’re interested, please refer to the brain.finalsurfs section
on the Longitudinal Tutorial here. 
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1. Fixing a bad skull strip

To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

Occasionally, the skull stripping step either removes more than just the skull, causing part of the brain to
be removed as well, or too little, leaving behind portions of the skull. Both of these problems need to be
corrected before continuing to the next step, either by manually editing the volumes or by adjusting input
parameters to the skull stripping step, and running the skull strip again until a good result is obtained.
Often the sagittal view reveals skull strip failures. Note that the inflated 2D surface is a less reliable gauge
of skull strip failure unless large portions of the brain are missing, or lots of skull is retained. 

skullstrip1_before has a poor skull strip, an entire hemisphere of the cerebellum has been stripped away
along with the skull. This page will walk you through the process of fixing this particular subject and also
offer suggestions for fixing other common skull stripping problems. 

If you look at coronal slice 91 for skullstrip1_before you can see that the brainmask.mgz volume (the first
picture) is missing the right hemisphere of the cerebellum and that it is present in the T1.mgz volume (the
second picture): 





In general there are two ways to fix a volume when there is something missing from the cortex or
cerebellum, you can clone the missing pieces in manually or you can adjust the parameters of
mri_watershed to do it automatically. For this case, because there is such a lot missing on so many slices
you should adjust the parameters of mri_watershed. 

1.1. Adjusting watershed parameters
The watershed algorithm is used during the skull stripping step to find a boundary between the brain and
skull. The mri_watershed program uses a default preflooding height of 25 percent. If we want the
algorithm to be more conservative (i.e. if part of the brain has been removed), you will want to make that
number larger than 25. If you want the algorithm to be more aggressive (i.e. part of the skull has been left
behind), you will want to make the height less than 25. There aren’t any hard and fast rules about how to
select your height value. You can adjust the preflooding height by passing the following flag to recon-all: 



recon-all -skullstrip -wsthresh <h> -clean-bm -subjid <subject name>
where <h> is replaced with the preflooding height you’d like to use and <subject name> is replaced with
your subject. The clean-bm flag is used to instruct recon-all to write over the old brainmask.mgz volume
with your new edits. If you do not use this flag your changes will not take effect. 

Part of the brain is missing
Now we will take another look at the first volume we looked at, where part of the cerebellum had been
removed. If you suspect that certain anatomy could be an outlier, and may be responsible for making the
skullstripping step fail or produce poor results then you can try using the -no-wsgcaatlas flag (wsgcaatlas
= with skull gaussian classifier array atlas). You can adjust the watershed threshold by passing the
-wsthresh flag to recon-all. In this instance, since too much was removed, we want to raise the watershed
threshold so use the command: 

recon-all -skullstrip -wsthresh 35 -clean-bm -no-wsgcaatlas -subjid skullstrip1_before

Take a look at your output volume (brainmask.mgz has been changed) along with the original T1 volume
(T1.mgz), and verify the result of the new skull stripping is correct. 

tkmedit skullstrip1_before brainmask.mgz -aux T1.mgz -surfs

It should look like this: 



Some skull still remains 
Sometimes the skull strip will leave pieces of skull in the brainmask volume. Subject skullstrip2_before is
an extreme example of this, it can be the case that there is just a bit of skull left. If that is the case with a
subject in your own dataset you may want to try running recon-all -skullstrip first to see if that fixes the
problem before trying the steps outlined below. If you are working with the tutorial data than you should
proceed with the example commands below, do not run recon-all -skullstrip. Open skullstrip2_before to
see what it looks like: 

tkmedit skullstrip2_before brainmask.mgz



and you should see this:

For this example, since there is so much skull remaining, we want to lower the watershed threshold, so
you could use the command: 

recon-all -skullstrip -wsthresh 5 -clean-bm -no-wsgcaatlas -subjid skullstrip2_before

Take a look at your output volume (brainmask.mgz has been changed) along with the original T1 volume
(T1.mgz), and verify the result of the new skull stripping is correct. 



tkmedit skullstrip2_before brainmask.mgz -aux T1.mgz -surfs

You can compare this to the brain volume in skullstrip2_after to see that your changes look the same. 

Reprocessing the data 
If you make changes to the brainmask.mgz volume, you can re-start the recon-all process from this point
by using the following command: 

recon-all -autorecon2 -autorecon3 -subjid <subject name>

Trying Several Thresholds 
If you would like to quickly run several different watershed thresholds simultaneously, you can use the
-multistrip flag which will create several orig, T1, and nu volumes stripped with the following preflood
heights: 5, 10, 20, 30. 

You can change which preflood heights it uses (instead of 5, 10, 20, 30) by first doing: 

setenv SUBJECTS_DIR /path/to/your/data
setenv WATERSHED_PREFLOOD_HEIGHTS ’20 30 40 50’
recon-all -multistrip -clean-bm -s <subjid> -no-isrunning

Note that it will launch mri_watershed for each one for each vol orig, nu and T1, so if you have 12
heights, for example there will be 36 processes. 

1.2. Using gcut
When the skull stripping has left a small part of dura left, it is quicker to try and rerun the skullstrip step
using the -gcut flag than to do manual editing. This flag removes any extra dura that could influence the
surfaces. 

recon-all -skullstrip -clean-bm -gcut -subjid <subjid>

INFO: Care must be taken to thoroughly inspect your data when using -gcut. In particular, inpsect the
edges of gm and cerebellum for over-aggressive cutting. Add -segmentation brainmask.gcuts.mgz to
tkmedit to view the voxels which gcut has removed. We recommend viewing the brainmask.gcuts.mgz
overlayed on the T1.mgz to clearly see which voxels have been removed by gcut. 







1.3. Use talairach_with_skull_2.lta
During the skull-strip stage, the registration file talairach_with_skull.lta is created by
mri_em_register in order to make use of the atlas to find skull. But in the autorecon2 stage, the registration
file talairach_with_skull_2.lta is created, and this one is created with the benefit of the
mri_ca_register stage, and so tends to be a tiny bit more accurate than 
talairach_with_skull.lta, and so it is possible that the skull-strip will work better with this
registration file. So to make use of it: 



cd $SUBJECTS_DIR/yoursubj/mri/transforms
cp talairach_with_skull.lta bak
cp talairach_with_skull_2.lta talairach_with_skull.lta
recon-all -s yoursubj -skullstrip -clean-bm -clean-lta

Inspect the brainmask.mgz after this completes. 

1.4. Manual editing
When the skull stripping process has left just a few slices with either missing brain regions or too much
skull you can edit these manually using tkmedit. 

Part of the brain is missing Sometimes there will be small regions missing from the pons or cerebellum,
or from part of the cortex itself. To fix these you’d need to open the output volume from the skull
stripping step (brainmask.mgz) and the original T1 volume (T1.mgz) simultaneously. 

For this following example we will use a subject with a missing cerebellum to demonstrate the tools,
but in reality this is not an example of something you would want to edit by hand. 

tkmedit skullstrip3_before brainmask.mgz -aux T1.mgz

Switch back and forth between the two volumes a few times with Ctrl-1 and Ctrl-2, and use the arrow
keys to view the different slices. Notice that a large part of the cerebellum has been stripped away along
with the skull around slice 91. 

In the tkmedit toolbar, go to: 

Tools -> Configure Volume Brush... 

Set Mode to "Clone", and Clone Source to "Aux Volume". Click the Close button to close the
configuration window. You can also change the size and shape of your brush, to do this go to: 

Tools -> Configure Brush Info... 

Select a radius and shape that you are comfortable using. Close the configuration menu, and click the
"Edit Voxels" button in tkmedit toolbar. 

Use Ctrl-1 and Ctrl-2 to cycle between the two volumes. Find a place in the image where the cerebellum is
missing in the output volume, then use the middle button on the mouse to paint in cerebellum from the
auxiliary volume. Cycle back and forth between the volumes frequently so you know where you are. 

Continue painting until the slice is no longer missing part of the brain. Repeat for the other slices in the
output volume. Go to File -> Save Main Volume As... and save your output. 

Some skull still remains 
If there are small pieces of skull still remaining on only a few slices you can manually remove the voxels.
To do this make sure that the "Edit Voxels" button is still selected. Removing voxels is very similar to
painting in voxels, except you use the right mouse button instead of the middle button. Use Ctrl-1 and



Ctrl-2 to cycle between the volumes. Find a place in the image where skull remains. Use the right mouse
button to delete the voxels. Continue on the other slices until all skull is removed. Save your volume. 

Ctrl-z and Edit -> Undo Last Edit in tkmedit only allow you to go back one edit. If you need to erase a
mistake made when painting in voxels, you can use the right mouse button to delete them again. If you
remove too many voxels, you can use the clone tool to paint areas back in from the original T1 volume,
similar to painting in voxels as described above. 
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1. Using Control Points to Fix Intensity Normalization

To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

Sometimes the intensity normalization step will fail because it cannot determine the proper intensity for
white matter. The result is an erroneous white matter segmentation. A control point is a manually selected
location in the volume that the user feels sure is inside the white matter boundary, and subsequently
should be normalized to an intensity of 110. TkMedit displays the intensity of any voxel your cursor is on
as a "value" in the Cursor and Mouse sections of its Tools interface. 

Manually Selecting Control Points 

Subject cp_before is an example of a subject that needs some control points in order to ensure that the
voxels are normalized correctly and then included in the wm.mgz volume. This page will walk you
through setting control points to fix this type of problem. 

First, make sure you have cp_before loaded into tkmedit: 

tkmedit cp_before brainmask.mgz -aux T1.mgz -surfs

Note: If you are using your own subject data, where surfaces are not yet available (ie. the -autorecon2
stage has not run yet), then don’t include the surfaces in the tkmedit command: 

tkmedit <my_subj> brainmask.mgz -aux T1.mgz

Scroll through this subject and find the location where the white matter is being excluded from the
surface. In subject cp_before, this happens around coronal slice 148. 



To add control points you will first need to select the Edit Control Points tool  . Middle-mouse-button
clicking will create a control point; right-button clicking will delete a control point. As you select control
points, they will appear as small green crosshairs. Select a few control points around your trouble areas,
space them out throughout the brain and on different slices. You want to pick points in a region where the
wm intensity is lower than it should be (that is, having a voxel value less than 110). 



General tips for adding control points: 

Control points should only be added in regions that are definitely white matter (i.e., not in the cortex,
cerebellum, brainstem, or outside of the skull). 
Control points should also only be added in regions where voxel intensity is not 110. A control point
in a region that is already normalized to 110 will be useless. 

Control points should NOT be used to try and normalize a brain lesion to 110. Such defects should be
fixed with white matter edits 
Control points can help recover thin wm strands that are dark by putting some at the base of the
strand. 
Control points are also useful in areas of very bright intensity. 
Start off with a few control points spread out in your trouble area. You may need to add more. With
experience you will be able to determine how many are appropriate, given your specific subject. 

Here is an example of one slice with the control points added. Note that there are other control points
spread out through other slices as well. 



After adding the control points, go to File -> Save Control Points; this will create a file called <subject
name>/tmp/control.dat. 

Once your control points are saved you can rerun recon-all as follows: 

recon-all -autorecon2-cp -autorecon3 -subjid cp_before



Do not run this command if you are conducting the tutorial! 

This step will take a long time so there is no need to run it for the purposes of this tutorial. 

Using the added control points the subject should look like this after rerunning recon-all: 
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1. Fixing Bad Output From the Talairach Registration

To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

FreeSurfer computes a linear Talairach transform contained in a 3x4 matrix in a file called talairach.xfm
and is located in the <subject name>/mri/transforms directory. Under some circumstances, the alignment
can fail the automatic failure detection scheme (-tal-check flag, which can be disabled via -notal-check). 

The best way to check the transform is by loading it visually. This can be done directly from tkmedit (File
--> Load Transform), however new users sometimes feel more comfortable viewing the transform in
tkregister2, where it is possible to view the transform on top of the talairach subject. When viewing in
tkmedit you can expect some distortion and stretching from the position of your subject - especially a
sagittal tilt, but you want to avoid any changes in orientation (i.e., the coronal view of your subject should
be the coronal view of your talairach transform), severe changes in positioning in the window (i.e., your
transformation should not show up in the top left corner of the view, while your subject is nicely
centered), and rotations or twisting. If any of these are seen, you will need to correct your transform. 

Subject tal_before is an example of a bad talairach. The surface cutting planes are far off center but the
problem actually originates from the bad talairach transform. To view this talairach in tkmedit first be sure
you have the subject open: 

tkmedit tal_before brainmask.mgz

If the surfaces are also loaded into tkmedit you may find it easier if you toggle them off for this part. 

In the tkmedit toolbar, go to File -> Transforms -> Load Transform for Main Volume... Click browse,
select the file talairach.xfm and click ’OK’. In the coronal view, the transform has resulted in an extremely
distorted brain. 



To further view and edit this transform we will use tkregister2. To open this you can close the tkmedit
window and open tkregister2 with the command: 

tkregister2 --mgz --s tal_before --fstal --surf orig

Note: If your subject surfaces are not yet available, then exclude the --surf orig  flag from 
tkregister2. 

Brief descriptions on how to operate tkregister2 are given below. More documentation is also available by
running "tkregister2 --help". 



You will see the subject’s volume as the TARGET volume and your Talairach volume as a fuzzy
MOVEABLE volume. The green lines are the orig surface from the subject. This will be the same in both
the TARGET and the MOVEABLE. It can be turned on and off by clicking in the image window and
hitting the ’s’ key.. Find the fmov: box in the tkregister toolbar and make sure it is set to 1.0. 

The goal is to stretch, translate, and rotate your MOVEABLE volume so that the two brains look as
similar as possible, at least along the key anatomical points (anterior/posterior commissures, the temporal
lobes in the coronal plane, and the midline cut). 

Use Ctrl-1 and Ctrl-2 to switch between the two volumes (or hit the COMPARE button). You will want to
do this frequently to check your progress. Click the SAGITTAL button to switch to a sagittal view, and go
to slice 128 by using the slider directly below the SAGITTAL button. In this view you have a good view
of the corpus callosum in both the moveable and target volumes. 





To rotate the moveable volume, use the ROTATE BRAIN slider. You will want to move the slider only a
couple of degrees at a time until you achieve the desired effect. You will notice a small red cross icon near
the middle of the viewing window. This is the center of rotation. You can change the location of the center
of rotation by left-clicking in the viewing window with your mouse. 

For translation, there are two sliders: one to move the volume left and right, and one to move the volume
up and down. Next, translate the moveable brain upwards by using the TRANSLATE BRAIN vertical
slider. Again, you only want to move the volume a couple millimeters at a time. You can move the volume
left and right in the same way. 



Once you have the corpus callosum aligned as well as possible in the sagittal plane, click the
HORIZONTAL button to get a horizontal view, and use the slider directly below the HORIZONTAL
button to go to slice 128. Use Ctrl-1 and Ctrl-2 to switch between the two volumes. Use the ROTATE
BRAIN and TRANSLATE BRAIN buttons as before to align the midlines of both volumes. 



Once you are done aligning the brains in the horizontal view, switch back to slice 128 in the sagittal view.
Fine tune your rotation and translation again until the corpus callosum is once again aligned in both
volumes. 



Click the CORONAL button, and go to slice 128. Align the midlines of the brains again in the same way. 



Continue this way, switching frequently between the HORIZONTAL, SAGITTAL, and CORONAL
views, and align the visible brain structures as much as possible in all of the slices. Use the SCALE
BRAIN button as needed to scale the brain in the X and Y direction. Keep in mind that you are working in
3D, not in 2D, so any changes made in one view will affect the other views as well. 







When you are satisfied with your registration result, click the SAVE REG button in the tkregister2
toolbar. You can close tkregister2 by clicking on the red close button in the upper left hand corner of the
viewing window, or by typing Ctrl-C in in the same terminal window as the new matrix. 

Because the talairach transformation affects everything in the stream it is necessary to rerun the whole
process using your new talairach, which is a default. You can do this with the command: 

recon-all -all -subjid tal_before

This step will take a long time to run, it is not necessary to run this step for the purposes of this tutorial.
You can compare your new talairach to the one in tal_after. 

Lastly, there is an alternate means of producing a talairach transform that may work better in some cases.
To run that method: 

recon-all -s tal_before -talairach -use-mritotal -tal-check -clean-tal

This runs the mritotal utility from the MNI toolset. Note that for this particular subject example, it
happens to produce worse results than the default talairach transform method. Also note that the -clean-tal
flag will delete any existing talairach.xfm file. 
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To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

1. Data Conversion
In this exercise, an image from a scanner, in DICOM format, will be converted into mgz format, using
recon-all. 

You first want to make sure you are working in the appropriate directory and that you have set your
SUBJECTS_DIR variable correctly. You can do this by entering the following directory: 

cd $TUTORIAL_DATA/buckner_data/tutorial_subjs

Set the current directory to be the default subjects directory using this command: 

setenv SUBJECTS_DIR ${PWD}

Two acquisitions of an anonymized volume have been provided for this tutorial with the recognizable face
characteristics removed, in the directory buckner_data/tutorial_subjs/014-anon and
buckner_data/tutorial_subjs/015-anon. Using the recon-all script you can specify both the acquisitions to
be converted to mgz format as well as the name you wish to give your subject in the following format: 

recon-all -all -i <in volume 1> -i <in volume 2> -s <subject name> 

where <in volume 1> is the first file that appears in the first acquisition directory, and <in volume 2> is
the first file that appears in the second acquisition directory. For this example we will use anon as our
<subject name>. To convert the two anon acquisitions use the command: 

recon-all -i 014-anon/001.dcm -i 015-anon/001.dcm -s anon

The output file list can be viewed with the following command: 

ls ${SUBJECTS_DIR}/anon/mri/orig

which will show: 

001.mgz  002.mgz

View the output of the data conversion with tkmedit: 

tkmedit -f ${SUBJECTS_DIR}/anon/mri/orig/001.mgz



The full path to the converted volume is specified with the -f option because a file is being specified
explicitly. If tkmedit is called without the -f, it will assume that the data is in
${SUBJECTS_DIR}/<subject name>/mri, where <subject name> is the first argument on the tkmedit
command line (anon in the example below). 

You can motion correct your two acquisitions using the -motioncor option of recon-all like this: 

recon-all -motioncor -s anon

Once motion correction has been performed using 001.mgz and 002.mgz, the volume
${SUBJECTS_DIR}/anon/mri/orig.mgz has been produced, tkmedit will be able to find that volume using
the subject directory and the volume name: 

tkmedit anon orig.mgz
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1. Image before and after comparisons (volume processing 
pipeline)



1.1. 1.0 N3 intensity normalization: nu_correct_subject <subject name>

1.2. 2.0 Cortical intensity normalization: mri_normalize orig T1

1.3. 3.0 Cortical Talairach: talairach <subject name>



1.4. 4.0 Cortical skull stripping: mri_watershed T1 brain

1.5. 5.0 Subcortical intensity normalization: mri_ca_normalize -mask
brain nu $GCA transforms/talairach.lta norm



1.6. 6.0 Subcortical segmentation: mri_ca_label norm
transforms/talairach.m3d $GCA aseg

1.7. 7.0 Subcortical brain intensity normalization: mri_normalize norm 
brain



1.8. 8.0 Subcortical white matter segmentation: mri_segment brain wm

1.9. 9.0 Auto segmentation Editing: mri_edit_wm_with_aseg wm aseg 
wm



1.10. 10.0 Filling: mri_fill wm filled
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To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

1. Visually check the cortical reconstruction output with tkmedit
For each step so far, look at the output generated for the subject ’bert’. As you are performing a cortical
reconstruction, it is a good idea to visually examine your data for errors or defects that may have been
generated in the reconstruction steps. When using tkmedit, scroll through the volumes with the up and
down arrow keys to visually inspect each slice. For a reminder of which inputs and outputs are taken by
each step in the reconstruction, refer to this guide First, set your subjects directory environment variable: 

cd $TUTORIAL_DATA/buckner_data/tutorial_subjs
setenv SUBJECTS_DIR ${PWD}

Data conversion
Before preprocessing is done, data must be converted from native scanner format to mgz format. The
output of this step is the bert/mri/orig.mgz. To open it in tkmedit: 

tkmedit bert orig.mgz

Intensity normalization
The intensity normalization step takes the bert/mri/orig volume as input and outputs the bert/mri/T1
volume. Look at these volumes simultaneously to see the difference from the intensity normalization step.
Use Ctrl-1 and Ctrl-2 to switch between the volumes. 

tkmedit bert T1.mgz -aux orig.mgz

Skull stripping 
The skull stripping step takes the bert/mri/T1 volume as input, strips off the skull, and outputs the
bert/mri/brainmask volume. Look at the T1 and brainmask volumes simultaneously with tkmedit. Use
Ctrl-1 and Ctrl-2 to switch between the volumes. 

tkmedit bert brainmask.mgz -aux T1.mgz

Segmentation 
The segmentation step takes the /bert/mri/brainmask volume as input, removes the gray matter and CSF,
and outputs the /bert/mri/wm volume. Look at the brainmask and wm volumes simultaneously with
tkmedit. Use Ctrl-1 and Ctrl-2 to switch between the volumes. 

tkmedit bert wm.mgz -aux brainmask.mgz
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To follow this exercise exactly be sure you’ve downloaded the tutorial data set before you begin. If
you choose not to download the data set you can follow these instructions on your own data, but you
will have to substitute your own specific paths and subject names. 

1. Visually check the cortical reconstruction output with tkmedit
and tksurfer
For each step so far, look at the output generated for the subject ’bert’. Each time you perform a cortical
reconstruction, it is a good idea to visually examine the final surfaces generated after automatic topology
fixing for errors or defects that may have been generated in the reconstruction steps. First, set your
subjects directory environment variable: 

cd $TUTORIAL_DATA/buckner_data/tutorial_subjs
setenv SUBJECTS_DIR ${PWD}

Generating cutting planes and filling 
This step takes the /bert/mri/wm.mgz segmented white matter volume as input, and outputs the
bert/mri/filled.mgz volume. To view this volume in tkmedit: 

tkmedit bert filled.mgz

Tessellate 
This step takes the /bert/mri/filled.mgz volume as input, and outputs the surfaces bert/surf/lh.orig and
/bert/surf/rh.orig for the left and right hemispheres, respectively. To view these surfaces in tksurfer: 

tksurfer bert lh orig
tksurfer bert rh orig

Smoothing and Inflation 
The smoothing and inflation step takes the bert/surf/lh.orig and /bert/surf/rh.orig surfaces as input, and
outputs the following surfaces in the bert/surf directory: lh.smoothwm, rh.smoothwm, lh.curv, rh.curv,
lh.sulc, rh.sulc, lh.inflated, and rh.inflated. To view the smoothed and inflated surfaces in tksurfer: 

tksurfer bert lh smoothwm
tksurfer bert rh smoothwm
tksurfer bert lh inflated
tksurfer bert rh inflated

To view the curv files, load the lh inflated surface into tksurfer again. Go to File -> Curvature -> Load 
Curvature..., click Browse, and select the file lh.curv. You will see a red and green pattern overlaid on
the inflated surface that represents the curvature of the white matter at that location. Repeat with the right
hemisphere inflated and curv files. 



Generate final surfaces 
The final surfaces are generated by taking the bert/surf/lh.orig and bert/surf/rh.orig surfaces as inputs, and
outputs the following surfaces in the bert/surf directory: lh.white, rh.white, lh.pial, rh.pial, lh.thickness,
rh.thickness. As mentioned previously, the white and pial surfaces are particularly important to check for
defects before continuing through the surface processing pipeline. To view the surfaces in tksurfer: 

tksurfer bert lh white
tksurfer bert rh white
tksurfer bert lh pial
tksurfer bert rh pial

Generate spherical surfaces 
The spherical surface is generated by taking the bert/surf/lh.inflated and bert/surf/rh.inflated surfaces as
inputs and outputting the surfaces bert/surf/lh.sphere and bert/surf/rh.sphere. To view these files in
tksurfer: 

tksurfer bert lh sphere
tksurfer bert rh sphere

To make these spheres more interesting, view the curv files overlaid on the spherical surfaces. Load the lh
sphere surface into tksurfer again. Go to File -> Curvature -> Load Curvature..., click Browse, and
select the file lh.curv. You will see a red and green pattern overlaid on the spherical surface that represents
the curvature of the white matter at that location. Repeat with the right hemisphere sphere and curv files. 
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FreeSurfer Tutorial: Process Flow
This table shows the recon-all steps for the current dev version of FreeSurfer. See 
ReconAllTableStableV5.1 to see a process flow for the latest stable version of FreeSurfer. 

Click here to see this information presented in a block diagram format and here for a process v. files table. 

See also the OtherUsefulFlags for other recon-all options. 

recon-all 
step 

Individual 
Flag Input Command Line Output 

recon-all
-autorecon1
-subjid 
<subjid> 

-i <invol1> -i
<invol2> 

invol1.dcm mri_convert invol1.dcm orig/001.mgz orig/001.mgz 

invol2.dcm mri_convert invol2.dcm orig/002.mgz orig/002.mgz 

-motioncor 

orig/001.mgz mri_robust_template --mov 001.mgz 002.mgz --average 1 --template rawavg.mgz --satit --inittp
1 --fixtp --noit --iscale --subsample 200 rawavg.mgz 

orig/002.mgz 

rawavg.mgz mri_convert rawavg.mgz orig.mgz --conform orig.mgz 

orig.mgz mri_add_xform_to_header -c transforms/talairach.xfm orig.mgz orig.mgz orig.mgz 

-talairach 

orig.mgz talairach_avi --i orig.mgz --xfm transforms/talairach.auto.xfm transforms/talairach.auto.xfm 

transforms/talairach.auto.xfm cp transforms/talairach.auto.xfm transforms/talairach.xfm transforms/talairach.xfm 

transforms/talairach.xfm talairach_afd -T 0.005 -xfm transforms/talairach.xfm transforms/talairach.xfm 

awk -f $FREESURFER_HOME/bin/extract_talairach_avi_QA.awk transforms/talairach_avi.log transforms/talairach_avi.log 

-nuintensitycor orig.mgz, talairach.xfm mri_nu_correct.mni --i orig.mgz --o nu.mgz --n 2 --uchar transforms/talairach.xfm nu.mgz 

-normalization nu.mgz mri_normalize -g 1 nu.mgz T1.mgz T1.mgz 

-skullstrip 

nu.mgz 
mri_em_register -skull nu.mgz
$FREESURFER_HOME/average/RB_all_withskull_2008-03-26.gca
transforms/talairach_with_skull.lta 

transforms/talairach_with_skull.lta 

T1.mgz 
mri_watershed -T1 -brain_atlas
$FREESURFER_HOME/average/RB_all_withskull_2008-03-26.gca
transforms/talairach_with_skull.lta T1.mgz brainmask.auto.mgz 

brainmask.auto.mgz 

brainmask.auto.mgz cp brainmask.auto.mgz brainmask.mgz brainmask.mgz 



recon-all
-autorecon2
-subjid 
<subjid> 

-gcareg 
brainmask.mgz mri_em_register -mask brainmask.mgz nu.mgz

$FREESURFER_HOME/average/RB_all_2008-03-26.gca transforms/talairach.lta transforms/talairach.lta 
nu.mgz 

-canorm 

brainmask.mgz 
mri_ca_normalize -mask brainmask.mgz nu.mgz
$FREESURFER_HOME/average/RB_all_2008-03-26.gca transforms/talairach.lta norm.mgz norm.mgz nu.mgz 

transforms/talairach.lta 

-careg 

brainmask.mgz 
mri_ca_register -align-after -nobigventricles -mask brainmask.mgz -T transforms/talairach.lta
norm.mgz $FREESURFER_HOME/average/RB_all_2008-03-26.gca transforms/talairach.m3z transforms/talairach.m3z transforms/talairach.lta 

norm.mgz 

-careginv transforms/talairach.m3z mri_ca_register -invert-and-save transforms/talairach.m3z 

transforms/talairach.m3z.inv.x.mgz 

transforms/talairach.m3z.inv.y.mgz 

transforms/talairach.m3z.inv.z.mgz 

-rmneck 
nu.mgz mri_remove_neck -radius 25 nu.mgz transforms/talairach.m3z

$FREESURFER_HOME/average/RB_all_2008-03-26.gca nu_noneck.mgz nu_noneck.mgz 
transforms/talairach.m3z 

-skull-lta 
transforms/talairach.lta mri_em_register -skull -t transforms/talairach.lta nu_noneck.mgz

$FREESURFER_HOME/average/RB_all_withskull_2008-03-26.gca
transforms/talairach_with_skull_2.lta 

transforms/talairach_with_skull_2.lta 
nu_noneck.mgz 

-calabel 

norm.mgz mri_ca_label -align -nobigventricles norm.mgz transforms/talairach.m3z
$FREESURFER_HOME/average/RB_all_2008-03-26.gca aseg.auto_noCCseg.mgz aseg.auto_noCCseg.mgz 

transforms/talairach.m3z 

aseg.auto_noCCseg.mgz mri_cc -aseg aseg.auto_noCCseg.mgz -o aseg.auto.mgz <subjid> aseg.auto.mgz 

aseg.auto.mgz cp aseg.auto.mgz aseg.mgz aseg.mgz 

-normalization2 

brainmask.mgz 

mri_normalize -aseg aseg.mgz -mask brainmask.mgz norm.mgz brain.mgz brain.mgz norm.mgz 

aseg.mgz 

-maskbfs 
brain.mgz 

mri_mask -T 5 brain.mgz brainmask.mgz brain.finalsurfs.mgz brain.finalsurfs.mgz 
brainmask.mgz 

-segmentation 

brain.mgz mri_segment brain.mgz wm.seg.mgz wm.seg.mgz 

wm.seg.mgz 

mri_edit_wm_with_aseg wm.seg.mgz brain.mgz aseg.mgz wm.asegedit.mgz wm.asegedit.mgz aseg.mgz 

brain.mgz 

wm.asegedit.mgz 
mri_pretess wm.asegedit.mgz wm norm.mgz wm.mgz wm.mgz 

norm.mgz 

-fill 

wm.mgz 
mri_fill -a ../scripts/ponscc.cut.log -xform transforms/talairach.lta -segmentation
aseg.auto_noCCseg.mgz wm.mgz filled.mgz 

filled.mgz 

aseg.auto_noCCseg.mgz 
../scripts/ponscc.cut.log 

transforms/talairach.lta 

-tessellate 

filled.mgz 
mri_pretess filled.mgz 255 norm.mgz filled-pretess255.mgz filled-pretess255.mgz 

norm.mgz 

filled-pretess255.mgz mri_tessellate filled-pretess255.mgz 255 lh.orig.nofix lh.orig.nofix 

filled.mgz 
mri_pretess filled.mgz 127 norm.mgz filled-pretess127.mgz filled-pretess127.mgz 

norm.mgz 

filled-pretess127.mgz mri_tessellate filled-pretess127.mgz 127 rh.orig.nofix rh.orig.nofix 

?h.orig.nofix mris_extract_main_component ?h.orig.nofix ?h.orig.nofix ?h.orig.nofix 

rm -f filled-pretess255.mgz filled-pretess127.mgz 

-smooth1 ?h.orig.nofix mris_smooth -nw ?h.orig.nofix ?h.smoothwm.nofix ?h.smoothwm.nofix 

-inflate1 ?h.smoothwm.nofix mris_inflate -no-save-sulc ?h.smoothwm.nofix ?h.inflated.nofix ?h.inflated.nofix 

-qsphere ?h.inflated.nofix mris_sphere -q ?h.inflated.nofix ?h.qsphere.nofix ?h.qsphere.nofix 

-fix 

?h.orig.nofix cp ?h.orig.nofix ?h.orig ?h.orig 

?h.inflated.nofix cp ?h.inflated.nofix ?h.inflated ?h.inflated 

?h.qsphere.nofix mris_fix_topology -mgz -sphere qsphere.nofix -ga <subjid> ?h ?h.orig 

?h.orig mris_euler_number ?h.orig ?h.orig 

?h.orig mris_remove_intersection ?h.orig ?h.orig ?h.orig 

rm ?h.inflated 

-white 

aseg.mgz,
brain.finalsurfs.mgz,
wm.mgz, filled.mgz 

mris_make_surfaces -whiteonly -noaparc -mgz -T1 brain.finalsurfs <subjid> ?h 

?h.white 

?h.orig 
?h.curv 

?h.area

?h.cortex.label 

-smooth2 ?h.white mris_smooth -n 3 -nw ?h.white ?h.smoothwm ?h.smoothwm 

-inflate2 

?h.smoothwm mris_inflate ?h.smoothwm ?h.inflated 
?h.inflated 

?h.sulc 

?h.inflated mris_curvature -thresh .999 -n -a 5 -w -distances 10 10 ?h.inflated 
?h.inflated.H 

?h.inflated.K 



recon-all
-autorecon3
-subjid 
<subjid> 

-sphere ?h.inflated,?h.smoothwm mris_sphere ?h.inflated ?h.sphere ?h.sphere 

-surfreg ?h.sphere mris_register -curv ?h.sphere
$FREESURFER_HOME/average/?h.average.curvature.filled.buckner40.tif ?h.sphere.reg ?h.sphere.reg 

-jacobian_white 
?h.white 

mris_jacobian ?h.white ?h.sphere.reg ?h.jacobian_white ?h.jacobian_white 
?h.sphere.reg 

-avgcurv ?h.sphere.reg mrisp_paint -a 5 $FREESURFER_HOME/average/?h.average.curvature.filled.buckner40.tif#6
?h.sphere.reg ?h.avg_curv ?h.avg_curv 

-cortparc 
aseg.mgz, ?h.cortex.label mris_ca_label -l ../label/lh.cortex.label -aseg mri/aseg.mgz <subjid> ?h ?h.sphere.reg

$FREESURFER_HOME/average/?h.curvature.buckner40.filled.desikan_killiany.2007-06-20gcs
?h.aparc.annot 

label/?h.aparc.annot 
?h.sphere.reg 

-pial 

aseg.mgz,
brain.finalsurfs.mgz,
wm.mgz, filled.mgz 

mris_make_surfaces -white NOWRITE -mgz -T1 brain.finalsurfs <subjid> ?h 

?h.pial 

?h.orig, label/?h.aparc.annot ?h.curv.pial, ?h.area.pial

?h.thickness

-surfvolume 

?h.area 
mris_calc -o ?h.area.mid ?h.area add ?h.area.pial ?h.area.mid 

?h.area.pial 

?h.area.mid mris_calc -o ?h.area.mid ?h.area.mid div 2 ?h.area.mid 

?h.area.mid 
mris_calc -o ?h.volume ?h.area.mid mul ?h.thickness ?h.volume 

?h.thickness 

-parcstats label/?h.aparc.annot mris_anatomical_stats -mgz -f stats/?h.aparc.stats -b -a label/?h.aparc.annot -c
label/aparc.annot.ctab <subjid> ?h 

stats/?h.aparc.stats
label/aparc.annot.ctab 

-cortparc2 
aseg.mgz, ?h.cortex.label mris_ca_label -l ../label/lh.cortex.label -aseg aseg.mgz <subjid> ?h ?h.sphere.reg

$FREESURFER_HOME/average/?h.destrieux.simple.2009-07-29.gcs
label/?h.aparc.a2009s.annot 

label/?h.aparc.a2009s.annot 
?h.sphere.reg 

-parcstats2 label/?h.aparc.a2009s.annot mris_anatomical_stats -mgz -f stats/?h.aparc.a2009s.stats -b -a label/?h.aparc.a2009s.annot -c
label/aparc.annot.a2009s.ctab <subjid> ?h 

stats/?h.aparc.a2009s.stats
stats/aparc.annot.a2009s.ctab 

-cortribbon 

aseg.mgz 
mris_volmask --label_left_white 2 --label_left_ribbon 3 --label_right_white 41
--label_right_ribbon 42 --save_ribbon --save_distance <subjid> ?h.ribbon.mgz, ribbon.mgz ?h.white 

?h.pial 

-segstats aseg.mgz 

mri_segstats --seg mri/aseg.mgz --sum stats/aseg.stats --pv mri/norm.mgz --empty --excludeid 0
--excl-ctxgmwm --supratent --subcortgray --totalgray --in mri/norm.mgz --in-intensity-name
norm --in-intensity-units MR --etiv --surf-wm-vol --surf-ctx-vol --ctab
$FREESURFER_HOME/ASegStatsLUT.txt --subject <subjid>

stats/aseg.stats 

-aparc2aseg 

aseg.mgz 

mri_aparc2aseg --s <subjid> --ribbon aparc+aseg.mgz ?h.ribbon.mgz

label/?h.aparc.annot 

aseg.mgz 

mri_aparc2aseg --s <subjid> --ribbon --a2009s aparc.a2009s+aseg.mgz ?h.ribbon.mgz 

label/?h.aparc.a2009s.annot 

-wmparc 

aparc+aseg.mgz mri_aparc2aseg --s <subjid> --labelwm --hypo-as-wm --rip-unknown --ribbon --o
mri/wmparc.mgz --ctxseg aparc+aseg.mgz wmparc.mgz 

wmparc.mgz 

mri_segstats --seg mri/wmparc.mgz --sum stats/wmparc.stats --pv mri/norm.mgz --excludeid 0
--brain-vol-from-seg --brainmask mri/brainmask.mgz --in mri/norm.mgz --in-intensity-name
norm --in-intensity-units MR --etiv --subject <subjid> --surf-wm-vol --ctab
$FREESURFER_HOME/FreeSurferColorLUT.txt 

stats/wmparc.stats 

-balabels ?h.sphere.reg mri_label2label --srcsubject fsaverage --srclabel fsaverage/label/?h.BA*.label --trgsubject
<subjid> --trglabel ?h.BA*.label --hemi ?h --regmethod surface label/?h.BA*.label

-label-exvivo-ec ?h.sphere.reg mris_spherical_average -erode 1 -orig white -t 0.4 -o <subjid> label ?h.entorhinal ?h sphere.reg
?h.EC_average ?h.entorhinal_exvivo.label label/?h.entorhinal_exvivo.label
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1. Preparations

1.1. If You’re at an Organized Course
If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs/group_analysis_tutorial
cd $SUBJECTS_DIR/glm

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 



1.2. If You’re not at an Organized Course
If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs/group_analysis_tutorial
cd $SUBJECTS_DIR/glm

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 

2. Introduction
This tutorial is designed to introduce you to the "command-line" group analysis stream in FreeSurfer (as
opposed to QDEC which is GUI-driven), including correction for multiple comparisons. While this 
tutorial shows you how to perform a surface-based thickness study, it is important to realize that most of
the concepts learned here apply to any group analysis in FreeSurfer, surface or volume, thickness or fMRI. 

Here are some useful Group Analysis Links: 
QDEC Tutorial
FSGD Format
FSGD Examples
DODS vs DOSS

3. This Data Set
The data used for this tutorial is 40 subjects from Randy Buckner’s lab. It consists of males and females
ages 18 to 93. You can see the demographics here. You will perform an analysis looking for the effect of
age on cortical thickness accounting for the effects of gender in the analysis. This is the same data set used
in the QDEC Tutorial, and you will get the same result. 

4. General Linear Model (GLM) DODS Setup

4.1. Design Matrix/FSGD File
For this example, we will model the thickness as a straight line. A line has two parameters: intercept (or
offset) and a slope. 



1.  The slope is the change of thickness with age 
2.  The intercept/offset is interpreted as the thickness at age=0. 

Parameter estimates are also called "regression coefficients". 

To account for effects of gender, we will model each sex with its own line, meaning that there will be four
linear parameters (also called "betas"): 

1.  Intercept for Females 
2.  Intercept for Males 
3.  Slope for Females 
4.  Slope for Males 

In FreeSurfer, this type of design is called DODS (for "Different-Offset, Different-Slope"). 

In FreeSurfer, you can either create your own design matrices, or, if you can specify your design in terms
of a FreeSurfer Group Descriptor File (FSGD), FreeSurfer will create them for you. The FSGD file is a
simple text file. See this page for the format. The demographics page also has an example FSGD file for
this data. 

Things to do: 

1.  Create an FSGD file for the above design. One (gender_age.fsgd) already exists so that you can
continue with the exercises. 

Information on how to create/view text files can be found here. 

4.2. Contrasts
A contrast is a vector that embodies the hypothesis we want to test. In this case, we wish to test the change
in thickness with age after removing the effects of gender. To do this, create a simple text file with the
following numbers: 

0 0 0.5 0.5

Notes: 

1.  There is one value for each parameter (so 4 values) 
2.  The intercept/offset values are 0 (nuisance) 
3.  The slope values are 0.5 so as to average the F and M slopes 
4.  A file called lh-Avg-thickness-age-Cor.mtx already exists 

5. Analysis



5.1. Assemble the Data (mris_preproc)
Assembling the data simply means: 

1.  Resampling each subject’s data into a common space, and 
2.  Concatenating all the subjects’ into a single file 
3.  Spatial smoothing (can be done between 1 and 2) 

This can be done in two equivalent ways: 

5.1.1. Previously Cached (qcached) Data

When you have run recon-all with the -qcache option, recon-all will resample data onto the average
subject (fsaverage) and smooth it at various FWHM (full-width/half-max), usually 0, 5, 10, 10, 20, and 
25mm. This can speed later processing. The data for this tutorial have been cached, so run: 

mris_preproc --fsgd gender_age.fsgd \
  --cache-in thickness.fwhm10.fsaverage \
  --target fsaverage --hemi lh \
  --out lh.gender_age.thickness.10.mgh

Notes: 

1.  Only takes a few seconds because the data have been cached 
2.  The FSGD file lists all the subjects, helps keep order. 
3.  The independent variable is the thickness smoothed to 10mm FWHM. 
4.  The data are for the left hemisphere 
5.  The output is lh.gender_age.thickness.10.mgh (which already exists) 

Things to do: 

1.  Run mri_info on lh.gender_age.thickness.10.mgh to find its dimensions,ie, 

mri_info lh.gender_age.thickness.10.mgh

5.1.2. Uncached Data

In the case that you have not cached the data, you can perform the same operations manually using the two
commands below. There is no need to do this for this tutorial. OPTIONAL: THIS WILL TAKE ABOUT
10 MINUTES 

mris_preproc --fsgd gender_age.fsgd \
  --target fsaverage --hemi lh \
  --meas thickness \
  --out lh.gender_age.thickness.00.mgh



Notes: 

1.  This resamples each subjects data to fsaverage 
2.  Output is lh.gender_age.thickness.00.mgh, which is unsmoothed 

OPTIONAL: THIS WILL TAKE ABOUT 5 MINUTES 

mri_surf2surf --hemi lh \
  --s fsaverage \
  --sval lh.gender_age.thickness.00.mgh \
  --fwhm 10 \
  --cortex \
  --tval lh.gender_age.thickness.10B.mgh

1.  This smooths by 10mm FWHM 
2.  "--cortex" means only smooth areas in cortex (exclude medial wall). This is automatically done with

qcache. You can also specify other labels. 
3.  Output is lh.gender_age.thickness.10B.mgh. 

5.2. GLM Analysis (mri_glmfit)

mri_glmfit \
  --y lh.gender_age.thickness.10.mgh \
  --fsgd gender_age.fsgd dods\
  --C lh-Avg-thickness-age-Cor.mtx \
  --surf fsaverage lh \
  --cortex \
  --glmdir lh.gender_age.glmdir

Notes: 

1.  Input is lh.gender_age.thickness.10.mgh 
2.  Same FSGD used as with mris_preproc. Maintains subject order! 
3.  DODS is specified (it is the default) 
4.  Only one contrast is used (lh-Avg-thickness-age-Cor.mtx) but you can specify multiple contrasts. 
5.  "--cortex" specifies that the analysis only be done in cortex (ie, medial wall is zeroed out). Other

labels can be used. 
6.  The output directory is lh.gender_age.glmdir 
7.  Should only take about 1min to run. 

Things to do: 

When this command is finished you will have an lh.gender_age.glmdir. There will be a number of output
files in this directory, as well as two other directories. If you did an ls in your glmdir there will be: 



y.fsgd -- copy of input FSGD file  (text)
Xg.dat -- design matrix  (text)
mask.mgh -- binary mask (surface overlay)
beta.mgh -- all parameter estimates (surface overlay)
rstd.mgh -- residual standard deviation (surface overlay)
sar1.mgh -- residual spatial AR1  (surface overlay)
fwhm.dat -- average FWHM of residual (text)
dof.dat  -- degrees of freedom (text)
lh-Avg-thickness-age-Cor -- contrast subdirectory
mri_glmfit.log -- log file (text, send this with bug reports)

Study Questions: 

1.  What was the DOF for this experiment? 
2.  What was the FWHM? 
3.  How many frames does beta have? Why? 

There will be a subdirectory for each contrast that you specify. The name of the directory will be that of
the contrast matrix file (without the .mtx extension). The lh-Avg-thickness-age-Cor directory will have
the following files: 

C.dat -- original contrast matrix (text)
gamma.mgh -- contrast effect size (surface overlay)
F.mgh -- F ratio of contrast  (surface overlay)
sig.mgh -- significance, -log10(pvalue), uncorrected (surface overlay)

View the uncorrected significance map with tksurfer: 

tksurfer fsaverage lh inflated \
  -annot aparc.annot -fthresh 2 \
  -overlay lh.gender_age.glmdir/lh-Avg-thickness-age-Cor/sig.mgh

You should see: 





Notes: 

1.  

The threshold is set to 2, meaning vertices with p<.01, uncorrected, will have color. 
2.  Blue means a negative correlation (thickness decreases with age), red is positive correlation. 
3.  Click on a point in the Precentral Gyrus. What is it’s value? What does it mean? 

Viewing the medial surface, change the overlay threshold to something very, very low (say, .01): 

View->Configure->Overlay, set "Min" .01

You should see: 



Notes: 

1.  Almost all of cortex now has color 
2.  The non-cortical areas are still blank (0) because they were excluded with --cortex in mri_glmfit

above. 

5.3. Clusterwise Correction for Multiple Comparisons
To perform a cluster-wise correction for multiple comparisons, we will run a simulation. The simulation is
a way to get a measure of the distribution of the maximum cluster size under the null hypothesis. This is
done by iterating over the following steps: 

1.  Synthesize a z map 
2.  Smooth z map (using residual FWHM) 
3.  Threshold z map (level and sign) 
4.  Find clusters in thresholded map 
5.  Record area of maximum cluster 
6.  



Repeat over desired number of iterations (usually > 5000) 

In FreeSurfer, this information is stored in a simple text file called a CSD (Cluster Simulation Data). 

Once we have the distribution of the maximum cluster size, we correct for multiple comparisons by: 

1.  Going back to the original data 
2.  Thresholding using same level and sign 
3.  Finding clusters in thresholded map 
4.  For each cluster, p = probability of seeing a maximum cluster that size or larger during simulation. 

5.3.1. Run the simulation

All these steps are performed with the mri_glmfit-sim: 

mri_glmfit-sim \
  --glmdir lh.gender_age.glmdir \
  --sim mc-z 5 4 mc-z.negative \
  --sim-sign neg --cwpvalthresh 0.4\
  --overwrite

Notes: 

1.  Specify the same GLM directory (--glmdir) 
2.  The simulation type is Z Monte Carlo (mc-z) 
3.  Specify the sign (neg for negative, pos, or abs) 
4.  

Vertex-wise threshold of 4 (p < .0001) 
5.  

Only 5 iterations (usually > 5000) 
6.  CSD files will have mc-z.negative base 
7.  

"--cwpvalthresh 0.4" Keep clusters that have cluster-wise p-values < 0.4 (usually you will want
something like .05). To see all clusters, set to .999 

8.  --overwrite deletes previous CSD files 

This has been run this data with 1000 iterations (CSD base of mc-z.neg). This can often take many hours. 

5.3.2. View CSD File

The CSD files are stored in lh.gender_age.glmdir/csd. Look at one of them: 



less lh.gender_age.glmdir/csd/mc-z.neg4.j001-lh-Avg-thickness-age-Cor.csd

Or click here. 

Notes: 

1.  Rows that begin with ’#’ are headers or comments. 
2.  Each data row is an iteration. 
3.  The 3rd column is the maximum cluster size for that iteration. 
4.  The CSD file itself is not particularly important, so don’t worry too much about it. 

5.3.3. View the Corrected Results

In the contrast subdirectory, you will see several new files, all beginning with mc-z: 

mc-z.neg4.sig.cluster.summary - summary of clusters (text)
mc-z.neg4.sig.cluster.mgh - cluster-wise corrected map (overlay)
mc-z.neg4.sig.ocn.annot - annotation of clusters

First, look at the cluster summary (or click here): 

less lh.gender_age.glmdir/lh-Avg-thickness-age-Cor/mc-z.neg4.sig.cluster.summary

Notes: 

1.  This is a list of all the clusters that were found (38 of them) 
2.  The CWP column is the cluster-wise probability (the number you are interested in). It is a simple p

(ie, NOT -log10(p)). 
3.  Note that ALL clusters are found, regardless of their significance. 
4.  Cluster number 1 has a CWP of p=.001. 
5.  Cluster number 21 has a CWP of p=.077. 

Load the cluster annotation in tksurfer 

tksurfer fsaverage lh inflated \
  -annot lh.gender_age.glmdir/lh-Avg-thickness-age-Cor/mc-z.neg4.sig.ocn.annot \
  -fthresh 2 -curv -gray

You should see: 





Notes: 

1.  These are all clusters, regardless of significance. 
2.  When you click on a cluster, the label will tell you the cluster number (eg, cluster-021). 

Change the label mode to "Outline" by hitting the outline button  . Now load the cluster p-value 
overlay with 
  File->LoadOverlay
  Click "Browse..."
  Next to where it says "Select", paste the following:  lh.gender_age.glmdir/lh-Avg-thickness-age-Cor/mc-z.neg4.sig.cluster.mgh
  Hit OK
  Hit OK

You should see: 



Note: 

Things to do: 

1.  Find and click on cluster 1. It is blue and has a value of -3 since this is log10(.001). The -3 is because
the correlation is negative. 

2.  Find and click on cluster 21. Its value is -1.11 because this is log10(.077). Note that it is transparent
because its significance 

is worse than the threshold we set (-fthresh 2, p < .01). 
3.  All vertices within a cluster are the same value (the p-value of the cluster). 
4.  You can changed the cluster-wise threshold by clicking on 

View->Configure->Overlay, and setting the "Min" to your desired level. As you do this, some
clusters will change transparency. 
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This page describes the FreeSurfer Group Descriptor (FSGD) File Format (Version 1) as of 11/12/02.
FSGD is a way to describe a group of subjects and their accompanying data (like a spreadsheet). This can
include class membership and other continuous varibles (eg, age). The nice thing about the FSGD is that
various FreeSurfer programs can automatically compute the design matrix from an FSGD file. The
FSGDF is used by mri_glmfit, mris_preproc, tksurfer, tkmedit. FSGD files are created automatically by
qdec, but qdec is currently (12/9/08) limited to two continuous variables and two discrete variables with
two levles. The FSGD format uses tags to identify information. 

In an FSGD, a Class is generally synonymous with a Group. A Class/Group is a specific level of a
specific discrete Factor. Eg, if you have Gender as a Factor, then the Factor will have two levels (Male and
Female). If the only Discrete Factor in your design is Gender, then there will only be two groups (Males
and Females). If you have two Discrete Factors (eg, Gender and Handedness), then you will have four
classes/groups (MaleRight, MaleLeft, FemaleRight, and FemaleLeft). 

Continuous Factors are referred to as Variables in the FSGD. These include things like Age, IQ, Weight,
etc. 

There are numerous FSGD examples worked out here.

Example of a legal file: 

  GroupDescriptorFile 1
  Title MyTitle
  Class Class1 plus blue 
  CLASS Class2 circle green
  SomeTag
  Variables             Age  Weight   IQ
  Input subjid1 Class1   10    100   1000               
  Input subjid2 Class2   20    200   2000
  #Input subjid3 Class2   20    200   2000
  DefaultVariable Age

Notes: 
* The first line must be "GroupDescriptorFile 1".
* Title is not necessary. This will be used for display. 
* CLASS only needs the class name, the next two items (eg, "plus blue)" will be used in the display.
* The third input is ignored because of the hash (#).
* DefaultVariable is the default variable for display.
* SomeTag is not a valid tag, so it will be ignored.

General Rules: 

* Each subject is represented by an Input tag. 
* The order of the subjects is not important but you must make sure it is consistent with the input to
mri_glmfit (--y). 
* Each subject must have values for all variables (no empty cells) 
* Tags are NOT case sensitive. 
* Labels are case sensitive. 
* When multiple items appear on a line, they can be separated by any white space (ie, blank or tab). 



* Any line where # appears as the first non-white space character is ignored (ie, it is treated as a
comment). 
* The Variables line should appear before the first Input line. 
* All Class lines should appear before the first Input line. 
* Variable label replications are not allowed. 
* Class label replications are not allowed. 
* If a class label is not used, a warning is printed out. 
* The DefaultVariable must be a member of the Variable list. 
* No error is generated if a tag does not match an expected keyword. 
* Empty lines are OK. 
* A class label can optionally be followed by a class marker. 
* A class marker can optionally be followed by a class color. 
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These are examples of FreeSurfer Group Descriptor (FSGD) files and contrasts for testing various
hypotheses. FreeSurfer can automatically construct design matrices from an FSGD file. The FSGD file is
usually easier to construct than the design matrix. The FSGD file is used as input to several FreeSurfer
programs (mainly mri_glmfit and mris_preproc). Note that you can always specify you own matrix using
the --X option to mri_glmfit. 

These examples are not meant to be exhaustive, nor are they meant to teach you statistics. See these slides
for more of the statistics background on group analysis and how it applies to FreeSurfer. 

An alternative to constructing your own FSGD files is to use QDEC, though QDEC cannot be used with
more than four groups and/or more than two continuous variables. In the examples below, the term
"QDEC-able" appears after those examples that can be analyzed in QDEC. 

Below, DODS refers to "Different Offset, Different Slope" and DOSS refers to "Different Offset, Same
Slope". Refer to the DODS vs DOSS page for more information. 

One Group, Zero Covariates (OSGM = One-Sample Group Mean). DODS or DOSS. QDEC-able. 

One Group, One Covariate. DODS or DOSS. QDEC-able. 

Two Groups (1 Factor, Two Levels), Zero Covariates. DODS or DOSS. QDEC-able. 

Two Groups (1 Factor, Two Levels), One Covariate. DODS only. QDEC-able. 

Two Groups (1 Factor, Two Levels), Two Covariates. DODS only. QDEC-able. 

Three Groups (1 Factor, Three Levels), Zero Covariates. DODS or DOSS. 

Four Groups (2 Factors, Two Levels), Zero Covariates. DODS or DOSS. QDEC-able. 

Four Groups (2 Factors, Two Levels), One Covariate. DODS only. QDEC-able. 

Six Groups (2 Factors, Three Levels), Zero Covariates. DODS or DOSS. 
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1. Introduction
This page describes the differences and similarities between DODS and DOSS. DODS stands for
"Different Offset, Different Slope". DOSS stands for "Different Offset, Same Slope". These refer to
methods for automatically creating a design matrix from an FSGD file and is used by mri_glmfit and
qdec. The terms DODS and DOSS are unique to FreeSurfer (ie, you won’t find them in a stats textbook:).
For examples of FSGD files see here. 

There are only differences between the two in cases where there are more than one group (or class) and at
least one continuous covariate (variable). 

Consider the simplest case, in which there are two groups (eg, Male and Female) and one continuous
covariate (eg, Age), and we are interested in how cortical thickness relates to these variables using a linear
model. 

A linear model implies two parameters: an offset and a slope. The offset is also called an intercept. The
offset/intercept is the thickness at a covariate of 0 (eg, birth) and is measured in the same units as
thickness (eg, mm). The slope is the rate of change of the thickness and is measured in mm/years. 

2. DODS
Generally speaking, we would probably use a separate linear model for each group, meaning that each
group would have its own offset and its own slope (thus DODS) for a total of four parameters. The model
here would imply that Males and Females could start at different thicknesses and the thicknesses could
grow/shrink at different rates. The design matrix would have four columns (one for each parameter). As
always, the design matrix has a row for each subject. In the automatic construction, the columns
(regressors) would have the following format and interpretation: 

Regressor 1: has a value of 1 if the subject (row) is a Male, 0 otherwise. This regressor codes for
membership in the Male group.



Regressor 2: has a value of 1 if the subject (row) is a Female, 0 otherwise. This regressor codes for
membership in the Female group.

Regressor 3: has a value of the subject’s age if the subject is a Male, 0 otherwise. This regressor
codes for the slope of the Males’ thickness vs age.

Regressor 4: has a value of the subject’s age if the subject is a Female, 0 otherwise. This regressor
codes for the slope of the Females’ thickness vs age.

Generally speaking, the number of DODS regressors will be: 

NregressorsDODS = Nclasses*(Nvariables+1) = 2*(1+1) = 4 

The order will be intercept, slope for variable 1, slope for variable 2, etc. 

3. DOSS
In the DOSS model, we still allow for the different groups to start at different places (different offset), but
we constrain them to evolve at the same rate (same slope). In a scatter plot of the data and best fit lines,
the two lines would be constrained to be parallel. The assumption is that the rate (slope) is the same across
groups. 

The design matrix would have three columns. As always, the design matrix has a row for each subject. In
the automatic construction, the columns (regressors) would have the following format and interpretation: 

Regressor 1: has a value of 1 if the subject (row) is a Male, 0 otherwise. This regressor codes for
membership in the Male group.

Regressor 2: has a value of 1 if the subject (row) is a Female, 0 otherwise. This regressor codes for
membership in the Female group.

Regressor 3: has a value of the subject’s age regardless of the group. This regressor codes for the
slope of the thickness vs age.

Generally speaking, the number of DODS regressors will be: 

NregressorsDOSS = Nclasses + Nvariables = 2+1 = 3 

The order will be the Nclasses intercepts followed by the Nvariables slopes. 



4. DODS or DOSS: which one should I use?
The choice of DODS and DOSS usually comes down to two things: 

Truth 

Power 

"Truth" refers to how you believe the data actually behave. If you truly believe that the groups evolve at
different rates, then your model should reflect this, and thus you should use DODS. 

"Power" refers to the fact that DOSS has fewer regressors than DODS and so will have a larger
degree-of-freedom (DOF). The DOF is the number of subjects minus the number of regressors. In the
above example, the DODS only has one fewer DOF than DOSS, which probably won’t be that important
if you have more than 20 subjects. On the other hand, if you have 4 groups and 3 variables, then DODS
will have 16 regressors whereas DOSS will have only 7, meaning that DODS will have 8 fewer DOFs
than DOSS, which could be important. 

You can, of course, drive yourself crazy deciding how to model your data. I refer you to the words of the
famous statistician George Box: "All models are wrong, but some are useful". Make sure your models are
useful. 

5. SODS?
We could have taken the extra step of automatically generating models that have the same offset but allow
for different slopes. But we didn’t. 

6. I want more flexibility than DODS and DOSS!
To be sure, there are a lot more ways to model your data than DODS and DOSS, however, it becomes
increasingly difficult to automatically generate design matrices. The FreeSurfer tools (namely
mri_glmfit) allows you as much flexibility as you want in modeling, but you have to construct the design
matrix yourself and pass it to mri_glmfit with the --X flag. 

Author: Doug Greve 
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1. FreeSurfer Tutorial: Surface Group Analysis with 
Qdec

1.1. Preparations

1.1.1. If You’re at an Organized Course

If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs/group_analysis_tutorial
cd $SUBJECTS_DIR

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 

1.1.2. If You’re not at an Organized Course

If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs/group_analysis_tutorial
cd $SUBJECTS_DIR

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 

In this tutorial, you will learn how to perform statistical analysis of group surface-based data, including:

Preprocessing the group data



Constructing a qdec.table.dat file of subject demographics

Using Qdec to design and execute your analysis
Interacting with the Qdec display 
Creating Regions of Interest (ROIs) for further analysis and a final check of your data 

Assuming that all ’recon-all -all’ processing has been completed for all subjects in the study, FreeSurfer’s
Qdec application can be used to perform inter-subject/group averaging and inference on the cortical
surface. Qdec permits statistical inferences to be made about effects of interest in relation to error
variance. The mri_glmfit command is used to model the data as a linear combination of effects related to
variables of interest, confounds and errors. Qdec also allows for certain permutation testing and other
means for correcting for multiple comparisons. For group analysis, this technique fits a general linear
model (GLM) at each surface vertex to explain the data from all subjects in the study. In this section, a
brief overview of linear modeling is presented and can be skipped if this material is already familiar.
Other software packages have similar types of programs (e.g., FSL’s GFEAT). Note that Qdec wraps the
mri_glmfit utility, which has more extensive GLM capabilities than QDEC, but is a command-line-only
tool. It has its own tutorial. 

1.2. Introduction
Qdec 
Qdec is a single-binary application included in the FreeSurfer distribution. QDEC is an acronym for
Query, Design, Estimate, Contrast. It is intended to aid researchers in performing inter-subject / group
averaging and inference on the morphometry data (cortical surface and volume) produced by the
FreeSurfer processing stream. Qdec is a GUI front-end to a ’statistics engine’ (the mri_glmfit binary,
included in FreeSurfer, currently fills this role) intended to: 

1.  select the subjects meeting the criteria under study 
2.  generate the necessary input to the stats engine, which, for mri_glmfit, includes: 

1.  

a Design matrix (called X in the GLM equation) containing the explanatory variables, 
2.  

a parameter Estimate matrix (called A in the GLM equation), and 
3.  

the Contrast vector(s) 
3.  generate and optionally display the output data and/or images 

Linear Modeling overview 
Linear modeling describes the observed data as a linear combination of explanatory factors plus noise, and
determines how well that description explains the data being analyzed. In order to understand how to
perform group analysis in FreeSurfer, you need to understand the general linear model (GLM) and how to
construct a GLM in matrix notation. You can click here for a review of this material. The notation we use
here is:y=X*beta, where y is the vector observed data (e.g., thicknesses for each subject at a vertex), X is



the known design matrix (e.g., gender, age), and beta is the vector of unknown parameter estimates (PEs).
The interpretation of the PEs will depend upon how X is constructed. For example, they could be
interpreted as a slope indicating the change of thickness with age. The analysis/estimation is then the
process of computing beta given the data y and the design matrix X. A Null Hypothesis (H0) is
constructed with a contrast matrix C. Inferences are drawn by testing whether the value gamma=Cb is
zero. 

1.3. Preprocess Group Data
recon-all 
Prior to using the qdec application, your group subject data must be processed by the standard FreeSurfer
processing stream, via the recon-all script. A freesurfer tutorial is available. This processing stream
supplies the surfaces and morphometry data on each subject. The data in the tutorial set has been
processed for you. 

pre-smoothed fsaverage surfaces 
Qdec needs each subject to have pre-computed smoothed data for the target surface (fsaverage is the
default) for each measure (thickness, sulc, area, curv, etc.). Your SUBJECTS_DIR should contain either a
link or a copy of the ’fsaverage’ subject found in your $FREESURFER_HOME/subjects directory.
Presmoothing the data onto the target surface is not part of the normal recon processing stream, but you
can easily create this data with recon-all, using the command: 

recon-all -s <subjid> -qcache

For the purposes of this tutorial, the -qcache command has been run for all of the subjects. The
-qcache flag will run numerous back-to-back mris_preproc processes on your machine, so be prepared for
it to run for about an hour. The help text of recon-all -help contains a section on other -qcache otpions. 

qdec.table.dat 
The primary input to Qdec is a text file, named qdec.table.dat, containing the subject IDs, and discrete
(categorical) and continuous factors, in table format. This is essentially a table of demographics for your
subject including all the variables and factors that you wish to consider. Here is an example file: 

fsid            gender  age diagnosis   Left-Cerebral-White-Matter
011121_vc8048   Female  70  Demented    202291
021121_62313-2  Female  71  Demented    210188
010607_vc7017   Female  73  Nondemented 170653
021121_vc10557  Male    75  Demented    142029
020718_62545    Male    76  Demented    186087
020322_vc8817   Male    77  Nondemented 149810

For each discrete (categorical) factor, there should exist a file named <factor>.levels which lists all
possible levels. For example, accompanying the example qdec.table.dat file must be a file named
’gender.levels’ containing these lines: 

Female
Male

http://surfer.nmr.mgh.harvard.edu/fswiki/FsTutorial


and there must be a file named ’diagnosis.levels’ containing these lines: 

Demented
Nondemented

Of course you may have different discrete (categorical) factor names and levels (or even no discrete
factors, in which case all column data are assumed to be continous factors). Continuous factors do not
need a <factor>.levels file to define them. 

For organizational purposes it is best to make a directory called qdec within your $SUBJECTS_DIR.
You can save the qdec.table.dat and <factor>.levels files in there. When Qdec runs it will also save your
analyses to this directory. A qdec subdirectory, with a qdec.table.dat has been made for you. Here
is a sample of what that looks like: 

fsid  gender  age   Left-Hippocampus Right-Hippocampus
140   Female  18    4214             4190
049   Male    19    4543             4153
141   Female  20    3896             3741
084   Male    21    4804             4722
021   Male    22    4021             3969
093   Female  22    3603             3597

This file contains 40 subject IDs, their gender, age, left hippocampus volume, and right hippocampus
volume. To accompany this file you will need to create a <factor>.levels text file to define the
discrete factor names. You can do this using the text editor of your choice (emacs, vi, pico...). For this
tutorial, the qdec.table.dat file already exists for you. 

Optionally, your qdec.table.dat file can explicitly specify the SUBJECTS_DIR, by including it in the first
non-commented line: 

# This is a comment-line in the qdec.table.dat file.
# This explicitly specifies the SUBJECTS_DIR:
SUBJECTS_DIR /my/path/to/subject/data

.

.

.

fsaverage 
For display purposes, you will need to have an average subject included in your SUBJECTS_DIR.
!Freesurfer’s fsaverage, made in MNI305 space, will do fine: 

cd $SUBJECTS_DIR
if (! -e fsaverage) ln -s $FREESURFER_HOME/subjects/fsaverage

This will add a copy of fsaverage into your SUBJECTS_DIR.
For the purposes of this tutorial, fsaverage has already been linked to your $SUBJECTS_DIR. 

If you wish to make your own average subject from your set you can do so using make_average_subject. 



1.4. Usage
To start qdec, from your $SUBJECTS_DIR, simply type qdec: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs/group_analysis_tutorial
cd $SUBJECTS_DIR

qdec &

It may take a few seconds for Qdec to open. The ampersand directs the terminal to run this process in the
background, so you may see your command prompt return before Qdec opens. 

1.4.1. Subjects

When Qdec opens you are looking at the Subjects tab. The first thing you will need to do is to load

your qdec.table.dat file. Click File -> Load Data Table, or you can use the  button, and traverse to
your subjects directory and select the qdec.table.dat file. When you click Open, it should load the file, the
contents scrolling-by in the terminal window. If the data is loaded correctly, you should see in the 
terminal window a summary, like this example: 

.

.

.
1  gender  discrete 2
    1  Female
    2  Male
2  age  continuous 0
3  Left-Hippocampus  continuous 0
4  Right-Hippocampus  continuous 0
                Continuous Factors:         Mean:       StdDev:
                -------------------         -----       -------
                                age        57.175        26.940
                   Left-Hippocampus      3645.850       579.214
                  Right-Hippocampus      3725.325       555.961

Number of subjects:   40
Number of factors:    4 (1 discrete, 3 continuous)
Number of classes:    2
Number of regressors: 8

The factors (gender, age, Left-Hippocampus, and Right-Hippocampus) should appear
in a list under ’Data Table View’ on the control panel. If you choose a factor from this list a scatter plot of
your data will appear in the window. Choose ’age’, and the display should like this: 



The x-axis has the subject number (taken from the order the subjects are listed in the qdec.table.dat), and
the y-axis has the value of the variable you’ve selected. In the example shown you can see a plot of the
ages of all 40 subjects. You can use this to visually check your data for outliers. In Qdec if you roll your
cursor over one of the points on the plot you can find out which subject it is, the ID will be shown in the
lower left corner of the Qdec interface. 

1.4.2. Stats Data Import

It is possible to import the aseg and aparc data from the FreeSurfer-processed group data. To do so, press
the ’Generate Stats Data Tables’ button. This will run the FreeSurfer utilities asegstats2table and
aparcstats2table on your group data. Upon completion (you should see the progress in the terminal
screen), then the ’Generate Stats Data Tables’ button becomes a menu-selection list. Within that menu,
you can select ’aseg.volume’. Upon doing so, the volumetric data for various subcortical structures are
displayed. You could choose for example ’Left-Lateral-Ventricle’, then click ’Add Selection to Data 
Table’. Upon doing so, it will appear in the ’Discrete and Continuous Factors’ display of the ’Data Table
View’. ’Left-Lateral-Ventricle’ is now available as a possible factor in your analysis (’Left-Hippocampus’
and ’Right-Hippocampus’ were imported from aseg.volume in this manner). If you select
’Left-Lateral-Ventricle’ in the ’Data Table View’, then the volumetric data for all the subjects is plotted.
You can look for patterns or outliers. If you suspect an outlier, right-click on that point in the scatter-plot.



You can then either exclude that subject, or examine it in tkmedit or tksurfer, to check for possible
problems in the original scan data. Lastly, you can save this newly imported data (in this case,
’Left-Lateral-Ventricle’) to your qdec.table.dat file by selecting ’Save Data Table’ from the File menu (but
dont do this for the tutorial). 

1.4.3. Design

When you click-over to the Design tab your discrete (gender) and continuous 
(age, Left-Hippocampus, Right-Hippocampus and Left-Lateral-Ventricle) 
factors should appear.



You can select up to four factors in the Design tab to regress against. For the tutorial data, you could
select ’gender’ and ’age’ (or ’Left-Hippocampus’, as long as just one Continuous Factor is selected). 
Nuisance Factor menu in Design tab allows selection of any number of continuous variables of which
will be treated as ’nuisance variables’ in the glm (contrast matrix will have value ’0’ for these). For
simplicity in this example, choose only ’age’ in the Continuous variables menu, leaving the ’Measure’,
’Hemisphere’ and ’Smoothing’ at their defaults (thickness, lh and 10mm). Before you click the ’Analyze’
button you will want to name your Design, something like ’lh-thickness-age-fwhm10’, and enter that into
the "Design Name" text entry box at the top of the window. Now click the ’Analyze’ button and the
stats-engine will begin processing, executing the mri_glmfit executable. Upon clicking ’Analyze’, the
terminal will display the output of this processing. Also, progress information is shown in the bottom bar
of the Qdec application. An analysis make take a minute or two. 



1.4.4. Display

Once the analysis is complete (taking up to several minutes for a large subject set), you can click the
Display tab and the fsaverage inflated surface will appear in the display window. You will see a list of
questions summarizing the various analyses that were completed. 



You can click on one of these questions to load the results. If you click on Does the correlation between
thickness and age differ from zero it will display the statistically significant regions where age and
thickness are correlated. Here is an example display: 



’FindClustersAndGotoMax’ button runs mri_surfcluster on a selected result, which will find clusters
based on currently selected display threshold, output a table of results to the terminal, and move the cursor
to the max vertex in the #1 cluster. ’Next’ and ’Prev’ buttons allow cycling movement of the cursor
through the found clusters. On the displayed image, notice the green cross-hairs that indicate the vertex
you have currently selected. You can change vertices and display a plot of the data for a particular vertex
by left-clicking on a point while holding-down the Ctrl key. If you’d like to turn off the cursor display you

can use the  button. Here is an example plot that corresponds to the shown selected vertex: 



The plot shows your measure on the y-axis (vertical) - in this case, cortical thickness - and the variable on
the x-axis (horizontal) - in this case, age. Each data point on the plot is representative of an individual
subject, denoting their age and cortical thickness at the vertex you have selected. For this example at this
vertex, we can see that the cortex is thinning with age. The information at the bottom of the both the plot
window and the Qdec window shows that this vertex has surface coordinates (-15.16, 7.58, 48.75) and is
Vertex# 102319. The significance value is -5.44 and it is in the precentral region. The significance in this
display is a -log(10)p value, and not a straight p value. 

In addition to this you can also do correction for multiple comparisons by Monte Carlo cluster-wise
simulation making use of pre-run data, making run-time near instantaneous. 

1.4.5. Interacting with your data

Rotating, Panning and Zoom You can rotate the display, hold-down the left mouse button and move the
mouse. Holding-down the middle button while moving the mouse will move the display in the window.
Holding-down the right mouse button while moving will zoom the display. 



There are buttons at the top of the Qdec display that will rotate and zoom as well:

 - rotates up 90 degrees

 - rotates down 90 degrees

 - rotates right 90 degrees

 - rotates left 90 degrees

 - rotates counterclockwise 90 degrees

 - rotates clockwise 90 degrees

 - zoom out

 - zoom in

If you get it rotated too far, the home button  will reset it. 

Parcellation Display The cortical parcellation is loaded into Qdec upon opening. On the Display tab you
can adjust the annotation opacity. There may be a slight delay while the display updates, be patient! 
Sliding the button to the right will begin to show the parcellation annotation underneath the overlay. You
can bring the opacity to a level that is useful in your interaction with the data. When you have selected a
point, which is accomplished by holding down the ctrl key and left-clicking the mouse, the information at
the bottom of the window will tell you what region, or parcellation unit, the point is found. 

Significance Thresholds 

You can also adjust the threshold levels for the overlay on the Display tab. 

When setting a color scale, you’re interested in two things: the threshold (i.e., the value below which the
vertex will be transparent - Min), and the saturation point (i.e., the value beyond which the color will not
change - Max). In Qdec you can also specify the point where the color will reach the midpoint, with Mid
on the control panel (by default Mid is set to just higher than Min. The meaning of these thresholds
depends upon the nature of the data you have loaded as the overlay. The map you are currently viewing is
-log10(p), where p is the significance, so a Min of 2 will display all vertices with p<.01 and a Max of 5
will show vertices of p<.00001 as the same color. You can lower the threshold to 1.3, 2, 3, to show all
vertices with p<.05. You could raise the threshold to 4, 5, 6 to show all vertices with p<.0001. 

1.4.6. Variations on Design

With Qdec it is easy to design and run a variety of different analyses. For the first example we looked
simply at age and thickness in our subjects. Click back to the Design tab and select gender, to add it to
the design. You will want to change the name of the design, call it ’lh-thickness-age-gender-fwhm10’, and
click Analyze. When the analysis is done running, click the Display tab and see that there are



additional questions in the list summarizing the various analyses that were completed. Among the
questions displayed now are Does the Thickness--age correlation differ between male and female? and 
Does the average thickness differ between male and female? Click on one of these questions to display
the statistically significant regions where the age and thickness correlation are different in men and
women, or the average thickness is different in men and women (respectively). Similarly, you can add in
one of the other continous variables - hippocampal volume - and run that design. 

You can change your design even more, if you click back to the Design tab, you can change your
measure from thickness to something else - area, area.pial, volume, sulc, curv, and jacobian_white are
your choices. You can also change your level of smoothing - 0, 5, 10, 15, 20, and 25 are your choices. And
you can perform any of these on the left (lh) or right (rh) hemispheres. Take a few minutes to select a new
design to run, remember to call it something new before you hit Analyze so that the directory of results
can be saved. 

1.4.7. Define a Region of Interest

FreeSurfer has the ability to compute statistics averaged over a defined region of interest (ROI), which is
another popular way to test statistical hypotheses and a good way to check your data. To define a label that
marks a region of interest (ROI) on the surface hold down shift then left click and drag to draw your ROI.
When drawing your ROI, draw slowly, allowing the display to catch up with you if necessary. There is no
need to worry about closing the ROI precisely, when you are done and release the mouse button QDEC
will automatically close the ROI for you. You should then see a green outline of the ROI you drew, like
this: 



You can then select the add the selection to the ROI button  , and your label should now be filled in
with purple, like this: 



If you do not add your label to the ROI and you start to draw again, QDEC will erase your first label and
begin a second. If you have added something to the ROI and want to remove it you can use the remove

selection from ROI button  . When you are finished you can save your label by selecting File -->

Save Label or clicking the  save label button. A dialog box will pop up, and you can choose the
location and name to save your label. For this example you can call your label lh.supramarg.label, since
it is a label of the supramarginal gyrus, and click Save. 

It may then be useful to map this label to all of the individual subjects in your group study, to either
extract statistical values from this region or to visualize the area on each subject to check the integrity of
your results. You can do this automatically by selecting File --> Map Label to Subjects..., a dialog box
will pop up asking for the label name, you can enter everything before the .label of the name, so for this
example enter lh.supramarg, and click Ok (OPTIONAL as it takes a few minutes for this to finish). This
will use mri_label2label to map this label from your average surface onto all the subjects in your study.
When it is complete (this can take several minutes) each subject will have a file named 
lh.supramarg.label in its label subdirectory. But for tutorial purposes, you can run the following
command to map the label onto a subject. 



mri_label2label --srclabel lh.supramarg --srcsubject fsaverage --trgsubject 004 --trglabel lh.supramarg --regmethod surface --hemi lh

The above command creates the label lh.supramarg.label in 004/label/ directory. This label can be loaded
onto each subject’s surface in tksurfer, or opened on the volume in tkmedit (not shown in this tutorial). 

mris_anatomical_stats You can use mris_anatomical_stats to get a set of statistics on each
individual label you’ve created. The command to run this on the label lh.supramarg.label that you
generated for subject 004 is: 

cd $SUBJECTS_DIR
mris_anatomical_stats -l lh.supramarg.label \
  -t lh.thickness -b -f 004/stats/lh.supramarg.stats 004 lh

This will output a stats file to 004/stats/lh.supramarg.stats, which looks like this. This file
gives the number of vertices, surface area, gray matter volume, average thickness and st. deviation, mean
curvature, gaussian curvature, folding index, and curvature index for this region only. You can run this
same command on all your subjects to generate these statistics. You could then use aparcstats2table to
generate one space delimited table of all these measures for your subjects. 

In addition, it might be a good idea to visualize this label on each subject, to be sure there is not a defect in
the surface causing your result. You can look at your label in tkemdit on the volume with the command: 

tkmedit 004 brainmask.mgz -label lh.supramarg.label

If you scroll towards the posterior end of the brain (coronal slice 80), you will find your label. Typically
you would load the surfaces as well, but for this tutorial, it is easier to find the label without them. 



1.4.8. Correction for Multiple-Comparisons

See this page for information on support for correction for multiple comparisons in Qdec. Note that it is
not a tutorial. A more in-depth tutorial on this subject is found here. 

1.4.9. Miscellaneous

Qdec supports some customizations via the .Qdecrc file. 

(end of qdec tutorial) 
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1. FreeSurfer Tutorial: Applying FreeSurfer Tools to FSL fMRI
Analysis (FEAT)
The purpose of these series of exercises is to give you some familiarity with integrating FreeSurfer and
FSL’s functional analysis. The main challenge in the integration is getting a subject’s anatomical data
properly registered with their functional data. Once registered, you can use FreeSurfer display tools to
visualize your FSL functional activation maps on the subject’s anatomical volume and on the surface. You
can also convert to the common surface space for group analysis with mri_glmfit or FSL’s flame or
randomise. 

For structural data, we will use ${SUBJECTS_DIR}/bert and ${SUBJECTS_DIR}/fsaverage. For
functional data, we will use fbert1.nii.gz and fbert2.nii.gz. The functional data set consists of two runs, 85
volumes each, 64 x 64 x 35 voxels, with size 3.4375 x 3.4375 x 4.0 mm^3. TR = 3 sec. The experiment is
a periodic block design with 15 sec ON blocks of simultaneous finger tapping, flashing checker board, and
auditory tone. The OFF blocks are rest periods. The paradigm starts with an OFF block. The FEAT
functional analysis has already been done, and the runs have been combined with GFEAT (Fixed-effects,
one-sample group mean). This data was smoothed in the volume at 5mm, but when preparing for a group
surface-based analysis, we recommend that you smooth on the surface prior to group analysis and not
smooth in the volume at all (or less than the voxel size) You can download the tutorial data from here. 

Throughout the tutorial, it will be assumed that you are in the fbert-feat directory. If you list the directory
(ls), you will see: 

fbert1.nii.gz -- run 1 raw functional data
fbert1.design.fsf -- run 1 FEAT design
fbert1.feat -- run 1 FEAT directory design
fbert2.nii.gz -- run 2 raw functional data
fbert2.design.fsf -- run 1 FEAT design
fbert2.feat -- run 2 FEAT directory design
fbert.gfeat -- runs 1 and 2 combined in FFx model
run-fsfeat-tut -- script to run through all the non-interactive components

You will see some other files/directories there too, but these are the most important. 

1.1. 1.0 Registration

The registration process computes a matrix that maps the FEAT example_func to the subject’s anatomical
using FLIRT. This matrix can then be used in later steps to display functional maps on the anatomical
volume and the surface. 

Exercise A. Registering FSL Feat output to the anatomical 



1.2. 2.0 Overlaying onto Same-Subject Anatomical

The statistical maps from Feat may be overlaid onto the subject’s anatomical volume, the surface derived
from the anatomical volume, or the FSL’s standard volume. All these options are described in the
following exercise. 

Exercise B. Overlaying FSL Feat statistical maps 

1.3. 3.0 Surface-based Group Functional Analysis

The statistical maps from Feat may be overlaid onto the subject’s anatomical volume, the surface derived
from the anatomical volume, or the FSL’s standard volume. All these options are described in the
following exercise. 

Exercise C. Surface-based Group Analysis 

1.4. 4.0 Mapping automatic segmentations

FreeSurfer automatically generates cortical and subcortical segmentations from the subject’s anatomical
data. These segmentations can be mapped into the functional space for performing region of interest (ROI)
analysis. Then, the segmentation for a particular structure can be extracted to create a binary mask. Go
through the following exercise for details. 

Exercise D. Mapping automatic segmentations to the functional space 
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1. Registering FSL Feat output to the anatomical
The registration is a multi-step process. Each step is described in detail below. 

1.1. Preparations

To begin the exercises, first enter the following: 

1.1.1. If You’re at an Organized Course

If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR/fbert-feat
ln -s $FREESURFER_HOME/subjects/fsaverage
ln -s $FREESURFER_HOME/subjects/bert

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 

1.1.2. If You’re not at an Organized Course

If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR/fbert-feat
ln -s $FREESURFER_HOME/subjects/fsaverage
ln -s $FREESURFER_HOME/subjects/bert

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 



The subjects ’fsaverage’ and ’bert’ may already exist in the subjects directory, so ignore any warnings that
might be issued that say ’File exists’. 

1.2. 1.1 Automatic registration

The program that performs the registration is called reg-feat2anat (which uses FLIRT to do the actual
computations). Information about how to run this program and what this program is doing can be obtained
with: 

reg-feat2anat --help

Now, run the registration for bert’s first fMRI data: 

reg-feat2anat --feat fbert1.feat --subject bert

Verify that this created directory fbert1.feat/reg/freesurfer. There are several files with matrices in them.
The most important one is anat2exf.register.dat. 

1.3. 1.2 Manual Checking/Editing the registration

You should ALWAYS visually check your registration. This is done with tkregister2 through
reg-feat2anat. This program brings up a GUI which allows you to inspect and interactively edit the
registration matrix. tkregister2 is a complicated with lots of features. You can get a full help on it with: 

tkregister2 --help

To check the registration computed in the previous step, run: 

reg-feat2anat --feat fbert1.feat --manual

You will see the following GUI window: 



You will also see an anatomical similar to the one on the left below. Pressing the "COMPARE" button
will allow you to flip between the anatomical (left) and functional (middle). The green line is the orig
surface. It is the same in both the anatomical and functional. The right is the same image as the middle
without the surface. 



1.4. 1.3 Navigating through tkregister2

tkregister2 is controlled through the interface and through keypress commands. When using a keypress
command, the image window must have control of the cursor; this can be accomplished by clicking in the
image window. Here are some useful commands. 

A. To switch between the functional and anatomical, press the "COMPARE" button.
B. To change orientation, press the CORONAL, SAGITTAL, or HORIZONTAL button.
C. To change slice, operate the slider.
D. To change the functional brightness, change the value in the "fmov" entry box. Or you can use the ’i’
keypress command to turn on automatic intensity normalization.
E. To toggle the surface on and off, use the ’s’ keypress command.

You can get more information on keypress commands and general usage with: 

tkregister2 --help.

1.5. 1.4 Evaluating the registration

The first step in evaluation is to make sure that there was no catastrophic failure, e.g., the functional is
rotated by 90 degrees with respect to the anatomical, or is shifted by a large amount. Such failures are
usually caused by failures in the registration to standard space (see section on troubleshooting). 

The second step is to make sure there was not a left-right flip. This is tricky because the brain is very
symmetrical. However, the cortical folding patterns often have subtle asymmetries. In general, you cannot
see the folding patterns in the functional, but you can see the CSF which will also follow the surface (see
the images above). Make sure that asymmetries in the (green) surface are present in the CSF. 



The final step is to check the alignment. This is done by making sure that green surface follows the
contour of the CSF. 

1.6. 1.5 Pitfalls

There are several ways in which the registration may be good but can appear bad. First, don’t evaluate the
registration in areas known to have B0 distortion (e.g., orbital frontal, medial temporal lobe). Second, be
careful using the ventricles for alignment. The anterior portion is often susceptible to B0 distortion. Third,
if it looks like the surface cuts through a CSF fold, look at adjacent slices to see if it lines up better. This
can happen because functional voxels are so big. Finally, be careful trying to use what looks like the edge
of the brain in the functional. For example, in the middle image above, it looks like the surface extends
beyond the top of the brain. However, if we adjust the brightness (set fmov to 1; see image below), one
can clearly see that the surfaces are actually in brain. 

1.7. 1.6 Editing the registration

If for some reason you do not believe that the automatic registration is sufficiently close, you can edit the
registration manually. tkregister allows you to translate, rotate, and scale the brain using the sliders on the
right side of the GUI. All the modifications happen in the viewing plane. The rotations are about the red
cross. Note: you should not need to adjust the scale (ie, stretch the brain) because both brains belong to the
same person. This is equivalent to contraining the registration to be rigid (ie, 6 DOF). When done, press
the "SAVE REG" button. Note that if you modify the registration, don’t re-run reg-feat2anat as that will
overwrite your edits. As an exercise, try translating the functional. First, view the functional and then
move the "TRANSLATE" slider. You will see the functional brain translate (the green surface will be
fixed). DON’T save the registration (if you do, then just re-run reg-feat2anat).You can get more
information on editing the registration with: tkregister2 --help. 



1.8. 1.7 Check FEAT registration to Standard Space

This registration tool can be used to check and adjust the FEAT registration to standard space with: 

reg-feat2anat --feat fbert1.feat --manxfm func2std
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1. Overlaying FSL Feat statistical maps

1.1. Preparations
In this exercise, the data set of subject bert is used for demonstration. Type the following prior to
beginning the exercises: 

1.1.1. If You’re at an Organized Course

If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR/fbert-feat
ln -s $FREESURFER_HOME/subjects/fsaverage
ln -s $FREESURFER_HOME/subjects/bert

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 

1.1.2. If You’re not at an Organized Course

If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR/fbert-feat
ln -s $FREESURFER_HOME/subjects/fsaverage
ln -s $FREESURFER_HOME/subjects/bert

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 



The subjects ’fsaverage’ and ’bert’ may already exist in the subjects directory, so ignore any warnings that
might be issued that say ’File exists’. 

1.2. 1.0 Overlaying the statistical map onto the bert’s orig 
volume
Use the following command to display the zmap (zstat1.nii.gz) from the first run overlaid onto the bert’s
orig volume. It will display the automatic segmentation, and will also set the threshold at z = 2.3: 

 tkmedit bert orig.mgz lh.white -aux brain.mgz \
   -overlay ./fbert1.feat/stats/zstat1.nii.gz \
   -overlay-reg ./fbert1.feat/reg/freesurfer/anat2exf.register.dat \
   -segmentation aparc+aseg.mgz  -fthresh 2.3 -fmax 4.3

You should see the image below:

When you click or mouse over a voxel, the cortical or subcortical structure that that voxel belongs to will
be displayed in the control panel. You can view any of the volumes in the stats dir in this way as well as
the clustered maps in the feat directory. 

1.3. 2.0 View statistical maps on bert’s surface
To view any of the statistical maps on bert’s surface, close the tkmedit GUI (or open a new terminal
window) and run: 



tksurfer bert lh inflated \
  -overlay ./fbert1.feat/stats/zstat1.nii.gz \
  -overlay-reg ./fbert1.feat/reg/freesurfer/anat2exf.register.dat \
  -fthresh 2.3 -fmid 3.3 -fslope 1 -annot aparc.annot

Change the cortical parcellation to outline mode with View->LabelStyle->Outline. You should see the
image below:

When you click or mouse over a vertex, the control panel will display the name of the cortical structure.
You can view any of the volumes in the stats dir in this way as well as the clustered maps in the feat
directory. You can also run the tkmedit and tksurfer commands above in separate shells and use the
Save-Point/Goto-Point functionality to navigate through the volume and surface. 

1.4. 3.0 Displaying Same-Subject, Cross-Run GFEAT Results
Typically, one collects more than one run/series of functional data for each subject. The individual runs
are analyzed separately, then combined in standard space with GFEAT using a fixed-effects model. Since
the data are no longer in the subject’s native functional space, a different registration matrix is needed to
map the GFEAT results to the individual. Each run of reg-feat2anat will create a 
reg/freesurfer/anat2std.register.dat. Any one of these can be used to map the GFEAT data to the subject’s
anatomy. 

First, verify that the registration is good with: 

tkregister2 --mov fbert.gfeat/mean_func.nii.gz --surf \
  --reg fbert1.feat/reg/freesurfer/anat2std.register.dat



mean_func.nii.gz is the mean of the example_func’s in standard space. Since this is the mean func, it will
be blurry if you have spatially smoothed. Note: if there is a problem with this registration, you need to
repair the registrations for each individual run. 

Now show gfeat results on anatomical volume: 

tkmedit bert orig.mgz -seg aparc+aseg.mgz \
  -ov fbert.gfeat/cope1.feat/stats/zstat1.nii.gz \
  -ovreg fbert1.feat/reg/freesurfer/anat2std.register.dat \
  -fthresh 2.3 -fmax 4.3

Here we’ve used the anat2std.register.dat from the first run. 

Now show gfeat results on the surface: 

tksurfer bert lh inflated -annot aparc.annot \
  -ov fbert.gfeat/cope1.feat/stats/zstat1.nii.gz \
  -ovreg fbert1.feat/reg/freesurfer/anat2std.register.dat \
  -fthresh 2.3 -fmid 3.3 -fslope 1
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1. Preparations

1.1. If You’re at an Organized Course

If you are taking one of the formally organized courses, everything has been set up for you on the
provided laptop. The only thing you will need to do is run the following commands in every new terminal
window (aka shell) you open throughout this tutorial. Copy and paste the commands below to get started: 

setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR/fbert-feat
ln -s $FREESURFER_HOME/subjects/fsaverage
ln -s $FREESURFER_HOME/subjects/bert

To copy: Highlight the command in the box above, right click and select copy (or use keyboard shortcut
Ctrl+c), then use the middle button of your mouse to click inside the terminal window (this will paste the
command). Press enter to run the command. 

These two commands set the SUBJECTS_DIR variable to the directory where the data is stored and then
navigates into this directory. You can now skip ahead to the tutorial (below the gray line). 

1.2. If You’re not at an Organized Course

If you are NOT taking one of the formally organized courses, then to follow this exercise exactly be sure
you’ve downloaded the tutorial data set before you begin. If you choose not to download the data set you
can follow these instructions on your own data, but you will have to substitute your own specific paths and
subject names. These are the commands that you need to run before getting started: 

tcsh
source your_freesurfer_dir/SetUpFreeSurfer.csh
setenv SUBJECTS_DIR $TUTORIAL_DATA/buckner_data/tutorial_subjs
cd $SUBJECTS_DIR/fbert-feat
ln -s $FREESURFER_HOME/subjects/fsaverage
ln -s $FREESURFER_HOME/subjects/bert

Notice the command to open tcsh. If you are already running the tcsh command shell, then the ’tcsh’
command is not necessary. If you are not using the tutorial data you should set your SUBJECTS_DIR to
the directory in which the recon(s) of the subject(s) you will use for this tutorial are located. 

The subjects ’fsaverage’ and ’bert’ may already exist in the subjects directory, so ignore any warnings that
might be issued that say ’File exists’. 



2. 1.0 Resampling COPEs to common surface

3. 1.1 Individual Runs for a Subject

In order to perform surface-based group analysis, you need to have all the copes sampled into a common
space. This is done with mris_preproc: 

mris_preproc --target fsaverage --hemi lh --fwhm 5 \
  --out xrun/lh.cope1.mgh \
  --iv fbert1.feat/stats/cope1.nii.gz fbert1.feat/reg/freesurfer/anat2exf.register.dat \
  --iv fbert2.feat/stats/cope1.nii.gz fbert2.feat/reg/freesurfer/anat2exf.register.dat

In this case, the common space is the left hemisphere of fsaverage. Surface-based smoothing of 5mm
FWHM is used. The output lh.cope1.mgh looks like a volume because it is in mgh format, but it is really a
surface stored in a volume format (note it’s dimensions are 1974 x 1 x 83 = 163842 = number of vertices
in fsaverage’s surface). It has 2 frames, one for each run. 

Note that each volume (cope1.nii.gz) is accompanied by a registration matrix (anat2exf.register.dat). The
above example extracts data from each run of the same subject. If you have multiple subjects, you can 
specify the gfeat/cope1/stats/cope1.nii.gz paired with the anat2std.register.dat matrix. 

You can also extract the cope variances (varcopes) in the same way: 

mris_preproc --target fsaverage --hemi lh --fwhm 5 \
  --out xrun/lh.varcope1.mgh \
  --iv fbert1.feat/stats/varcope1.nii.gz fbert1.feat/reg/freesurfer/anat2exf.register.dat \
  --iv fbert2.feat/stats/varcope1.nii.gz fbert2.feat/reg/freesurfer/anat2exf.register.dat

4. 1.2 Runs combined in a GFEAT within a Subject

Once the runs are combined in a GFEAT analysis, they are no longer in the native functional space but
rather in the standard space. You can still use the surface-based analysis as long as the subjects have not
been combined together. To do this, you just need the appropriate registration matrix that takes the data
from standard space to the subject’s anatomical. This is computed when you run reg-feat2anat. Each run
will have this matrix, but they should all be the same. Eg: 

mris_preproc --target fsaverage --hemi lh --fwhm 5 \
  --out xsubject/lh.cope1.mgh \
  --iv fbert.gfeat/cope1.feat/stats/cope1.nii.gz fbert1.feat/reg/freesurfer/anat2std.register.dat \
  --iv fnick.gfeat/cope1.feat/stats/cope1.nii.gz fnick1.feat/reg/freesurfer/anat2std.register.dat \
  ...

The cope is specified from the gfeat, but the registration matrix is specified from the feat from the first run
of each subject. The output can be used in the surface-based group analysis below. 



5. 2.0 Surface-based Group Analysis

Once you have the copes in the common surface space, the (nearly) same as you would with a thickness
study. With a functional study, you also have the flexibility to run fixed- and weighted random-effects 
analysis. 

The command below can be used to run a fixed-effects analysis across both runs. Normally, you would
probably run a random effects or weight random effects analysis, but since we only have two runs here,
we’ll use a fixed-effects. The dof=163 is the sum of the dofs from fbert?.feat/stats/dof. The model here is a
simple one-sample group mean (OSGM) in which the design matrix is simply a column of 1s. For more
elaborate designs, use an FSGD file instead of --osgm. 

mri_glmfit --y xrun/lh.cope1.mgh --yffxvar xrun/lh.varcope1.mgh --ffxdof 163 \
           --osgm --glmdir xrun/lh.osgm.ffx --surf fsaverage lh \
           --label $SUBJECTS_DIR/fsaverage/label/lh.cortex.label

This will create a directory called xrun/lh.osgm.ffx: 

ls xrun/lh.osgm.ffx
ar1.mgh -- spatial AR1 map
beta.mgh -- regression coefficients (same as PEs)
fwhm.dat -- estimate of spatial FWHM (not valid with 2 data points)
mask.mgh -- binary mask (if used)
mri_glmfit.log -- log file
osgm -- contrast directory
rstd.mgh -- residual standard deviation
rvar.mgh -- residual standard variance
Xg.dat -- design matrix (text)
X.mat -- design matrix (matlab)

The most important results are in the contrast directory: 

ls xrun/lh.osgm.ffx/osgm
C.dat - contrast matrix
cnr.mgh - contrast-to-noise ratio
F.mgh - F ratio
gamma.mgh - contrast size (same as COPE)
maxvox.dat - info about the vertex with max F stat
sig.mgh - significance map (-log10(p))

To view the higher-level results, run: 

tksurfer fsaverage lh inflated  \
  -overlay xrun/lh.osgm.ffx/osgm/sig.mgh  \
  -fthresh 2 -fmid 3 -fslope 1 -annot aparc.annot

There are several differences between this invocation of tksurfer and the one used during the individual
analysis before: 



The subject is fsaverage, not bert 
The input is a sig map, which is -log10(p) 

The thresholds are significance thresholds, not z. So, 2 means p < .01. 

6. 3.0 Alternative method to resample COPEs to common surface

This command will resample the copes to the common surface space, but does not concatenate them
together as mris_preproc does. Rather, it stores the result in fbert1.feat/reg_surf-lh-fsaverage/stats for the 
left (reg_surf-rh-fsaverage for right). 

feat2surf --feat fbert1.feat --cope-only
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1. FreeSurfer Tutorial: FreeSurfer Tools
Tkmedit and tksurfer are two important tools in the FreeSurfer package. 

Tkmedit displays volumetric anatomical data and allows the user to navigate through that data and view it
from different orientations. Tkmedit also displays other data types such as functional data and surfaces as
overlays onto this anatomical data. 

Tksurfer displays surface data and allows the user to navigate through that data and view it from different
orientations. Tksurfer also displays other data types such as functional data and curvature as overlays onto
this surface data. 

Tkmedit and tksurfer are described in detail below. 

1.1. 1.0 Tkmedit

Interface 

General usage 

Working with data 

Quick reference 

1.2. 2.0 Tksurfer

Interface 

General usage 

Working with data 

Quick reference 
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1. Tkmedit interface
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1. General usage

1.1. 1.0 Quick start

Tkmedit is started by one of two methods: using the tkmedit-sess script, or invoking it from the command
line with the tkmedit command. Depending on which method you use, you may see different types of data
loaded, but all methods require an anatomical data set to be loaded. Other types of data can be loaded from
the File menu. 

To explore your data, you can move the mouse over the picture of the volume (the Display Window) and
see information about the area under the mouse in the window on the bottom (the Tools Window). You
can change the view with the orientation buttons (the ones shaped like cross-sections of the head labeled
’C,’ ’H,’ and ’S,’ which stand for Coronal, Horizontal and Sagittal) and the slice number field in the
Navigation Toolbar. To save pictures of your data, go to the Tools menu and select the Save RGB item
near the bottom. 

1.2. 2.0 Viewing area

Tkmedit consists of two windows. The top window, called the Display Window, shows the currently
displayed slice. Multiple panes can show multiple orientations and configurations. The bottom window,
called the Tools Window, contains the controls and feedback information. Here is the interface. 

Information about the currently displayed data can be obtained by moving the mouse over the Display
window or by clicking to set the cursor. As the mouse is moved in the display window, the mouseover
section of the Tools window will display information about the voxel (or volume element) under the tip of
the mouse arrow. Alternatively, most tools set the cursor upon clicking with the left button. The Cursor
section of the Tools window displays information about the voxel under the cursor. By default, the cursor
is drawn as a red cross. Guidelines are drawn on the sides of the Display Window to help locate the
cursor. 

It is possible to display multiple orientations of data simultaneously in the Display Window. This is done
by splitting the window up into multiple viewing panes, each with a different slice, orientation, or other
viewing characteristics. The cursor can be linked between so that a click in one pane to set the cursor will
update the cursor in all the other panes. There are three built-in configurations: Single View, Multiple
Views, and Mosaic View. These can be activated by clicking on the appropriate icon in the Navigation

Toolbar (  Single,  Multiple,  Mosaic) or by choosing the appropriate item in the View menu. 

In the latter two views, there is more than one pane in the Display Window. A green border is drawn
around the active pane. To make another pane active, click in it to set the cursor. The mouseover section
of the Tools Window will only display information about the voxel under the mouse if it is in the active
pane. 



2.1 Single view 

This is the default view. It is the simplest and fastest view for tkmedit to render. 

2.2 Multiple views 

This viewing mode divides the window into four panes. Each of the three orientations is shown, with one
orientation duplicated. This configuration is optimal for viewing all planes around a single point. By
default, the cursor is linked so that setting it in one view moves the current slice in all other views to the
cursor’s location in that view’s orientation. 

2.3 Mosaic view 

When mosaic view is first activated, the volume is sliced up in the orientation of the last active pane.
Sixteen panes are created, each showing a different slice in the same orientation. Note that this mode is
slow on most machines and is not optimal for ’live’ navigation. It is mainly provided as a way to set up a
view to be printed or saved to an image file. 

1.3. 3.0 Navigation

3.1 Changing slices 

The current slice can be changed with the controls on the right side of the slice label in the Navigation

Toolbar, with the mouse button 2 with the Navigation Tool (  ), or with the arrow keys. The current

orientation can be changed by clicking on the appropriate button in the Navigation Toolbar (  coronal, 

 horizontal, or  sagittal) or by pressing the ’X,’ ’Y,’ and ’Z’ keys. 

With the Navigation Tool active, clicking with button 2 in the top half of the screen increases the slice
number by 1, and clicking in the bottom half decreases it by 1. Clicking in dragging will continuously
change the slice number; dragging up will increase the slice number, dragging down will decrease it. 

3.2 Zooming 

The view in any pane may be zoomed in to magnify the size of a voxel. The current zoom level is
displayed both in the Navigation Toolbar and on the Navigation Toolbar. The zoom level may be changed
in three ways: 

1.  By holding down the control key and clicking with button 1 to set the cursor and zoom in, or button 3
to zoom out. This works with any tool active. 

2.  By clicking on the zoom buttons in the toolbar or the zoom slider in the display area, zooming in or
out around the cursor but not set the cursor. 

3.  By activating the Navigation Tool and clicking with button 3. Clicking in the top half of the Display
window zooms in, and clicking in the bottom half zooms out. Clicking and dragging up continuously
zooms in, and dragging down zooms out. This operation does not change the cursor. 



3.3 Panning 

While zoomed in, you will not be able to see the entire slice. To pan around in the current slice, you may
hold down the control key and click with button 2 to set the cursor and re-center, or activate the
Navigation Tool and click and drag with button 1 Using that Navigation Tool will not change the cursor. 

As you can see, navigation is primarily down in a modal fashion with the Navigation Tool or at any time
with the control-click combinations, although the Navigation Tool is more intuitive and also allows slice
changing. You will probably benefit from using both methods. 

1.4. 4.0 Cursor

The cursor serves two main purposes. It acts as a central focus point when multiple viewing panes are
open, and it selects a voxel whose information will be displayed in the Tools Window. It also serves as a
kind of bookmark for sharing cursors with tksurfer, as a centroid for rotation, selecting a voxel to be
graphed in the Time Course Window, and other various functions, explained later. 

4.1 Linked cursors 

When the viewing area is split into multiple panes, each panel may have a separate cursor location. If
cursor linking is active, setting the cursor in one panel will set the cursor in all panes. Cursor linking can

be activated with the  button on the Main Toolbar. 

For example, in the Multiple Views configuration, setting the cursor in the coronal pane will change the
slice in the horizontal and sagittal planes. So the cursor becomes a way of navigating through the volume
using the three orientations. 

Depending on the viewing configuration, with Linked Cursors active, other attributes are linked as well,
including zooming and display flags. In Mosaic View mode, only the in-plane cursor coordinates will be
linked, so the slice in each pane will be the same. However, if the slice number is increased in one pane,
the slice number will be increased in all other panes. 

4.2 Cursor and mouse information 

The bottom of the Tools Window displays information about the voxel under the cursor (on the left) and
the mouse (on the right). The information displayed depends on the kind of data loaded. If only an
anatomical volume is loaded, only the volume index coordinates, volume Talairach coordinates, and
volume value will be displayed. (If for some reason a Talairach transform could not be found, RAS (Right
Anterior Superior) coordinates will be displayed instead.) The Talairach coordinates reported are based on
Matthew Brett’s 10/8/1998 non-linear transform from MNI305 space. The MNI305 coordinates are also
available, but are turned off by default (select View->Information->MNI Coordinates). 

As other data are loaded, more information will appear in this area. For example, if a functional overlay is
loaded, the functional overlay value will appear in this area. Alternatively, the data shown can be changed
in the View->Information menu. 



1.5. 5.0 Saving images

You can save the contents of the Display Window to a picture file. Tkmedit uses the RGB format, a simple
format readable by most image programs. To save a single picture, choose Tools->Save RGB.... You may
want to turn off the cursor or other view items in the View menu before saving your picture. 

You can also save a series of images with the Tools->Save RGB Series... command. This command steps
through slices in the current orientation and saves an image of each. You choose a directory and prefix for
the file names as well as the range of slices to step through. For example, if you choose /tmp for the
directory, "image" for the prefix, and 5 and 8 for the start and end, it will create /tmp/image005.rgb,
/tmp/image006.rgb, /tmp/image007.rgb, and /tmp/image008.rgb. 

1.6. 6.0 Tips

Most volume input operations can take many different kinds of volumes. If the volume is a bfloat or
bshort volume, select one of the .bfloat or .bshort files. If the volume is a COR volume, select the
COR-.info file or just enter the directory without any file names. 

Tkmedit uses the Tk toolkit (http://www.tcl.tk) for its interface (the ’Tk’ in ’tkmedit’). A nice feature
of this toolkit is that all the menus are detachable and can become a separate window that stays up all
the time. This is particularly useful when using the View menu. Just click on the top line of the menu
when it comes down from the menu bar, and a window will take its place. 
Learn the keyboard shortcuts for volume navigation. 

The ’x’, ’y’, and ’z’ keys will change orientations. 
The arrow keys will change slices. 
You can zoom in with Ctrl + (Ctrl-Shift =) and out with Ctrl -. 
You can also jump to the Navigation Tool by hitting the ’n’ key and click around the volume,
then return to the tool you were using previously. 

If you are using tkmedit with the expected directory structure at the NMR-MGH center, tkmedit will
automatically look in certain places for files. See the File Name Substitution section. 
Find yourself using certain toolbars? You can set environment variables to automatically hide or
show without using the View menu. Set TKMEDIT_TOOLBAR_MAIN,
TKMEDIT_TOOLBAR_NAV, or TKMEDIT_TOOLBAR_RECON to 0 or 1 to hide or show the
main, navigation, or reconstruction toolbars, respectively. 
All file dialog boxes have a menu at the top which you can use to jump to specific directories to find
data quickly. Additionally, you can specify your own shortcut directory by setting the environment
variable FREESURFER_DATA. 
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1. Working with data

1.1. 1.0 Anatomical volumes

1.1 Main and aux volumes 

Tkmedit can hold two anatomical volumes in memory at the same time, called the Main volume and the
Aux volume. Although it can not display them together at the same time, clicking on a voxel in one
volume will display that value at that voxel in both volumes. 

The Main volume is considered the central data object in tkmedit. All other data is displayed relative to
the Main volume. The subject name and Main volume name are displayed in the title bar of the Display
Window. If an Aux volume is loaded, its name is displayed in parentheses next to the Main volume name
in the title bar. 

If both volumes are loaded, you may select which volume is displayed by choosing Main Volume or Aux

Volume in the View menu, or by pushing in the appropriate button (  for Main and  for Aux) on the
Main Toolbar. The currently shown volume will be surrounded by double asterisks in the title bar, and its
value in the Tool WIndow is shown in double asterisks. If only the Main volume is loaded, asterisks will
not be displayed. 

You can go to a specific location in the volume by using the Tools, Goto Point... command, or by typing
the coordinates into one of the fields in the Tools Window where the coordinates are displayed and
pressing the return key. 

1.2 Display transform 

Display transforms can be applied to each volume to transform its position. This transform only affects the
way the volume is drawn in the Display Window. All coordinates displayed in the Tools Window will not
be affected by this transform. 

The file must be an LTA (*.lta) or XFM (*.xfm) transform type. To load a transform for the Main volume,
choose File, Transforms, Load Transform for Main Volume... from the menu and enter the file name of
the transform. To unload it, choose File, Transforms, Unload Transform for Main Volume. There are
corresponding items for the Aux volume. 

1.3 Display options 

Volume display in tkmedit is pretty basic, but there are options for configuring the brightness and contrast
of each volume. Choose View, Configure, Brightness / Contrast... to open a dialog with four sliders. The
top two control the brightness and contrast of the Main volume and the bottom two the Aux volume. 



You may also turn off the volume display by unchecking View, Anatomical Volume. This is useful if you
want to look at other types of data with the anatomical volume in the background. Neither the Main nor
Aux volume will be displayed if this item is not checked. 

You can display a maximum intensity projection by checking the View, Maximum Intensity Projection
item. This displays the voxel with the highest value in the current orientation, and is the same for every
slice in an orientation. 

1.4 Editing 

Editing is done with the Edit Tool which can be activated by pushing the  button in the Main Toolbar,
by choosing Tools, Edit Voxels, by pressing the ’a’ key. 

There are settings for two ’colors’ for this tool, each bound to a button when this tool is active. These
settings can be choosing Tools, Configure Volume Brush.... This tool, along with the other editing tools,
uses the global brush settings available in Tools, Configure Brush Shape... and in the Reconstruction

Toolbar. These include the shape of the brush (  circular or  square), its radius, and whether or not

it acts in all three dimensions (  ). You can also select whether your edits affect only the Main volume
or both the Main and Aux volumes. (Most users will only want to edit one volume.) If the Main volume is
the only target and even if the Aux volume is visible, the Main volume will still be edited. 

This brush uses a threshold that allows you to specify which voxel values to be affected. This allows you
to change ranges of values in an area to a new value, useful in cleaning up large anatomical areas. 

There are a few other operations you can use to edit the volume. In the Tools, Volume menu there are
commands for Thresholding, Flipping, and Rotating the volume. These are self-explanatory and can be
used to fix misoriented data. These operations only affect the Main volume only. 

The Smart Cut command is designed for removing entire chunks of volume based on the position of the
cursor. It will create a cutting plane perpendicular to the current viewing orientation based on the closest
edge of the window and remove everything from that plane to the edge. For example, if you place the
cursor near the bottom-middle of the screen and activate the command, it will remove everything from the
cursor to the bottom edge. 

1.5 Undoing 

There are three ways to undo an edit. All of them only work with the Main volume, as it is the only one
that can be edited. The first is with the standard Edit, Undo Last Edit menu item. This action will undo the
last edit, and is the quickest and easiest way to undo single edits. 

Another way is to use the Snapshot Volume tool in the Tools, Volume menu. Take a snapshot of the
volume to save a copy of its contents in memory by choosing Edit, Take Snapshot of Volume. To restore
the volume to this state, use the Edit, Restore Volume to Snapshot tool. This method is ideal for making
’milestone’ versions of the the volume state. There are buttons for these commands on the Reconstruction

Toolbar:  for taking a snapshot, and  for restoring to it. 



The third way is to use the Undo Volume. This can be envisioned as a separate volume containing all the
voxels that have been changed. You can view these voxels by checking View, Undoable Voxels; they will
be drawn with a blue highlight. By holding down the shift key and clicking with mouse button 2 with the
Edit Voxel tool active on an undoable voxel in Display Window, you can undo all contiguous undoable
voxels, like an undo flood fill. This is best suited for undoing contiguous areas of voxels. 

1.6 Saving 

After all your careful edits, you will want to save the changes to your data. tkmedit writes anatomical
volumes out as COR- files. Choose File, Save Main Volume to overwrite the original source volume or
File, Save Main Volume As... to specify a new location. You can save the Aux volume with corresponding
commands in the File, Aux Volume submenu. 

1.2. 2.0 Control points

Control points are used in surface construction. Every subject has an associated control.dat file in their
tmp directory; this is the list of control points, in TalairachSpace, that is read in to tkmedit automatically
upon start. 

2.1 Display options 

Control points appear as green cross hairs in the Display Window. They can be turned off by unchecking 
View->Control Points. 

2.2 Making and deleting control points 

Control points can be edited with the Edit Control Points tool, which can be activated by pushing the  
button on the Main Toolbar, by choosing Tools->Edit Control Points, or by pressing the ’c’ key when
the mouse is in the Display Window. 

To make a new control point, click anywhere in the Display Window with mouse button 2. To remove a
control point, click near it with mouse button 3. Button 3 will remove the closest control point to the voxel
clicked, within 3 voxels. 

2.3 Saving 

Whenever a new control point is made, it is automatically written to the control.dat file. However,
removed control points are not removed from the file until you choose File->Save Control Points or quit
normally with the File->Quit command. 

1.3. 3.0 Selections

Selections are also called labels or ROIs. You can read or write selections from and to label files or create
them from within tkmedit. Note that there is only one selection in tkmedit, even though it doesn’t have to
be contiguous. 



3.1 Display options 

Selections are drawn as a green overlay. This overlay can be turned off by unchecking View, Selection / 
Label. 

3.2 Selecting and deselecting 

You can select and deselect voxels with the Select Voxels Tool, which can be activated by pushing the 

 button on the Main Toolbar, by choosing Tools, Select Voxels, or by pressing the ’s’ key. 

This tool is a brush tool, so it uses the global brush settings available in Tools, Configure Brush Shape...
and in the Reconstruction Toolbar. You can think of selecting and deselecting voxels as painting your
selection. To select voxels, use mouse button 2 to draw your selection and button 3 to erase it. 

You can also use a flood fill to select and deselect contiguous areas. Open the configuration dialog box
with the Tools, Configure Flood Select...command. Here, you have options for the making the fill 2D or
3D, settings the source, and the fuzziness and distance parameters. 

Source Volume: Specifies which volume to use when looking for similar voxels, so that the Main,
Aux, or segmentation volumes can be used to look for regions. 

Fuzziness: Determines the level of similarity to consider when finding regions. If it is 0, only voxels
with exactly the same value as the voxel clicked will be set. If it is greater than 0, this is the
maximum value difference from the clicked voxel that a contiguous voxel can have to be considered
in the same region. 

Distance: Determines the maximum size of the region to fill from the clicked voxel. If it is 0, there
will be no distance limit. 

3D: Determines if the fill is in-plane only or will fill in three dimensions. 

Once you have configured your fill, perform it with shift-mouse button-2 or 3; 2 will select an area, and 3
will deselect an area. 

3.3 Saving and loading 

Tkmedit reads and writes label files. This file format is basically a list of points in RAS coordinate space
with some header information. They can be loaded into tksurfer if they intersect with a surface. 

1.4. 4.0 Surfaces

Tkmedit can read and display 3D surface files. The surfaces are intersected with the displayed slices and
drawn overlaid onto the anatomical data. 



4.1 Surface configurations 

There are three possible surface configurations: Main, Original, and Pial. When you first load a surface, it
is read into the Main configuration, and tkmedit looks for the other two configurations with similar names. 

You can manually load in another surface as the Original or Pial configuration. All three configurations
can be displayed at the same time, so you can compare how a surface looks in relation to another one. 

4.2 Loading and unloading 

Use the File, Load Main Surface... command to load in the Main configuration. This will also try and
load Original and Pial versions of this surface. Use the File, Load Surface Configuration... submenu to
load the Original Vertices or Pial Vertices manually. 

Surfaces take up a lot of memory and they some time to intersect and draw. To release these resources
when you are done with a surface, use the File, Unload Surface command. 

4.3 Display options 

Each configuration is drawn in a different color. By default, the Main surface is drawn in yellow, the
Original surface in green, and the Pial surface in red. You can change these colors in the View,
Configure..., Surface... dialog box. You can also configure the width of the line used to draw the surface. 

You can turn off surface display by unchecking the View, Main Surface, View, Original Surface, and 
View, Pial Surface items. You can also hide and show the surfaces with the buttons on the Reconstruction

Toolbar (  Main surface,  Original surface, and  Pial surface). You can display the actual
vertices of the surface by checking the View, Surface Vertices option. 

There are two ways of determining which points to draw when intersecting the surface with the current
slice; by using interpolation, and by using projection. Using interpolation will produce a smoother picture
and a truer view of the surface intersection. However, the vertices that are drawn will be the interpolated
intersection points of an edge and the slice, not the actual vertex. When projection is used, the vertices
drawn will appear in their actual place in-plane. This diagram illustrates the methods better: 



When View, Interpolate Surface Vertices is checked, the interpolation method is used. When it is
unchecked, the projection method is used. 

4.4 Finding and showing vertices 

Tkmedit has a few tools for finding and displaying specific surface vertices. If you know the vertex
number of the vertex you are interested in, you can use the Tools, Surface, Find Main Vertex...
command to enter the number and go to that vertex. Note that if the edge width is smaller than the slice
width, the vertex may be ’embedded’ in the slice and the cursor will not appear right over a vertex. There
are corresponding commands for the Original and Pial surfaces as well. 

You can also have tkmedit find the surface vertex closest to the cursor with the Tools, Surface, Show
Nearest Main Vertex command. The vertex information will be printed to the console. There are
corresponding commands for the Original and Pial surfaces as well. 

1.5. 5.0 Functional volumes

Functional data can be viewed in tkmedit as an overlay onto the anatomical data (or any other volumetric
data) or in a graph, as in a time course. Tkmedit can hold one volume for each purpose in memory at the
same time. The volumes can be the same, i.e. a volume can be viewed as an overlay and as a time course,
or separate. 

5.1 Loading data 

Loading Overlay and Time Course data is similar. Use the File, Load Overlay Data... or File, Load
Time Course Data... command to load in a functional volume. 



You can specify a registration file to use. If you do not, tkmedit will look in the same directory as the bfile
data for a file called register.dat. A registration file is a matrix that defines the translation between
anatomical RAS space and functional RAS space. Tkmedit uses this to align the functional volume with
the anatomical volume. 

The Time Course volume can also have an offset volume. This must be specified from the command line.
See the reference section for details. 

5.2 Overlay 

5.2.1 Display options 

The Overlay is displayed, as implied in its name, as a translucent overlay in the Display Window. Its
default state uses a heat color scale, in which negative values are drawn in blue and positive values are
drawn in red. A threshold is used to limit the values shown and define a color ramp so that more values
close to the maximum or negative maximum are red or blue and values close to the minimum or negative
minimum are yellow or teal. 

The Overlay display can be turned off by unchecking the View, Functional Overlay option. Other aspects
of the Overlay display are configured in the dialog box available in View, Configure..., Functional 
Overlay.... The following options are shown: 

Time Point / Condition: Changes the currently shown time point or condition in the Display Window.
The range is shown in parentheses next to the label. Note that a header file must be present in order to
specify the division of data between time points in conditions, otherwise tkmedit assumes multiple time
points and no conditions. 

Truncate negative / positive values: Check to turn off the display of negative or positive values. 

Reverse values: Check to display negative values in red and positive values in blue. 

Grayscale: Check to use a grayscale color scale instead of the normal blue to red heat color scale. The
lowest, most negative values will be shown in black and the highest, most positive values in white. 

Opaque: Check to make the Overlay opaque. 

Ignore threshold: Check to display all the values in the volume with a linear threshold, disabling the
threshold values. 

Threshold minimum / midpoint / slope: Configures the heat scale display. The minimum is the lowest
value shown. The maximum is defined by ( (1/slope) + midpoint ). 

Note that the Apply button must be clicked for changes to take effect. 

The View, Mask to Functional Overlay option is available to only draw areas of the anatomical volume
that are in the valid space of the Overlay volume. This gives you a better sense of the entire Overlay
volume and how it relates to the anatomical volume. 



5.2.2 Registration 

If enabled, you can use tkmedit to register the Overlay volume, or align the Overlay volume with the
anatomical data. This changes the registration file. Use the Tools, fMRI, Register Functional Overlay
command to bring up a dialog box containing arrow buttons. Use these buttons along with the associated
parameters to move the Overlay volume. 

You can save your changes to the registration file with the File, Save Overlay Registration item. You
can restore the registration to its original state with the Tools, fMRI, Restore Overlay Registration. Use
the Tools, fMRI, Set Registration to Identity command to set the registration matrix to the identity
matrix. 

Note that since registration can affect the validity of any data analysis you perform, the MGH-NMR
processing stream only allows registration at a specific point in the stream. Registration may not be
available at all times. It can be enabled from the command line at start-up time. See the reference section
for details. 

5.3 Time course 

5.3.1 Graph 

The Time Course is displayed in a separate graph window. The graph will only be shown if the Time
Course volume has more than one time point. Clicking on a voxel in the Display Window finds the
corresponding functional voxel based on the registration and displays the values at that voxel for all time
points in the graph window. 

If there are multiple conditions defined in the header file, each condition will show up as a separate line in
the graph. The legend on the right side of the graph window displays what line corresponds to what
condition. By moving the mouse over a condition label in the legend, the corresponding line in the graph
will be highlighted. This is useful for picking out one condition in a crowded graph. 

You can also zoom into the graph. Click and drag with button 2 to draw a box around the area of interest.
The graph will be resized around that box. Click with button 3 to zoom back out. 

If the same volume is being used for the Overlay and the Time Course, clicking in the graph window will
change the time point in the Overlay display to what x point was clicked. You can use this method to
navigate the Overlay volume. 

The selection / label can be used to specify an average area to graph. To graph a selection / label as an
average, draw or load a selection and choose Tools, fMRI, Graph Current Selection. The title at the top
of the graph will change to show that a selection is being graphed instead of a single voxel. The contents
of a selection can be printed to a text file in a chart form with the Tools, fMRI, Print Time Course
Summary to File... command. You can use this data in a separate graphic program. 

The contents of the graph window can be written to a Postscript file with the Tools, fMRI, Save Time
Course Graph to Postscript File... command. It can then be included in another document or printed. 



5.3.2 Display options 

The graph can be configured with the View, Configure..., Time Course Graph dialog box. The top part
of this dialog is a list of mappings between colors and conditions. You will see as many rows as the Time
Course volume has conditions. You can assign a color to each condition with the number field on the right
or hide colors / conditions with the checkbox on the left. By default, condition 0 is hidden. You can also
enter a name for the color in the column on the left. This name will show up in the graph window in the
legend on the right. 

The bottom part has the following options: 

Show error bars: If this box is checked and error data is present, vertical errors bars will be drawn at
each data point, signifying the possible error for each value. 

Automatically size graph: If checked, the graph axes will automatically resize according to the range of
values. If unchecked, the axes will stay static. 

Subtract pre-stim average: If checked, the average value of the values before the stimulus (time second
= 0) for each condition is subtracted from all values. This effectively adjusts the y axis to normalize for
pre-stim values. 

Show percent change: If an offset volume is available, this will show the percent change for each value
instead of the raw value itself. 

Number of pre-stim points: Originally defined by the header file, this value lets you adjust the time = 0
value. 

Time resolution: This is defined by the header file and is used to calculate how many seconds are in each
time point. 

Note that the Apply button must be clicked for changes to take effect. 

1.6. 6.0 Segmentations

A segmentation is a volume whose values represent an index of an anatomical structure or label to which
the corresponding voxel in the main anatomical volume belongs. The structures are listed in a lookup
table. This table also specifies the colors the structures should appear in, and is more commonly called a
color table. 

6.1 Loading 

Both a volume and a color table must be loaded to view a segmentation. A segmentation data file is treated
the same as a normal anatomical volume, so it can be a COR- volume or any other supported file type. The
color table assigns a name and color to each index. You can load both items by choosing File, Load 
Segmentation.... 



You can create a new segmentation with the File, New Segmentation... command. You will still need to
enter a color table to use. 

You can import a surface annotation with the File, Import Surface Annotation as Segmentation...
command. A surface annotation is a segmentation of the surface, so that every vertex in the surface has an
associated label. Tkmedit will look up the corresponding voxel for each vertex and assign the label value
to that voxel in a new segmentation. 

Like the anatomical volumes, tkmedit can have a Main or Aux segmentation. Each can have its own color
table. To load Aux segmentations use the commands in File, Aux Segmentation. As with the anatomical
volumes, only the Main segmentation volume can be edited. 

6.2 Display options 

Segmentations are drawn as a colored overlay in the Display Window. The colors are defined in the color
lookup table file specified at load time. The opacity of the overlay can be configured in the dialog box
brought up by choosing View, Configure..., Segmentation Display.... overlay can be hidden by
unchecking View, Segmentation Overlay. You can toggle between the Main and Aux segmentations with
the View, Aux Segmentation Overlay command. 

If the Segmentation Label Volume Count option in the View menu is checked, when the Edit
Segmentation tool is active and the left button is used to set the cursor, tkmedit will count the number of
contiguous voxels in the label clicked and display the result in the Cursor Information area in the Tools
Window. This operation may take anywhere from 1 to 10 seconds depending on the size of the label
clicked, so be aware that tkmedit may seem unresponsive for this length of time after setting the cursor
with this option activated. 

6.3 Editing 

A segmentation can be edited with the Edit Segmentation tool, which can be activated by pushing the 

 button on the Main Toolbar, by choosing Tools, Edit Segmentation, or by pressing the ’g’ key. 

By clicking with button 2 with this tool, you can ’paint’ a label in the segmentation. The color used can be
set in the dialog box brought up by choosing Tools, Configure Segmentation Brush.... This tool is a
brush tool, so it uses the global brush settings available in Tools, Configure Brush Shape... and in the
Reconstruction Toolbar. Clicking with button 3 will ’erase’ segmentation labels (by setting the label
values to 0). 

The painting function is similar to the Edit Voxels tool: the clicked voxel, and those around it depending
on the brush radius, are set to the value specified in the Configure Segmentation Brush dialog. Clicking
on a voxel with button 2 and the control and shift key held down will set the current painting color to the
color of the clicked voxel. Edits can be undone with the Edit, Undo Last Edit menu item. 

A flood fill is also available, activated by shift-clicking mouse button 2 or 3. This tool fills areas with
values equal to or similar to the voxel clicked. It looks for contiguous areas in the source volume to fill in
the segmentation with the selected color. It is configured in the Configure Segmentation Brush dialog. It
has parameters for 3D, the source volume, fuzziness, distance. 



Source Volume: Specifies which volume to use when looking for similar voxels, so that the Main, Aux,
or segmentation volume can be used to look for regions. Fuzziness: Determines the level of similarity to
consider when finding regions. If it is 0, only voxels with exactly the same value as the voxel clicked will
be set. If it is greater than 0, this is the maximum value difference from the clicked voxel that a contiguous
voxel can have to be considered in the same region. Distance: Determines the maximum size of the region
to fill from the clicked voxel. If it is 0, there will be no distance limit. 3D: Determines if the fill is in-plane
only or will fill in three dimensions. 

A fill can be undone with the Edit, Undo Last Edit menu item. 

6.4 Saving 

To save changes to a segmentation, choose File, Save Segmentation to overwrite the original
segmentation volume or File, Save Segmentation As... to specify a new directory in which to write the
COR- volume. 

1.7. 7.0 DTI

Diffusion Tensor Images can be viewed as an overlay. The red, blue, and green colors represent the
direction of the vectors. 

7.1 Loading 

DTI volume data sets consist of two volume: a three frame eigenvector volume (EV volume) and a
fractional anisotropy volume (FA volume). These must be specified in the File, DTI, Load DTI 
Volumes... dialog box. There will be a considerable delay while loading DTI volumes as tkmedit does
some pre-processing. 

The eigenvector volume describes the directionality of diffusion in a particular direction (with the first EV
being the direction of greatest mean diffusion within each voxel), and the FA volume describes how
homogeneous the diffusion is in a particular direction (high values mean that diffusion is primarily
occurring in a single direction- and FA is calculated from something like the variance of the three
eigenvalues). 

7.2 Display options 

Head points are displayed in full color. The red, green, and blue spectrums represent the directionality of
the EV volume. The opacity of the overlay can be configured in the dialog box brought up by choosing 
View, Configure..., DTI Display.... The overlay can be hidden by unchecking View, DTI Overlay. 

1.8. 8.0 Head points

Head points data represent the location sensors during an MEG/EEG scan. 

8.1 Loading 



Head points data consist of two files: a list of points and their labels, and a transform file. These must be
specified in the File, Load Head Points... to load head points data. 

8.2 Display options 

Head points are displayed as green diamonds in the Display Window. They can be hidden by unchecking 
View, Head Points. You can select a head point by clicking near it. The selected head point is drawn in
red and its label is shown in the Tools Window. 

When you are viewing the maximum intensity projection (by checking View, Maximum Intensity 
Projection), you will see all the head points. Note that in this view you can select head points in all
planes, not just the current one. 

8.3 Editing 

You can edit the label of the currently selected head point by choosing Tools, Head Points, Edit Current
Head Point Label.... Enter the new name in the dialog box. You will need to click the point again in the
Display Window to see the new name in the Tools Window. 

You can also modify the registration transform. Use the Tools, Head Points, Register Head Points...
command to bring up a dialog box containing arrow buttons. Use these buttons along with the associated
parameters to move the head points. It is easiest if you do this in the maximum intensity projection view. 

8.4 Saving 

Save changes to the head points labels by choosing File, Save Head Points. Save changes to the
registration transform by choosing File, Save Head Points Transform. Both commands overwrite the
original files. 
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1. Reference

1.1. 1.0 Mouse commands



Mouse Controls for Tools 

Key
Shortcut Button 1 Button 2 Button 3 

Navigation
Tool n 

Clicking and
dragging pans
the view
across the
current slice.
No effect
when the
zoom level is
1. 

Clicking once in the top
half of the window
increases the slice by 1,
clicking in the bottom
decreases the slice.
Dragging up increases
the slice, dragging
down decreases it. 

Clicking once in the top
half of the window zooms
in, clicking in the bottom
zooms out. Dragging up
zooms in continuously,
dragging down zooms
out. 

Select Voxel
Tool s Clicking sets

the cursor.

Clicking adds a voxel to
the selection. Sets the
cursor when the button
is released. Shift+click
performs a flood select.

Clicking removes a voxel
from the selection. Sets
the cursor when the
button is
released.Shift+click
performs a flood deselect.

Edit Voxel
Tool a Clicking sets

the cursor.

Clicking edits a voxel
with the Button 2
settings. Shift+click
undoes a undoable
voxel region. Sets the
cursor when the button
is released.

Clicking edits a voxel
with the Button 3 settings.

Edit
Segmentation
Tool 

g 

Clicking sets
the cursor. If
the ROI
Volume
Count display
option is on,
displays the
ROI volume
in the Tools 
Window.

Clicking paints a
segmentation voxel.
Shift+click performs a
flood fill.
Shift+Ctrl+click sets the
color to the color of the
voxel clicked. Sets the
cursor when the button
is released.

Clicking erases a
segmentation voxel (sets
to label 0). Sets the cursor
when the button is
released. Shift+click
performs a flood erase.

Edit Control
Points Tool c Clicking sets

the cursor. 

Clicking makes a new
control point. Sets the
cursor when the button
is released.

Clicking removes nearest
control point. Sets the
cursor when the button is 
released.



Mouse Controls for Zooming 

Control+Button
1: Zoom in, doubling the zoom level

Control+Button
2: 

When zoomed in, sets the cursor and re-centers the view around the new cursor
without changing the zoom level. 

Control+Button
3: Zoom out, halving the zoom level

1.2. 2.0 Menus

2.1 File 

Load Main Volume... Loads the Main volume from a directory of COR- files.

Load Aux Volume... Loads the Auxiliary volume from a directory of COR- files.

Import Main Volume from 
File... Reads a specified file as the Main volume.

Import Aux Volume from 
File... Reads a specified file as the Aux volume.

Load Transform for Main 
Volume...

Loads an LTA or XFM file to use as the display transform for the Main 
volume.

Load Transform for Aux 
Volume...

Loads an LTA or XFM file to use as the display transform for the Aux 
volume.

Unload Transform for
Main Volume Removes the display transform for the Main volume.

Unload Transform for Aux 
Volume Removes the display transform for the Main volume.

Save Main Volume Saves the Main volume in its original COR- file directory.

Save Main Volume As... Saves the Main volume in a new directory.

Load Main Surface... Loads a surface overlay (e.g. orig.?h, white.?h, pial.?h), looking for
other configurations and loading them available.

Load Surface 
Configuration Loads an alternate (Original or Pial) surface configuration.

Unload Surface Removes the surface and all configurations.

Load Overlay Data... Reads in coregistered functional data for in-plane overlay.



Load Time Course Data... Loads in coregistered functional data for graphing over multiple time 
points.

Save Overlay Registration If registration has been enabled, this will save the registration to the
register.dat file.

Load Segmentation... Loads a segmentation, requiring a COR- file directory and a color
lookup table file.

Save Segmentation Saves the segmentation in its original COR- file directory.

Save Segmentation As... Saves the segmentation in a new directory.

Load Label... Reads in a cortical label file as the selection.

Save Label As... Saves the selection as a cortical label file.

Load Head Points.... Loads a head points transform file and a list of MEG/EEG sensor 
points.

Save Head Point 
Transform Saves an edited head points transform file.

Save Head Points Saves head points.

Save Control Points Saves control points to control.dat file. (Done automatically.)

Quit Exits the program.

2.1.1 Load surface configuration 

Original Vertices Load the Original vertex set for an existing surface

Pial Vertices Load the Pial vertex set for an existing surface

2.1.2 Transforms 

Load Transform for Main Volume... Load a display transform for the Main anatomical volume.

Load Transform for Aux Volume... Load a display transform for the Aux anatomical volume.

Unload Transform for Main Volume Unload a display transform from the Main anatomical volume.

Unload Transform for Aux Volume Unload a display transform from the Aux anatomical volume.

2.1.3 Label 

Load Label... Load a label file and add it to the current selection.

Save Label As... Save the current selection as a label file.



2.1.4 GCA 

Load GCA Load GCA volumes.

Save GCA Save GCA volumes.

Unload GCA Unload GCA volumes.

2.1.5 Head points 

Load Head Points... Load a list of head points.

Save Head Point Transform Save a modified head point transform (overwrites existing).

Save Head Points Save list of head points.

2.1.6 DTI 

Load DTI Volumes... Load DTI volumes.

2.1.7 Edit 

Undo Last Edit Undoes the last volume or segmentation edit.

Take Snapshot of Volume Makes a copy of the current Main volume.

Restore Volume to Snapshot Restores the Main volume to the saved copy.

Clear Label / Selection Clears the current selection.

Clear Undo Volume Clears the Undo Volume.

2.2 View 

View Configurations Shows a submenu of view configurations.

Tool Bars Shows a submenu of available toolbars. Check or uncheck the toolbar in
this submenu to show or hide the toolbar.

Information
Shows a submenu of available information area items such as coordinate
labels. Check or uncheck the item in this submenu to show or hide the 
item.

Configure... Shows a submenu of viewing characteristics that can be configured.

Anatomical Volume Check to display the anatomical volume.

Main Volume Toggle between showing the Main or Aux volume.



Aux Volume

Maximum Intensity 
Projection

Check to display the maximum intensity projection of the current volume,
or the highest values in the current plane for each voxel.

Main Surface Check to display the Main surface configuration.

Original Surface Check to display the Original surface configuration.

Pial Surface Check to display the Pial surface configuration.

Surface Vertices Check to display the surface vertices on top of the surface overlay.

Interpolate Surface 
Vertices

Check to use interpolation to draw surface vertices. Uncheck to use 
projection.

Functional Overlay Check to show the functional overlay volume.

Functional Scale Color 
Bar Check to show the color scale bar for the overlay.

Mask to Functional 
Overlay Check to mask the anatomical volume to valid functional overlay space.

Show Histogram
Percent Change Check to show the window displaying changes in VLI label volumes.

Segmentation Overlay Check to show the segmentation overlay.

Segmentation Label
Volume Count

Check to count the volume of a label in the segmentation when clicking
with the left mouse button when the Edit Segmentation Tool is selected.

Selection / Label Check to show the selection.

Head Points Check to show the head points.

Control Points Check to show the control points.

Cursor Check to show the cursor.

Axes Check to show the coordinate space axes.

Undoable Voxels Check to show the undoable voxels in the Undo Volume.

2.2.1 View configurations 

Single View Displays one pane with a single orientation.

Multiple 
Orientations

Displays four panes, allowing all orientations to be viewed at the same time
around the cursor.

Mosaic Displays a 4x4 grid of different slices in the same orientation.



2.2.2 Tool bars 

Main

Check to display the Main toolbar, which has the following controls: Tool Selector
(Navigation, Select Voxels, Edit Voxels, Edit Segmentation, Edit Control Points),
View Configuration (Single, Multiple, Mosaic), Surface Display (Main, Original,
Pial), Current Volume (Main, Aux)

Navigation
Check to display the Navigation toolbar, which has the following controls:
Orientation (Coronal, Horizontal, Sagittal), Slice number, Zoom Out, Zoom In,
Zoom Level, Save Point, Go To Saved Point, Linked Cursors

Reconstruction
Check to display the Reconstruction toolbar, which has the following controls:
Brush shape (Circular, Square), 3D brush, Radius, Make Snapshot , Restore to
Snapshot, TkTimer on

2.2.3 Information 



Volume Index 
Coordinates Check to show the volume index coordinates (0..255).

Volume RAS 
Coordinates

Check to show the RAS coordinates. The origin is at the center of the 
volume.

Volume Scanner 
Coordinates Check to show the scanner coordinates, usually the RAS coordinates.

MNI Coordinates Check to show the MNI Talairach coordinates. This was the old Talairach
coordinate system, but has been replaced by a slightly modified version.

Talairach Coordinates Check to show the Talairach coordinates, determined by the talairach.xfm
file for a subject. May not be available if this file is missing.

Volume Value Check to show the value of the Main volume voxel.

Aux Volume Value Check to show the value of the Aux volume voxel.

Functional Overlay
Index Coordinates Check to show the functional overlay volume index coordinates.

Functional Overlay RAS 
Coordinates

Check to show the functional overlay RAS coordinates. The origin is at
the center of the functional volume.

Functional Overlay 
Value Check to show the value of the functional overlay volume voxel.

Segmentation Label Check to show the name of the ROI in the Main segmentation that the
voxel is a part of.

Aux Segmentation Label Check to show the name of the ROI in the Aux segmentation that the
voxel is a part of.

Head Point Label Check to show the name of the head point nearest the cursor or mouse.

Surface Distance Check to show the distance from the last cursor location to the present
mouse or cursor location. (Used in setting surface distance values.)

2.2.4 Configure... 



Brightness / 
Contrast...

Opens a dialog box in which you can set the brightness and contrast of the
Main and Aux volumes.

Cursor... Opens a dialog box in which you can change the color and shape of the 
cursor.

Surface... Opens a dialog box in which you can change the color and line width of each
surface configuration.

Functional Overlay... Opens a dialog box in which you can change various characteristics of the
functional overlay.

Time Course 
Graph...

Opens a dialog box in which you can change various characteristics of the
time course graph.

Segmentation 
Display...

Opens a dialog box in which you can change the overlay opacity of the
segmentation display.

DTI Display... Opens a dialog box in which you can change the overlay opacity of the DTI 
display.

2.3 Tools 



Navigate Changes the current tool to the Navigation Tool.

Select Voxels Changes the current tool to the Select Voxels Tool.

Edit Voxels Changes the current tool to the Edit Voxels Tool.

Edit Segmentation Changes the current tool to the Edit Segmentation Tool.

Edit Control Points Changes the current tool to the Edit Control Points Tool.

Configure Brush Info... Opens a dialog box in which you can change the size, shape, and depth of
the brush.

Configure Volume 
Brush...

Opens a dialog box in which you can change the threshold and color values
for the Edit Voxels Tool.

Configure
Segmentation Brush...

Opens a dialog box in which you can change the color and fill settings for
the Edit Segmentation Tool.

Configure Flood 
Select...

Opens a dialog box in which you can change the parameters for the flood
action of the Select Voxels Tool.

Save Point Saves the current cursor so that tksurfer can use its Go To Point function to
go to that point.

Goto Saved Point Sets the cursor to the one last saved in tksurfer for this subject.

Goto Point... Opens a dialog box in which you can enter specific numerical values in
multiple coordinate systems and go to that point.

Volume Opens a submenu of tools and commands for anatomical data.

Surface Opens a submenu of tools and commands for surface data.

fMRI Opens a submenu of tools and commands for to functional data.

Head Points Opens a submenu of tools and commands for EEG/MEG head point data.

Save RGB... Saves the contents of the Display Window to an RGB file.

Save RGB Series... Opens a dialog box in which you can tell tkmedit to automatically scroll
through a series of slices and save their images to RGB files.

2.3.1 Volume 



Threshold 
Volume...

A tool for changing all Main volume values above or below a specific value to a
new value.

Flip Volume... A tool for flipping the Main volume, creating a mirror image.

Rotate Volume... A tool for rotating the Main volume any number of degrees around a main axis.

Smart Cut A tool for setting large sections of the Main anatomical volume to 0. See the
Working With Data section for details.

2.3.2 Surface 

Show Nearest Main 
Vertex

Sets the cursor to the point of the nearest vertex on the Main surface 
configuration.

Show Nearest Original 
Vertex

Sets the cursor to the point of the nearest vertex on the Original surface 
configuration.

Show Nearest Pial Vertex Sets the cursor to the point of the nearest vertex on the Pial surface 
configuration.

Show Nearest Main
Surface Edge

Sets the cursor to the point of the nearest interpolated vertex on the Main
surface configuration.

Show Nearest Original
Surface Edge

Sets the cursor to the point of the nearest interpolated vertex on the
Original surface configuration.

Show Nearest Pial
Surface Edge

Sets the cursor to the point of the nearest interpolated vertex on the Pial
surface configuration.

Find Main Vertex... Opens a dialog in which you can enter a vertex index on the Main
surface. The cursor will be set to that index.

Find Original Vertex... Opens a dialog in which you can enter a vertex index on the Original
surface. The cursor will be set to that index.

Find Pial Vertex... Opens a dialog in which you can enter a vertex index on the Pial surface.
The cursor will be set to that index.

Set Vertex Distance at 
Cursor

Sets the value in the Surface Distance information field for the closest
vertex in the Main surface.

Average Vertex 
Positions...

Opens a dialog in which you can execute a command to average surface
vertex positions in the Main surface.

2.3.3 fMRI 



Select Contiguous Voxels
by Func Value

Selects contiguous voxels to the cursor whose corresponding functional
values are greater than or equal to the functional value at the cursor.

Select Contiguous Voxels
by Threshold

Selects contiguous voxels to the cursor whose corresponding functional
values are greater than or equal to the minimum functional threshold 
value.

Select Functional Voxel Selects an entire functional voxel.

Register Functional 
Overlay...

A tool for aligning (registering) the functional overlay data with the
anatomical data.

Restore Overlay 
Registration Restores the overlay registration to its original value.

Set Registration to 
Identity

Sets the overlay registration matrix to the identity matrix, removing all 
transformations.

Graph Current Selection Graphs the average of all voxel values in the selection in the Time
Course graph window.

Print Time Course
Summary to File...

Creates a file containing a table version of the time course information
for the current voxel or selection.

Save Time Course Graph
to Postscript File...

Saves the contents of the Time Course graph window to a Postscript file
suitable for printing or including in other documents.

2.3.4 Segmentation 

Select Current Label Selects all the anatomical voxels in the segmentation label under the cursor.

Recompute 
Segmentation

Recomputes the Main segmentation using the Main anatomical volume and
the GCA volume.

Graph Current Label 
Average

Graphs the average time course for all the anatomical voxels in the
segmentation label under the cursor. Only works with a time course loaded.

2.3.5 Head points 

Restore Head Points Restores the head points registration to its original value.

Edit Current Head Point Label... Edits the label of the head point closest to the cursor.

Register Head Points... A tool for aligning the head point data with the anatomical data.



1.3. 3.0 File name substitution

Whenever a file name is required to load or save data, the following system is used. First, on startup,
tkmedit attempts to acquire a User Home Directory and a Subject Home Directory. The User Home
Directory is always the current directory from which tkmedit was launched. The Subject Home Directory
is based on the way in which the anatomical data was loaded. If the default tkmedit loading method is
used, it is the concatenated contents of $SUBJECTS_DIR and the subject name. If the -f switch is used, it
is the value of that parameter. 

If the first character of the file name is ~ (tilde) or . (period), it is substituted with the Subject Home
Directory or User Home Directory, respectively. If the first character is another alphanumeric character, a
default location directory is prepended to the file name. If the first character is / (slash), it is left alone.
This behavior is summarized below: 

If the first character of FILENAME is.... The final file name is...

~ (tilde) SubjectHomeDir/FILENAME

. (period) UserHomeDir/FILENAME

/ (slash) FILENAME

other character SubjectHomeDir/Subdirectory/FILENAME

...where FILENAME is the file name that was input. 

The subdirectory used in the last substitution depends on the file type being loaded, and is appropriate for
the standard NMR center directory structure. These are: 



Data Type Subdirectory

Functional data fmri

Head Points bem

Surface surf

Anatomical mri

ROI/Label label

RGB image/rgb

Control Points (control.dat) tmp

Edit (edit.dat) tmp

Segmentation mri

Color Table $CSURF_DIR

Label label

Anatomical Transform mri/transforms

1.4. 4.0 Command line options

4.1 Script 

To automatically run a script, use the -tcl option, passing a script name. Tkmedit still requires anatomical
data to be loaded before doing anything. 

tkmedit -tcl SCRIPT_NAME 

4.2 Anatomical volume 

There are two ways to load anatomical data from the command line. The first is the default tkmedit mode
for loading COR- volumes. 

tkmedit SUBJECT IMAGE_TYPE 

Where SUBJECT is a subject directory relative to the value of the SUBJECTS_DIR environment variable,
and IMAGE_TYPE is a subdirectory of ${SUBJECTS_DIR}/<subject name>/mri. i.e. 

tkmedit <subject name> T1 

looks in ${SUBJECTS_DIR}/<subject name>/mri/T1. If there is a COR- volume in this directory, or
another kind of readable data, it will be loaded as the Main anatomical volume. 



Another way to load anatomical data is with an explicit path or file name using the -f switch: 

tkmedit -f PATH/TO/DATA/[FILENAME] 

This method looks in the given directory or file for any recognizable data. It will be loaded as the Main
volume. 

The Aux volume can be loaded with the -aux switch, i.e. 

tkmedit <subject name> T1 -aux wm 

This looks in ${SUBJECTS_DIR}/<subject name>/mri/wm for a COR- volume. 

Note that tkmedit will not load without specifying a Main anatomical volume with the subject/image type
method or the -f method. 

4.3 Surface 

To load a surface from the command line, add the name after the subject: 

tkmedit <subject name> IMAGE_TYPE SURFACE 

or 

tkmedit -f /path/to/volume/data SURFACE 

4.4 Functional volume 

Overlay data is loaded with the -overlay switch and time course data with the -timecourse option, with the
concatenated path and stem as the argument i.e.: 

tkmedit -overlay DATA_DIRECTORY/STEM -timecourse DATA_DIRECTORY/STEM 

where STEM is the portion of the bfloat file data that comes before the _xxx slice number. i.e. the stem of
a file set named minsig_000.bfloat through minsig_015.bfloat is minsig. 

To enable functional registration, pass -register on the command line with no arguments. 

To specify a registration file that is not in the same directory as the functional volume, use the
-overlay-reg or -timecourse-reg option with the registration file as the argument, i.e: 

tkmedit -overlay DATA_DIRECTORY/STEM -overlay-reg /PATH/TO/REGISTRATION_FILE.DAT 

To load an offset volume for the Time Course volume, specify it the same way as the Time Course volume
but with the -timecourse-offset switch: 

tkmedit -timecourse-offset DATA_DIRECTORY/STEM 



4.5 Segmentation 

Use the -segmentation switch to load a COR- volume representing a segmentation. A color file is also
necessary. 

tkmedit -segmentation COR_DIRECTORY COLOR_FILE 

The COR_DIRECTORY is the directory of the COR- files and the COLOR_FILE is the file to use as a
color lookup table. 

You can specify the opacity of the segmentation overlay with the -segmentation-opacity option: 

tkmedit -segmentation COR_DIRECTORY COLOR_FILE -segmentation-opacity 0.6 

4.6 Head Points 

Use the -headpts switch to load a head points file. This is a file of points indicating MEG/EEG sensor
placement. A transform file is also required and can be specified on the command line. 

tkmedit -headpts POINTS_FILE TRANSFORM_FILE 

1.5. 5.0 Crash recovery

If tkmedit segfaults (makes a memory access violation), and it will, and the user has edited the Main
volume, the volume will be saved in the /tmp directory. This can be reloaded by loading the volume from
that directory, i.e. 

tkmedit -f /tmp 
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1. Tksurfer interface
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1. General usage

1.1. 1.0 Quick start

Tksurfer can be started in any of three ways: launching it from FreeSurfer with the Surface button, using
the tksurfer-sess script, and calling it from the command line. Depending on which method you use, you
may see different types of data loaded, but all methods require a surface data set to be loaded. Other types
of data can be loaded from the File menu. 

To explore your data, you can move the mouse over the picture of the surface (the Display Window) and
see information about the area under the mouse in the window on the bottom (under the Mouse section of
the tksurfer Tools Window). You can change the view with the navigation buttons (under the toolbar, with
icons of various arrows). To save pictures of your data, go to the Tools menu and select the Save RGB
As... item near the bottom. 

By default, tksurfer does not redraw the display window unless you perform a command that changes the
view. This means that if another window obscures the display window and then is moved, the display
window will not automatically update. This because of the time it takes to redraw an average surface. To
explicitly redraw the view, just click on the Redraw button. 

1.2. 2.0 Viewing area

Tksurfer consists of two windows. The top window, called the Display Window, shows the currently
loaded surface and its overlays. The bottom window, called the Tools Window, contains controls and
feedback information. Here is the interface. 

Information about the currently displayed data can be obtained by moving the mouse over the Display
window or by clicking to select a vertex. As the mouse is moved in the display window, the Mouse section
of the Tools window will display information about the vertex under the tip of the Mouse arrow.
Information about the vertex clicked on is displayed in the Cursor section. 

The view is configured with various dialog boxes and options available from the View menu. From this
menu, you can configure the toolbars and labels available in the Tools window, various aspects of the
surface, curvature, and overlays, and the time course graph window. 

1.3. 3.0 Navigation

Tksurfer displays the surface in a 3D environment. You may move the surface with the buttons in the
movement area of the Tools window. 



The buttons in the left section rotate the hemisphere, the ones in the middle translate it, and the ones on the
right zoom in and out. The sliders adjust the number of degrees of each movement. You can also zoom in
and out by holding down the control key and clicking with button 1 or 3. Button 1 zooms in, and button 3
zooms out. The vertex you click becomes the center vertex in the new view. 

1.4. 4.0 Cursor and marked vertices

Clicking on a vertex sets the cursor. The edges touching the vertex are drawn in a cyan color. 

The cursor is drawn every time the mouse is clicked without redrawing the whole window. However,
clicking also marks vertices, adding each clicked vertex to a list of marked ones. These are drawn in a
white color, but only show up after the screen is redrawn. This screen shot shows two marked vertices and
the cursor, at normal zoom level and zoomed in. 

To see this behavior, start tksurfer with any subject and surface. Click with button 1 on the surface and see
the cyan cursor appear. Now press the Redraw button (or type Alt+R while the mouse is in the display
window) and see the white highlight under it. Now click around some more without hitting redraw and see

the cyan cursor move. Now press Redraw  , and see how all the points you previously clicked are
drawn in white. 

Most tools require at least two marked vertices, and some as many as four. The icons for the cut tools give
hints as to how many you need. To clear the marked vertices (unmark them), click with button 3. Note that
the white highlights will not disappear until Redraw is pressed. 
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1. Working with data

1.1. 1.0 Surfaces

Tksurfer holds one main surface. This surface structure has the surface vertex information as well as other
information related to the surface, such as additional values for each vertex. Tksurfer can also hold four
more surface configurations. These are additional sets of vertex information and locations, but not the
other surface information. These configurations are called Inflated, White, Pial, and Original Vertices. 

1.1 Loading surfaces 

The main surface must always be loaded. To load more configurations, use the File->Load Surface 
Configurations... submenu. You can also load a different main surface configuration in this menu. This
will replace the main vertex information but not the other surface information. 

1.2 Surface display options 

You can select the currently shown surface configuration with the View->Surface Configuration
submenu. Only loaded configurations will be available. 

You can enable a wireframe overlay with the View->Wireframe Overlay option. This will draw the
surface polygon edges in blue, so you can see exactly where the edges and vertices are. 

1.3 Surface related tools 

There are four tools available to cut surfaces. These tools are available in the Tools menu and in the Main

toolbar. The Cut Line tool (  ) calculates a line along all the marked vertices in the order that they were

marked and cuts the vertices on that line. The Cut Closed Line tool (  ) does the same, but closes the
line from the last marked vertex to the first. In the graphics below, the first image shows some marked
vertices. The second shows the results after a Cut Line action, and the third shows the results after a Cut
Closed Line action. 

The Cut Plane tool requires exactly four marked vertices. The first three define three points on the plane
and the fourth defines a point inside the plane. This image shows this process. The surface image has been
scaled down to show that the entire surface has been cut away in the second image. 



The Cut Area tool is used to cut away one incontiguous area from another. Click in the area you wish to
keep and perform the action. The other area will be cut. All cut vertices can be restored with the Clear
Cuts tool. 

1.4 Saving surfaces 

Some tools and other functions change the surface vertex information. Other tools change the vertex
values and other information. To save these changes to the surface, use the File->Save Surface option to
overwrite the original surface file and File->Save Surface As... to save it a new location. Note that this
does not save the extra surface configurations; these are not part of the main surface structure. 

1.2. 2.0 Curvature

2.1 Loading curvature files 

Use the File->Curvature->Load Curvature... item to load a curvature file. 

2.2 Curvature display options 

The curvature is displayed as either a green/red color scale or a binary gray background. When no overlay
is displayed, the green/red color scale is used. When an overlay is active, the simpler gray is used. 

The View->Configure->Configure Curvature Display dialog box allows you to set the midpoint and
slope of the curvature color scale. This affects both the green/red and the gray display. 

2.3 Saving curvature files 

Use the File->Curvature->Save Curvature to save the curvature values and overwrite the original file,
or File->Curvature->Save Curvature As... to save a new curvature file in a new location. 

1.3. 3.0 Overlay

An overlay is a set of values, 0 or 1 per vertex, displayed with a color scale. It is normally used as a
functional activation overlay, but can really be any floating point value per voxel. The source volume can
be a .w file, a file containing one value per vertex, previously registered with the volume. It can also be a
binary volume or bfile. These are volumes of short integers (.bshort) or floating point values (.bfloat) with
a corresponding registration file. Binary volumes can contain multiple time points and conditions. 



Overlays can be loaded into any of five layers. Tksurfer can display one overlay layer at a time. 

3.1 Loading overlay files 

To load an overlay file, use the File->Load Overlay... item. You will be prompted for the overlay file
name and the layer in which to load the file. Chose the .w file or a .bshort or .bfloat file if you are loading
a binary volume. 

If you are loading a binary volume, you will be prompted for the stem of the volume and a registration
file. You may leave the registration file field blank if there is a registration file in the same directory as the
binary volume named "register.dat." 

3.2 Overlay file display options 

To select which overlay to show, use the View->Overlay Layer submenu. The field names are
automatically set to the file name loaded. You can change this name by typing a new one into the
information area in the Tool window. 

The display for the current overlay can be configured in the View->Configure->Configure Overlay 
Display dialog. If the data you have loaded has multiple time points or conditions, you can select which
one to show with the Time Point and Condition fields. You can select the color scale to use with the
radio buttons in the top area of the dialog. The Truncate option can be checked to turn off the display of
negative values. Check the Reverse option to reverse the sign of the values as they are drawn in the color
scale. Inverse and Complex are reserved for future upgrades. Also see SettingTheOverlayColorScale. 

Click the Apply button to see your changes. 

3.3 Saving overlay files 

An overlay can only be written out to a .w file; binary volumes cannot be written from overlays. To write
a .w file, choose File->Save Overlay As..., and choose a file name and layer from the dialog box. 

1.4. 4.0 Time course

The Time Course is a binary volume with multiple time points or conditions. The data is displayed in a
graph so that all time points can be seen for a given vertex. When a vertex is clicked, the corresponding
voxel is found in the binary volume. Tksurfer graphs the data for all time points at the chosen vertex. 

Loading Time Course Volumes Loading binary volume Overlays and Time Course data is similar. Use the 
File->Load Time Course... command to load a time course volume. Tksurfer requires functional volumes
to be in binary volume format. It will look for a header file with the same stem as the slice data or just
guess the dimensions from the bfile. You need to specify the directory of the data, the stem, and
optionally, a registration file. The format of a bfile name looks like this: 

/path/to/data/stem_000.bfloat 
/path/to/data/stem_000.bshort 



The numbers go from 0 to the number of slices minus one. The ’stem’ represents any text that appears
before the underscore before the number in the bfile. 

You can specify a registration file to use. If you do not, tksurfer will look in the same directory as the bfile
data for a file called register.dat. A registration file is a matrix that defines the translation between
anatomical RAS space and functional RAS space. Tksurfer uses this to align the functional volume with
the anatomical volume. 

1.5. 5.0 Time course graph

The Time Course is displayed in a separate graph window. The graph will only be shown if the Time
Course volume has more than one time point. Clicking on a vertex in the Display Window finds the
corresponding functional voxel based on the registration and displays the values at that voxel for all time
points in the graph window. 

If there are multiple conditions defined in the header file, each condition will show up as a separate line in
the graph. The legend on the right side of the graph window displays what line corresponds to what
condition. By moving the mouse over a condition label in the legend, the corresponding line in the graph
will be highlighted. This is useful for picking out one condition in a crowded graph. 

You can also zoom into the graph. Click and drag with button 2 to draw a box around the area of interest.
The graph will be resized around that box. Click with button 3 to zoom back out. 

You can specify an average area to graph in two ways. You can click the vertices you want, marking
them, and then choose Tools->Graph Marked Vertices Avg to graph the average. (Note that loading a
patch marks vertices, so you can also graph the average of a path this way.) You can also load a label and
graph the average of it with the Tools->Graph Label Avg. 

The contents of the graph window can be written to a Postscript file with the Tools->Save Graph to
Postscript File... command. It can then be included in another document or printed. 

1.6. 6.0 Patches

6.1 Loading patches 

Use the File->Patch->Load Patch... item to load a patch file. 

6.2 Saving patches 

Use the File->Patch->Save Patch command to overwrite the original file, or File->Patch->Save Patch 
As... to save a new patch file in a new location. 

1.7. 7.0 Labels

7.1 Loading labels 



Use File->Label->Load Label... item to load a label file. 

7.2 Saving labels 

Use File->Label->Save Label command to overwrite the original file, or File->Label->Save Label As...
to save a new label file in a new location. the current dipole values. 

1.8. 8.0 Field sign

8.1 Loading field sign files 

Use the File->Field Sign->Load Field Sign... command to load a field sign file. 

8.2 Saving field sign files 

Use the File->Field Sign->Save Label command to overwrite the original file, or File->Field Sign->Save
Field Sign As... to save a new field sign file in a new location. 

1.9. 9.0 Field mask

9.1 Loading field mask files 

Use the File->Field Mask->Load Field Mask... item to load a field mask file. 

9.2 Saving field mask files 

Use the File->Field Mask->Save Field Mask command to overwrite the original file, or File->Field
Mask->Save Field Mask As... to save a new field mask file in a new location. 
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1. Reference

1.1. 1.0 Mouse commands

1.1 Mouse clicks 

Button 1 Sets the cursor, drawing it in the new location, and marks the clicked vertex. 

Button 2 Sets the cursor without drawing it in the new location and unmarks the clicked vertex. 

Button 3 Clears marked vertices. 

1.1 Mouse controls for zooming 

Control+Button 1 Zooms in, doubling the zoom level 

Control+Button 3 Zooms out, halving the zoom level 

1.2. 2.0 Menus

2.1 File 



Load Surface... Loads the main surface information, including main surface
configuration. 

Load Surface 
Configuration... Shows a submenu with commands for loading vertex configurations. 

Save Surface Saves the contents of the entire surface structure, overwriting the
original file. 

Save Surface As... Saves the contents of the entire surface structure to a new file. 

Load Overlay... Loads a .w or binary volume file into an overlay layer. 

Save Overlay As... Saves an overlay layer as a new .w file. 

Load Time Course... Loads a binary volume as a time course. 

Curvature Shows a submenu with options for loading and saving. 

Patch Shows a submenu with options for loading and saving. 

Label Shows a submenu with options for loading and saving. 

Field Sign Shows a submenu with options for loading and saving. 

Field Mask Shows a submenu with options for loading and saving. 

Quit Quits tksurfer. 

2.2 Load surface configuration 

Main Vertices Loads the specified vertices from another surface file into the selected surface
configuration. 

Inflated 
Vertices 

White Vertices 

Pial Vertices

Original 
Vertices 

2.3 Curvature 

Load Curvature... Loads a curvature file. 

Save Saves changes to the curvature, overwriting the original file. 

Save Curvature As... Saves the curvature into a new file. 



2.4 Patch 

Load Patch... Loads a patch file. 

Save Patch Saves changes to the patch, overwriting the original file. 

Save Patch As... Saves the patch into a new file. 

2.5 Label 

Load Label... Loads a label file. 

Save Label Saves changes to the label, overwriting the original file. 

Save Label As... Saves the label into a new file. 

2.6 Field sign 

Load Field Sign... Loads a field sign file. 

Save Field Sign Saves changes to the field sign, overwriting the original file. 

Save Field Sign As... Saves the field sign into a new file. 

2.7 Field mask 

Load Field Mask... Loads a field mask file. 

Save Field Mask Saves changes to the field mask, overwriting the original file. 

Save Field Mask As... Saves the field mask into a new file. 

2.8 Edit 

Undo Undoes the cut. 

Unmark All 
Vertices 

Unmarks all vertices. Same as clicking with button 3 in the Graphics
window. 

Clear Label Clears the vertices selected by loading a label. 

2.9 View 



Tool Bars Shows a submenu of available toolbars. Check or uncheck the toolbar in this
submenu to show or hide the toolbar. 

Information Shows a submenu of available information area items such as coordinate labels.
Check or uncheck the item in this submenu to show or hide the item. 

Configure Shows a submenu of viewing characteristics that can be configured. 

Surface 
Configuration 

Shows a submenu of surface configurations. Check one to make the currently
shown configuration. 

Overlay Layer Shows a submenu of overlay layers. Check one to make the currently shown
layer. 

Overlay Check to display the current overlay layer. 

Scale Bar Check to display a scale bar in the window, showing the scale of 10 mm. 

Color Scale Bar Check to display a color bar in the Display window, showing the range of
colors in the current overlay color scale. 

Wireframe 
Overlay Check to display a wireframe view of the surface edges. 

2.10 Tool bars 

Main 
Check to make the Main toolbar visible. This toolbar contains the following controls: Cut
Line, Cut Closed Line, Cut Plane, Cut Area, Clear Cuts, Save Point, Goto Saved Point,
Restore Home View, Redraw View. 

2.11 Information 



Vertex Index Check to show the nearest vertex index. 

Distance Check to show the distance in mm to the reported index. 

Vertex RAS Check to show the RAS coordinates of the vertex. 

Vertex Talairach Check to show the Talairach coordinates of the vertex. 

MRI Index Check to show the anatomical index of the vertex in the anatomical volume
for this subject. 

Vertex Normal Check to show the normal vector of the vertex. 

Spherical X, Y, Z Check to show the spherical coordinates. 

Spherical Rho, 
Theta Check to show the spherical rho and theta. 

Curvature Check to show the curvature value at the vertex. 

Field Sign Check to show the field sign value at the vertex. 

Overlay Layer 1-5 Check to show the overlay layer value at the vertex. 

Amplitude Check to show the value at the vertex. 

Angle Check to show the value at the vertex. 

Degree Check to show the value at the vertex. 

Annotation Check to show the value at the vertex. 

MRI Value Check to show the MRI value at the associated anatomical location for this
vertex. 

Parcellation Check to show the name of the parcellation label of this vertex. 

2.12 Configure 



Lighting... Opens a dialog box in which you can set the lighting parameters for the
scene. 

Overlay... Opens a dialog in which you can change various characteristics of the
overlay display. 

Time Course... Opens a dialog in which you can change various characteristics of the
time course graph. 

Curvature Display... Opens a dialog in which you can change various characteristics of the
curvature display. 

Phase Encoded Data 
Display... 

Opens a dialog in which you can change various characteristics of phase
encoded data display. 

2.13 Surface configuration 

Main Check to make this surface configuration the currently displayed one. 

Inflated 

White 

Pial 

Original 

2.14 Overlay layer 

Overlay Layer 1-5 Check to make this overlay layer the currently displayed one. 

2.15 Tools 

Save Point Saves the current cursor so that tksurfer or tkmedit can use its Goto Saved
Point function to go to that point. 

Goto Saved Point Sets the cursor to the one last saved in tksurfer or tkmedit for this subject. 

Run Script... Executes a tcl script. 

Cut Line Calculates a line between marked vertices and cuts the vertices in that
line. 

Cut Closed Line Same as above, but closes the line between the first and last marked
vertex. 

Cut Plane Requires exactly four vertices to be marked. Cuts the surface but not in
the plane defined by the four vertices. 



Cut Area Requires one marked vertex and two incontiguous surface areas. Cuts the
area that the marked vertex is not in. 

Clear Cuts Removes all cut vertex, restoring the surface to whole. 

Send to Subject... Same as Save Point, but allows you to enter a subject name explicitly. 

Write Decimation... Not functional, reserved for future upgrade. 

Write Dipoles... Writes a file containing the dipole values at each vertex. 

Set Background
Midpoint to Average 

In the curvature colorscale, sets the point at which red transitions to green
to the mean curvature across the whole surface, making the data more
interpretable. 

Fill Stats Marks vertices based on the overlay values surrounding the cursor. 

Fill Curvature Marks the region around each selected vertex that has a similar curvature
to that of the selected curvature. Used for labeling anatomical regions. 

Smooth... Iteratively smooths scalar for a user-selected number of iterations.
Equivalent to convolving with a surface-based gaussian. 

Inflate.... Applies the inflation force for a user-specified number of iterations, to
smooth the surface. 

Swap Surface Fields... 
Intended for use by those who know the internal data structure of the
surface. Opens a dialog box allowing you to specify two surface vertex
fields to swap. 

Clear Curvature Sets the curvature value at each vertex to 0. 

Graph Marked
Vertices Avg Graphs the average of marked vertices in the time course. 

Graph Label Avg Graphs the average of a label in the time course. 

Save Graph to
Postscript File Saves the contents of the time course graph to a Postscript file. 

Save RGB As... Saves the contents of the Display window to an RGB file. 
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40.  topology
41.  topological defect
42.  volume
43.  voxel
44.  white surface
45.  wm volume

1. anatomically derived defect
A topological defect in the cortical surface that arises from a feature of normal neuroanatomy to be
distinguished from defects arising entirely from segmentation errors. See topological defect 

2. artifact
A feature that appears in an image but is not actually present in the imaged object. 

3. average convexity
The signed distance that a vertex moves during the inflation process. 

4. brain volume
The T1 volume after the skull and other non-brain structures have been removed. This volume can be
viewed using tkmedit. 

5. canonical surface
Surface-based atlas constructed from the cortical surfaces of 40 normal individuals (used for
inter-subject averaging). 

6. conversion/averaging

Process of converting and averaging multiple structural acquisitions from the native magnet format
into the native FreeSurfer format (see COR files). 

7. COR files

The native file format used by FreeSurfer to store 3D structural image data. 



8. Euler number

After Leonhard Euler (1707-83). A topological invariant of a surface that can be computed from the
number of edges, vertices and faces in a polygonal tessellation (command mris_euler_number ). The
Euler number of a sphere will equal 2; the Euler number of a surface with n handles is 2 Â 2n. 

9. filled volume
The wm volume after separation of the left and right hemispheres and filling of each hemisphere.
This volume can be viewed using tkmedit. 

10. flattening
Producing a planar (flat) representation of a patch of the cortical surface that has minimal metric
distortion. 

11. gyrus
A fold or convolution of brain tissue (an outward folded region). 

12. hypointensities (wm)
Dark white matter on a T1-weighted image. 

13. hypointensities (non-wm)
Dark gray matter on a T1-weighted image. 

14. inflated surface
The smoothwm surface after inflation. This surface can be viewed using surfer. 

15. inflation
The process of smoothing the cortex while minimizing metric distortion, so that all sulci are fully
visible and surface distances are apparent to visual inspection. 

http://surfer.nmr.mgh.harvard.edu/fswiki/mris_euler_number


16. intensity
Measured amount of magnetic field at a given spatial location, represented by a voxel (higher SNR
signal to noise ratio means voxels will have a higher intensity relative to the background noise, and
appear brighter). 

17. label
A particular region of interest. e.g. in tksurfer the label would be a region of interest in the surface. In
tkmedit a label is a region of interest in the volume. 

18. morphing
Computer graphics technique whereby a mapping is computed that smoothly transforms one image or
surface into another. 

19. morphometrics
The study of geometric properties of the human brain. 

20. motion correction
Processing multiple structural volumes so that the effects of subject movement are minimized. This is
typically done by aligning multiple images/volume to an initial image/volume (see
conversion/averaging). 

21. MRI volume
The three dimensional volumetric data set collected from a MRI scanner. 

22. orig volume
The original MRI volume. This volume can be viewed using tkmedit. 

23. orig surface
The first surface constructed by covering the labeled voxels in the filled volume. This surface can be
viewed using surfer. 



24. pial
Pertaining to the delicate pia mater which envelops the brain (gray matter). Also, the model of the
pial surface (?h.pial). 

25. pial surface
The refined estimate of the gray/CSF boundary (pial surface). This surface can be viewed using
surfer. 

26. region growing process
An algorithm that groups voxels or sub-regions into larger regions. 

27. RF-field inhomogeneities
Spatial variations in the Radio Frequency (RF) excitation pulse. These variations result in changes in
the measured intensity for a given tissue class that are related to the spatial location of the voxel. 

28. segmentation
Labeling of tissue classes from MRI data (e.g. white matter). 

29. smoothing
Process of producing a relatively even and regular cortical surface. 

30. smoothwm surface
The orig surface after smoothing. This surface can be viewed using surfer. 

31. sulcus
A groove or furrow in brain tissue (an inward folded region). 

32. supertessellated icosahedron
Polygonal approximation to a sphere. 



33. T1
Longitudinal relaxation constant. 

34. T1 volume
The MRI volume after intensity normalization. This volume can be viewed using tkmedit. 

35. T1 Weighted Image
A magnetic resonance image where the contrast is predominantly dependent on T1. 

36. T2 Weighted Image
A magnetic resonance image where the contrast is predominantly dependent on T2. 

37. T2
Transverse relaxation constant. 

38. Talairach coordinate
The corresponding location in the Talairach atlas for a given point in a brain that has been
coregistered with the atlas (Talairach et al, 1967). 

39. tessellation
Covering of a surface by repeated use of a single shape. 

40. topology
The properties of a surface related to its connectivity that are unaffected by geometric (i.e. rubber
sheet) transformations. 

41. topological defect
A portion of a surface that results in the surface topology differing from that of a sphere. 



42. volume
A 3-D data set that typically contains either intensity information derived from the original MRI, or
the results of segmenting this data into tissue classes. 

43. voxel

The basic element of an MRI volume (analogous to a pixel in a 2-D image). The volume of a
structural voxel is approximately 1 mm3 . 

44. white surface
The refined estimate of the gray/white boundary. This surface can be viewed using surfer. 

45. wm volume
The brain volume after white matter segmentation. This is also the volume that is manually edited.
This volume can be viewed using tkmedit. 
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